<!DOCTYPE html>
<html lang="en-US">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="pingback" href="https://www.androidpolice.com/wordpress/xmlrpc.php" />
<meta property="og:site_name" content="Android Police" />
<meta name="theme-color" content="#0041C8">
<meta name="supported-color-schemes" content="dark light">

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=3">

<script>
    (function(a,c,d,e){if(!a[c]){var b=a[c]={};b[d]=[];b[e]=function(a){b[d].push(a)}}})(window,'Scroll','_q','do');
    Scroll.config = {
      detected: document.cookie.indexOf("scroll0=") > -1

      // other configuration keys can go here
    };
  </script>
<script async src="https://static.scroll.com/js/scroll.js"></script>


<meta name="monetization" content="$ilp.uphold.com/QYAfJw3AKBgA">

<script>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</script>

<style>
    @import url('//fonts.googleapis.com/css?family=Oswald|Roboto:700,500,400|Roboto+Slab&display=swap');
  </style>

<link rel="shortcut icon" data-primary-favicon="" type="image/png" href="https://www.androidpolice.com/wp-content/themes/ap2/images/favicon-light.png" />
<link rel="shortcut icon" type="image/png" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-114x114.png">
<script>
  var ap_naag_timeset = parseFloat(localStorage['naag-timeset']),
                  ap_naag_expiry  = ap_naag_timeset + 600000,
                  ap_naag_article_count = parseFloat(localStorage['naag-article-count']),
                  naag_d = new Date(),
                  naag_time = naag_d.getTime();

              console.log('APDEBUG ARTICLE COUNT: ' + ap_naag_article_count );</script>
<script>
    if (document.cookie.indexOf("scroll0=") < 0) {
        var ap_scrolluser = false;
    } else {
        var ap_scrolluser = true;
        document.getElementsByTagName('html')[0].classList.add('scrolluser');
        window.disqus_config = function () {
            this.disable_ads = true;
        }
    }
    function ap_write_scroll_script(args){
      if(ap_scrolluser){
        return;
      }
      var script = document.createElement('script');
      for (var prop in args) {
          if (!args.hasOwnProperty(prop)) continue;
          script.setAttribute(prop , args[prop]);
      }
      document.write(script.outerHTML);
    }
  </script>

<script>
    ap_write_scroll_script({
      "data-ad-client" : "ca-pub-8776668743582988",
      "async" : "1",
      "src" : "https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"
    });
  </script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Everything we know (and some things we don&#039;t) about Google&#039;s Pixel 6</title>
<meta name="description" content="Google&#039;s upcoming Pixel 6 looks like a return to form for the company, based on current leaks. In fact, we&#039;ve seen quite a bit when it comes to the new" />
<link rel="canonical" href="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Everything we know (and some things we don&#039;t) about Google&#039;s Pixel 6" />
<meta property="og:description" content="Google&#039;s upcoming Pixel 6 looks like a return to form for the company, based on current leaks. In fact, we&#039;ve seen quite a bit when it comes to the new" />
<meta property="og:url" content="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/" />
<meta property="og:site_name" content="Android Police - Android news, reviews, apps, games, phones, tablets" />
<meta property="article:publisher" content="https://www.facebook.com/AndroidPolice" />
<meta property="article:author" content="https://www.facebook.com/ryne.hager" />
<meta property="article:published_time" content="2021-07-08T15:32:12+00:00" />
<meta property="article:modified_time" content="2021-07-08T15:32:45+00:00" />
<meta property="og:image" content="https://www.androidpolice.com/wp-content/uploads/2021/05/20/PIXEL-6-PRO-5K3-scaled.jpg" />
<meta property="og:image:width" content="2560" />
<meta property="og:image:height" content="1440" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@rynehager" />
<meta name="twitter:site" content="@AndroidPolice" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Ryne Hager">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="11 minutes">
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; Feed" href="https://www.androidpolice.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; Comments Feed" href="https://www.androidpolice.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; Everything we know (and some things we don&#039;t) about Google&#039;s Pixel 6 Comments Feed" href="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/feed/" />
<style type="text/css">
			.mistape-test, .mistape_mistake_inner {color: #E42029 !important;}
			#mistape_dialog h2::before, #mistape_dialog .mistape_action, .mistape-letter-back {background-color: #E42029 !important; }
			#mistape_reported_text:before, #mistape_reported_text:after {border-color: #E42029 !important;}
            .mistape-letter-front .front-left {border-left-color: #E42029 !important;}
            .mistape-letter-front .front-right {border-right-color: #E42029 !important;}
            .mistape-letter-front .front-bottom, .mistape-letter-back > .mistape-letter-back-top, .mistape-letter-top {border-bottom-color: #E42029 !important;}
            .mistape-logo svg {fill: #E42029 !important;}
		</style>
<link rel='stylesheet' id='elasticpress-related-posts-block-css' href='https://www.androidpolice.com/wp-content/plugins/elasticpress/dist/css/related-posts-block-styles.min.css?ver=3.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='wpappbox-css' href='https://www.androidpolice.com/wp-content/plugins/wp-appbox/css/styles.min.css?ver=4.2.1' type='text/css' media='screen' />
<link rel='stylesheet' id='wp-polls-css' href='https://www.androidpolice.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.androidpolice.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='mistape-front-css' href='https://www.androidpolice.com/wp-content/plugins/mistape/assets/css/mistape-front.css?ver=1.3.9' type='text/css' media='all' />
<link rel='stylesheet' id='layout-css' href='https://www.androidpolice.com/wp-content/themes/ap2/stylesheets/layout.css?ver=1624315307' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.androidpolice.com/wp-content/plugins/tablepress/css/default.css?ver=1.13' type='text/css' media='all' />
<style id='tablepress-default-inline-css' type='text/css'>
.tablepress-id-134 .column-2,.tablepress-id-134 .column-3{min-width:105px}
</style>
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/jquery/jquery.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/jquery/jquery-migrate.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/convertkit/resources/frontend/jquery.cookie.min.js?ver=1.4.0' id='jquery-cookie-js'></script>
<script type='text/javascript' id='convertkit-js-js-extra'>
/* <![CDATA[ */
var ck_data = {"ajaxurl":"https:\/\/www.androidpolice.com\/wordpress\/wp-admin\/admin-ajax.php","post_has_tag":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/convertkit/resources/frontend/wp-convertkit.js?ver=1.9.4' id='convertkit-js-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-6275685-2' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'custom_map', {"dimension2":"author","dimension3":"date"} );
gtag('set', 'linker', {"domains":["www.androidpolice.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-6275685-2", {"author":"Ryne Hager","date":"2021\/07\/08 PDT"});
</script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.androidpolice.com/wordpress/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.androidpolice.com/wordpress/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://www.androidpolice.com/?p=790784' />
<link rel="alternate" type="application/json+oembed" href="https://www.androidpolice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.androidpolice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.29.0" /><style type='text/css'>img#wpstats{display:none}</style>
<link rel="amphtml" href="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/?amp">
<style>
.scrolluser .ai_widget {
    display: none !important;
}
</style>

<meta name="flattr:id" content="j099pg">


<script>
  if ((window.matchMedia('(prefers-color-scheme: dark)').matches && localStorage['theme'] != 'light') || localStorage['theme'] === 'dark') {
    document.getElementsByTagName('html')[0].classList.add('ap-dark-theme'); 
  } else {
    document.getElementsByTagName('html')[0].classList.add('ap-light-theme'); 
  }
  </script>
</head>
<body class="post-template-default single single-post postid-790784 single-format-image">

<script type="text/javascript">
  var skimlinks_settings = {
    skimwords_horizontal_distance: 300,
    skimwords_vertical_distance: 300
  };
</script>


<div class="band header hidden-phone">
<div class="container">
<div class="sixteen columns">
<a href="https://www.androidpolice.com"><h1 class="logo">Android Police</h1></a>
<div class='ains ains-1 ains-ap2_header_1 ai-track' data-ai='WzEsMl0=' style=''>
<div class='ai-adb-hide' data-ai-debug='1'>
<style type="text/css">
.ains-ap2_header_1,
.adslot_ap2_header_1 { display: none; }
@media (min-width: 768px) {
  .adslot_ap2_header_1 { display:inline-block; width: 728px; height: 90px;} 
  .band.header .sixteen.columns{
  	display: flex;
  	height: 120px;
  }
  .ains-ap2_header_1{
  	width: 100%;
  	display: flex;
  	align-items: center;
  	justify-content: center;
  }
  .ains-ap2_header_1 .ezoic-ad.box-2{
  	min-height: auto !important;
  	margin: 0 !important;
  }
}
</style>
<div id="ezoic-pub-ad-placeholder-130">
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot_ap2_header_1" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="3439725683"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div></div>
<div class='ai-adb-show' style='visibility: hidden; display: none;' data-ai-tracking='WzI4LDAsImFwMl9oZWFkZXJfMV9hZGIiLCIiLDBd' data-ai-debug='1 <= 28'>
<style type="text/css">
.ap2_header_1_adb img{
max-width: 100%;
}
</style>
<a class="ap2_header_1_adb" href="https://scroll.com/signup?affiliateId=5e2945ebc82069585a19a2bb&utm_source=androidpolice" target="_blank">
<img src="/wp-content/themes/ap2/images/scroll/scroll-72890-1.png" alt="Try Scroll">
</a></div>
</div>
</div>
</div>
</div>
<div class="band nav">
<div class="ap-nav-wrapper">
<div class="container">
<ul class="mobile-nav list-unstyled">
<li class="depth-priority">
<a id="ap-menu-button" href="#" class="menu">
<span class="ap-bar"></span>
<span class="ap-bar"></span>
<span class="ap-bar"></span>
</a>
<a class="search-box-close visible-handheld hidden">
<i class="icon-backarrow"></i>
</a>
</li>
<li>
<a href="https://www.androidpolice.com" id="ap-logo-small">
<i class="icon-ap"></i>
</a>
</li>
<li>
<a id="search-btn-a" class="search-btn depth-priority" onclick="firstIconClick(event)"><i class="icon-search"></i></a>
<div class="search-box" id="search-box">
<form role="search" method="get" id="searchform" action="https://www.androidpolice.com/" autocomplete="off">
<input class="textfield" type="search" name="s" id="s" placeholder="Search" value="" autocomplete="off" />
<input type="hidden" name="order" value="rel" />
<div class="cat-select">
<ul class="cat-ul list-unstyled">
</ul>
</div>
</form>
</div>
</li>
<li class="ap-theme">
<div id="ap-theme-btn" role="button" data-mode="" aria-label="Toggle site theme (auto, light, dark)"></div>
</li>
<li class="ap-new-articles">
<a class="ap-new-articles-btn ap-btn-red" href="#">
<span id="ap-new-articles-num" class="ap-new-articles-num"></span>
<script>
              apNewArticlesNum = document.getElementById("ap-new-articles-num");
              console.log('APDEBUG EL: ' + apNewArticlesNum);
              console.log('APDEBUG ARTICLE COUNT: naag_time = ' + naag_time + ', ap_naag_expiry = ' + ap_naag_expiry);
              if ( !isNaN(ap_naag_article_count) && naag_time < ap_naag_expiry ) {
                apNewArticlesNum.innerHTML = ap_naag_article_count;
                console.log('APDEBUG ARTICLE COUNT: updating content with ' + ap_naag_article_count);
              }
              else {
                console.log('APDEBUG ARTICLE COUNT: DID NOT UPDATE');
              }
            </script>
<span class="ap-new-articles-lable">New<br>Articles</span>
<i class="icon-sort-down"></i>
</a>
</li>
</ul>
<ul id="menu-primary-nav" class="primary-nav ap-panel" role="navigation">
<li id="nav-menu-item-294419" rel="news"><a class='ap-nav-primary' href="https://www.androidpolice.com/news/">News<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294419'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294423" rel="news"><a class='ap-nav-sub' href="https://www.androidpolice.com/news/">Latest news</a></li>
<li id="nav-menu-item-714850" rel="android-11"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/android-11/">Android 11</a></li>
<li id="nav-menu-item-567472" rel="android-10"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/android-10/">Android 10</a></li>
<li id="nav-menu-item-294428" rel="android-os"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/">Android OS</a></li>
<li id="nav-menu-item-747434" rel="chrome-os"><a class='ap-nav-sub' href="https://www.androidpolice.com/chrome-os/">Chrome OS</a></li>
<li id="nav-menu-item-294429" rel="wearables"><a class='ap-nav-sub' href="https://www.androidpolice.com/wearables/">Smartwatches/Wearables</a></li>
<li id="nav-menu-item-294598" rel="android-tv-android-os"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/android-tv-android-os/">Android TV</a></li>
<li id="nav-menu-item-294597" rel="android-auto"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/android-auto/">Android Auto</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/news/'>More News...</a></div></div>
</li>
<li id="nav-menu-item-294420" rel="applications-games"><a class='ap-nav-primary' href="https://www.androidpolice.com/applications-games/">Apps/Games<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294420'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294425" rel="games"><a class='ap-nav-sub' href="https://www.androidpolice.com/applications-games/games/">Games</a></li>
<li id="nav-menu-item-294424" rel="apps"><a class='ap-nav-sub' href="https://www.androidpolice.com/applications-games/apps/">Applications</a></li>
<li id="nav-menu-item-294430" rel="roundups"><a class='ap-nav-sub' href="https://www.androidpolice.com/roundups/">Roundups</a></li>
<li id="nav-menu-item-294431" rel="app-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/app-reviews/">App Reviews</a></li>
<li id="nav-menu-item-294432" rel="game-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/game-reviews/">Game Reviews</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/applications-games/'>More Apps/Games...</a></div></div>
</li>
<li id="nav-menu-item-294421" rel="reviews"><a class='ap-nav-primary' href="https://www.androidpolice.com/reviews/">Reviews<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294421'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294435" rel="reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/">All reviews</a></li>
<li id="nav-menu-item-294434" rel="phone-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/phone-reviews/">Phone Reviews</a></li>
<li id="nav-menu-item-294436" rel="tablet-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/tablet-reviews/">Tablet Reviews</a></li>
<li id="nav-menu-item-294437" rel="wearable-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/wearable-reviews/">Wearable Reviews</a></li>
<li id="nav-menu-item-294433" rel="other-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/other-reviews/">Other Reviews</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/reviews/'>More Reviews...</a></div></div>
</li>
<li id="nav-menu-item-294422" rel="phones-devices"><a class='ap-nav-primary' href="https://www.androidpolice.com/phones-devices/">Devices<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294422'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-535290" rel="google-phones-devices"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/google-phones-devices/">Google</a></li>
<li id="nav-menu-item-294438" rel="samsung"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/samsung/">Samsung</a></li>
<li id="nav-menu-item-761417" rel="oneplus-phones-devices"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/oneplus-phones-devices/">OnePlus</a></li>
<li id="nav-menu-item-294594" rel="lg"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/lg/">LG</a></li>
<li id="nav-menu-item-535291" rel="xiaomi"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/xiaomi/">Xiaomi</a></li>
<li id="nav-menu-item-294440" rel="motorola"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/motorola/">Motorola</a></li>
<li id="nav-menu-item-294441" rel="sony"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/sony/">Sony</a></li>
<li id="nav-menu-item-294595" rel="huawei"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/huawei/">Huawei</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/phones-devices/'>More Devices...</a></div></div>
</li>
<li id="menu-item-294411" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-294411"><a href="https://www.androidpolice.com/news/leak/">Leaks</a></li>
<li id="menu-item-294412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294412"><a href="https://www.androidpolice.com/news/exclusive/">Exclusives</a></li>
<li id="menu-item-294413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294413"><a href="https://www.androidpolice.com/downloads/">Downloads</a></li>
<li id="menu-item-294414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294414"><a href="https://www.androidpolice.com/deals/">Deals</a></li>
<li id="menu-item-294415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294415"><a href="https://www.androidpolice.com/contests/">Giveaways</a></li>
<li id="menu-item-294416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294416"><a href="https://www.androidpolice.com/features/">Features</a></li>
<li id="menu-item-294417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294417"><a href="https://www.androidpolice.com/editorials/">Editorials</a></li>
<li id="menu-item-435701" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435701"><a title="donate" href="https://www.androidpolice.com/subscribe-donate/">Subscribe / Donate</a></li>
<li><a class="tip-us" href="https://www.androidpolice.com/contact">Tip Us</a></li> </ul>
</div>
<div class="ap-panel ap-panel-news">
<div class="container">
<div id="news-slider"></div>
<div class="fs-navigation">
<a href="" class="fs-control fs-control-prev"><i class='icon-caret-left'></i> Prev</a>
<div class="fs-control fs-control-filters disabled">
<span>Posts in the last </span>
<div class="ap-dropdown ap-filter-time">
<a class="ap-dropdown-trigger active" href=""><span>24 Hours</span><i class="icon-sort-down"></i></a>
<ul class="list-unstyled ap-dropdown-content ap-dropdown-content-bottom depth3">
<li><a class="active" href="" data-function="ap_news_updater" data-time="24">24 Hours</a></li>
<li><a href="" data-function="ap_news_updater" data-time="48">48 Hours</a></li>
<li><a href="" data-function="ap_news_updater" data-time="72">72 Hours</a></li>
</ul>
</div>
<span>sorted by </span>
<div class="ap-dropdown ap-filter-criteria">
<a class="ap-dropdown-trigger active" href="#"><span>Hottest</span><i class="icon-sort-down"></i></a>
<ul class="list-unstyled ap-dropdown-content ap-dropdown-content-bottom depth3">
<li><a class="active" href="" data-function="ap_news_updater" data-criteria="hottest">Hottest</a></li>
<li><a href="" data-function="ap_news_updater" data-criteria="latest">Latest</a></li>
<li><a href="" data-function="ap_news_updater" data-criteria="comments">Comments</a></li>
</ul>
</div>
</div>
<a href="" class="fs-control fs-control-next">Next <i class='icon-caret-right'></i></a>
</div>
</div>
</div>
</div>

</div>
<div class="band sub-nav main">
<div class="container">
<div class="sixteen columns">
<nav>
<ul id="menu-quick-menu-1" class="sub-nav"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-294411"><a href="https://www.androidpolice.com/news/leak/">Leaks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294412"><a href="https://www.androidpolice.com/news/exclusive/">Exclusives</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294413"><a href="https://www.androidpolice.com/downloads/">Downloads</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294414"><a href="https://www.androidpolice.com/deals/">Deals</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294415"><a href="https://www.androidpolice.com/contests/">Giveaways</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294416"><a href="https://www.androidpolice.com/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294417"><a href="https://www.androidpolice.com/editorials/">Editorials</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435701"><a title="donate" href="https://www.androidpolice.com/subscribe-donate/">Subscribe / Donate</a></li>
<li class="fl-right"><a class="tip-us ap-btn-red" href="https://www.androidpolice.com/contact" data-lightbox-type="ajax">Tip Us</a></li></ul>
</nav>
</div>
</div>
</div>
<div class="band content main single">
<div class="container" id="ap-body">
<div class="primary column">
<div class='ains ains-2 ains-ap2_header_2 ai-track' data-ai='WzIsMl0=' style=''>
<style type="text/css">
.ains-ap2_header_2 { margin: 0 auto 10px; }
@media (min-width: 599px) { .ains-ap2_header_2 { margin-top: 0px; margin-bottom: 20px } }
@media (min-width: 768px) { .ains-ap2_header_2 { display: none !important; } }
</style>
<div id="ezoic-pub-ad-placeholder-133">
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot adslot_ap2_header_2" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="8936001924" data-ad-format="horizontal" data-full-width-responsive="false"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div></div>
<div class="large-post single post post-790784 type-post status-publish format-image has-post-thumbnail hentry category-google-phones-devices category-leak category-news category-pixel-6 category-rumors tag-everything-we-know tag-leaks tag-pixel-6 tag-pixel-6-pro tag-pixel-6-xl tag-rumors post_format-post-format-image" id="post-790784">
<header class="post-header">
<a class="comment-btn" href="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/#disqus_thread" data-disqus-identifier="790784 https://www.androidpolice.com/?p=790784">0</a><div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div><h2 itemprop="name"><a href="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/">Everything we know (and some things we don't) about Google's Pixel 6</a><div class="subtitle"><a href="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/">Early leaks leave a lot of unknowns</a></div></h2><div class="post-meta">
<a class="author-pic hidden-phone" href="https://www.androidpolice.com/author/ryne-hager/"><img alt='Ryne Hager' src='https://secure.gravatar.com/avatar/b006e235fd93cf5407bf243599dc8c1b?s=50&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/b006e235fd93cf5407bf243599dc8c1b?s=100&#038;d=mm&#038;r=x 2x' class='avatar avatar-50 photo' height='50' width='50' loading='lazy' /></a>
<span class="post-author"><a class="author-name" href="https://www.androidpolice.com/author/ryne-hager/">Ryne Hager</a></span><div class="card card-small card-popup card-author depth3">
<div class="card-inner">
</div>
<div class="card-action"><a href="https://twitter.com/rynehager" class="twitter-follow-button fl-left" data-show-count="false" data-size="medium" data-show-screen-name="false">Follow</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if (!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><a href="https://www.androidpolice.com/author/ryne-hager/" class="card-action-btn fl-right">View All Posts</a>
</div>
</div><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/08 <br>8:32am PDT</time><time class="timeago" title="Jul 8, 2021" datetime="2021-07-08T08:32:12-07:00">Jul 8, 2021</time></span> </div><div class="share-box"><div class="addthis_inline_share_toolbox" data-url="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/" data-title="Everything we know (and some things we don&#039;t) about Google&#039;s Pixel 6"></div><div class="addthis_fallback"><div class="at-share-btn-elements"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F" target="_blank" class="facebook-color"><span class="icon-facebook"></span></a><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F&text=Everything+we+know+%28and+some+things+we+don%27t%29+about+Google%27s+Pixel+6" target="_blank" class="twitter-color"><span class="icon-twitter"></span></a><a href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F&title=Everything+we+know+%28and+some+things+we+don%27t%29+about+Google%27s+Pixel+6" target="_blank" class="reddit-color"><span class="icon-reddit"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 32 32" version="1.1" role="img" aria-labelledby="at-svg-reddit-3" class="at-icon at-icon-reddit"><g><path d="M27 15.5a2.452 2.452 0 0 1-1.338 2.21c.098.38.147.777.147 1.19 0 1.283-.437 2.47-1.308 3.563-.872 1.092-2.06 1.955-3.567 2.588-1.506.634-3.143.95-4.91.95-1.768 0-3.403-.316-4.905-.95-1.502-.632-2.69-1.495-3.56-2.587-.872-1.092-1.308-2.28-1.308-3.562 0-.388.045-.777.135-1.166a2.47 2.47 0 0 1-1.006-.912c-.253-.4-.38-.842-.38-1.322 0-.678.237-1.26.712-1.744a2.334 2.334 0 0 1 1.73-.726c.697 0 1.29.26 1.78.782 1.785-1.258 3.893-1.928 6.324-2.01l1.424-6.467a.42.42 0 0 1 .184-.26.4.4 0 0 1 .32-.063l4.53 1.006c.147-.306.368-.553.662-.74a1.78 1.78 0 0 1 .97-.278c.508 0 .94.18 1.302.54.36.36.54.796.54 1.31 0 .512-.18.95-.54 1.315-.36.364-.794.546-1.302.546-.507 0-.94-.18-1.295-.54a1.793 1.793 0 0 1-.533-1.308l-4.1-.92-1.277 5.86c2.455.074 4.58.736 6.37 1.985a2.315 2.315 0 0 1 1.757-.757c.68 0 1.256.242 1.73.726.476.484.713 1.066.713 1.744zm-16.868 2.47c0 .513.178.95.534 1.315.356.365.787.547 1.295.547.508 0 .942-.182 1.302-.547.36-.364.54-.802.54-1.315 0-.513-.18-.95-.54-1.31-.36-.36-.794-.54-1.3-.54-.5 0-.93.183-1.29.547a1.79 1.79 0 0 0-.54 1.303zm9.944 4.406c.09-.09.135-.2.135-.323a.444.444 0 0 0-.44-.447c-.124 0-.23.042-.32.124-.336.348-.83.605-1.486.77a7.99 7.99 0 0 1-1.964.248 7.99 7.99 0 0 1-1.964-.248c-.655-.165-1.15-.422-1.486-.77a.456.456 0 0 0-.32-.124.414.414 0 0 0-.306.124.41.41 0 0 0-.135.317.45.45 0 0 0 .134.33c.352.355.837.636 1.455.843.617.207 1.118.33 1.503.366a11.6 11.6 0 0 0 1.117.056c.36 0 .733-.02 1.117-.056.385-.037.886-.16 1.504-.366.62-.207 1.104-.488 1.456-.844zm-.037-2.544c.507 0 .938-.182 1.294-.547.356-.364.534-.802.534-1.315 0-.505-.18-.94-.54-1.303a1.75 1.75 0 0 0-1.29-.546c-.506 0-.94.18-1.3.54-.36.36-.54.797-.54 1.31s.18.95.54 1.315c.36.365.794.547 1.3.547z" fill-rule="evenodd"></path></g></svg></span></a><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F&title=Everything+we+know+%28and+some+things+we+don%27t%29+about+Google%27s+Pixel+6" target="_blank" class="linkedin-color"><span class="icon-linkedin"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 32 32" version="1.1" role="img" aria-labelledby="at-svg-linkedin-6" class="at-icon at-icon-linkedin"><g><path d="M26 25.963h-4.185v-6.55c0-1.56-.027-3.57-2.175-3.57-2.18 0-2.51 1.7-2.51 3.46v6.66h-4.182V12.495h4.012v1.84h.058c.558-1.058 1.924-2.174 3.96-2.174 4.24 0 5.022 2.79 5.022 6.417v7.386zM8.23 10.655a2.426 2.426 0 0 1 0-4.855 2.427 2.427 0 0 1 0 4.855zm-2.098 1.84h4.19v13.468h-4.19V12.495z" fill-rule="evenodd"></path></g></svg></span></a></div></div></div></header><div class="categories"><ul class="post-categories list-unstyled"><li><a class="cat cat-google-phones-devices" href="https://www.androidpolice.com/phones-devices/google-phones-devices/" title="View all posts in Google">Google</a></li><li><a class="cat cat-leak" href="https://www.androidpolice.com/news/leak/" title="View all posts in Leaks"><i class="icon-leak"></i>Leaks</a></li><li><a class="cat cat-news" href="https://www.androidpolice.com/news/" title="View all posts in News"><i class="icon-news"></i>News</a></li><li><a class="cat cat-pixel-6" href="https://www.androidpolice.com/phones-devices/google-phones-devices/pixel-6/" title="View all posts in Pixel 6">Pixel 6</a></li><li><a class="cat cat-rumors" href="https://www.androidpolice.com/news/rumors/" title="View all posts in Rumors"><i class="icon-rumors"></i>Rumors</a></li></ul></div><a class="post-hero post-hero-single" href="https://www.androidpolice.com/wp-content/uploads/2021/05/20/PIXEL-6-PRO-5K3-scaled.jpg"><img class="img-hero" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F20%2FPIXEL-6-PRO-5K3-scaled.jpg&w=728" width="728" height="410" loading="lazy" alt="Everything we know (and some things we don&#039;t) about Google&#039;s Pixel 6"></a>
<div class="post-content">
<div class='ains ains-9 ains-ap2_above_post_body ai-track' data-ai='WzksMl0=' style=''>
<style type="text/css">
.ains-ap2_above_post_body { margin: 10px -10px; }
@media (min-width: 540px)  { .ains-ap2_above_post_body { margin: 10px -20px; } }
@media (min-width: 768px)  { .ains-ap2_above_post_body { margin: 10px -15px; } }
@media (min-width: 960px)  { .ains-ap2_above_post_body { margin: 10px -20px; } }
@media (min-width: 1160px) { .ains-ap2_above_post_body { margin: 10px -30px; } }
</style>
<div id="ezoic-pub-ad-placeholder-128">
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot adslot_ap2_above_post_body" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4825925002" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div></div>
<div id="toc_observer"></div><div id="toc_wrapper"><div id="toc_container" class="no_bullets"><div class="toggle icon-list"></div><p class="toc_title">Article Contents</p><ul class="toc_list"><li><a href="#What_will_it_look_like"><span class="toc_number toc_depth_1">1</span> What will it look like?</a><ul><li><a href="#Pixel_6"><span class="toc_number toc_depth_2">1.1</span> Pixel 6</a></li><li><a href="#Pixel_6_Pro_or_XL_mdash_whatever_they_call_the_big_one"><span class="toc_number toc_depth_2">1.2</span> Pixel 6 Pro or XL &mdash; whatever they call the big one</a></li></ul></li><li><a href="#Back_to_two_phones"><span class="toc_number toc_depth_1">2</span> Back to two phones</a></li><li><a href="#What_are_the_specs"><span class="toc_number toc_depth_1">3</span> What are the specs?</a></li><li><a href="#Specs"><span class="toc_number toc_depth_1">4</span> Specs</a></li><li><a href="#Compared_to_the_Pixel_5"><span class="toc_number toc_depth_1">5</span> Compared to the Pixel 5</a></li><li><a href="#How_much_will_it_cost"><span class="toc_number toc_depth_1">6</span> How much will it cost?</a></li><li><a href="#When_will_it_come_out"><span class="toc_number toc_depth_1">7</span> When will it come out?</a></li></ul></div></div>
<p></p>
<p>Google's upcoming Pixel 6 looks like a return to form for the company, based on current leaks. In fact, we've seen quite a bit when it comes to the new phone, both internally and externally, and it looks like it should be the first "true" flagship from the company for two years &mdash; or longer, depending on how you felt about the Pixel 4. Everything's subject to change as we learn more, but here's everything we know about the Pixel 6 so far.</p>
<p><span id="more-790784"></span></p>
<h2><span id="What_will_it_look_like">What will it look like?</span></h2>
<p>We've seen the Pixel 6 a few times in both of its expected sizes. While <a href="https://www.androidpolice.com/2021/05/13/google-pixel-6-and-pixel-6-pro-leak-reveals-a-totally-new-look-and-hardware/">earlier leaks</a> showed off general designs, later leaks seem more accurate with more precise details regarding what we should expect:</p>
<h3><span id="Pixel_6">Pixel 6</span></h3>
<div class="multi-column ap-gallery"><div class="gallery-display"><div class="gallery-arrow left hidden" aria-label="Previous"></div><a class="gallery-display-link active" href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-09.jpeg" data-image-index="0"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-09.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><a class="gallery-display-link" href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-05.jpeg" data-image-index="1"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-05.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><a class="gallery-display-link" href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-012.jpeg" data-image-index="2"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-012.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><a class="gallery-display-link" href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-02.jpeg" data-image-index="3"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-02.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><a class="gallery-display-link" href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-07.jpeg" data-image-index="4"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-07.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><a class="gallery-display-link" href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-03.jpeg" data-image-index="5"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-03.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><a class="gallery-display-link" href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-scaled.jpeg" data-image-index="6"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-5K1-scaled.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><div class="ap-loader"></div><div class="gallery-arrow right " aria-label="Next"></div></div><div class="gallery-slider"><div class="gallery-arrow left hidden" aria-label="Previous"></div><div class="slider-mask"><ul class="gallery-thumbs list-unstyled text-center"><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-09.jpeg" class="gallery-thumb active" data-image-index="0"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-09.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-05.jpeg" class="gallery-thumb" data-image-index="1"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-05.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-012.jpeg" class="gallery-thumb" data-image-index="2"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-012.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-02.jpeg" class="gallery-thumb" data-image-index="3"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-02.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-07.jpeg" class="gallery-thumb" data-image-index="4"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-07.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-03.jpeg" class="gallery-thumb" data-image-index="5"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-03.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-scaled.jpeg" class="gallery-thumb" data-image-index="6"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F21%2FPIXEL-6-5K1-scaled.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li></ul></div><div class="gallery-arrow right hidden" aria-label="Next"></div></div></div>
<p>Both phones in the Pixel 6 series look pretty similar to one another, with Google finally changing the design language it has used for the last two generations when it comes to the back of the phone.</p><div class='ains ains-3 ains-ap2_in_post_body_1 ai-track' data-ai='WzMsMl0=' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<style type="text/css">
@media (min-width: 960px) and (max-width: 1159px)  { .ains-ap2_in_post_body_1 { margin-left: -10px !important; margin-right: -10px !important; } }
</style>
<div class="ap_house_slot">
<div id="ezoic-pub-ad-placeholder-114">
<style type="text/css">
.adslot_ap2_in_post_body_1 {  }
@media (min-width: 599px) { .adslot_ap2_in_post_body_1 {  } }
@media (min-width: 768px) { .adslot_ap2_in_post_body_1 {  } }

</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot adslot_ap2_in_post_body_1" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4273329030" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div></div>
<p>The square camera bump used on the Pixel 4 and 5 has been replaced by a TCL-style camera strip, with the various cameras all set in a line. On the smaller model, that's two cameras plus a flash, with a narrow accent strip just above it and a big, blank, presumably glass panel beneath it.</p>
<p>Recent CAD-based renders indicate a body around 158.6 x 74.8 x 8.9mm, plumping out to 11.8mm at the camera strip, making the "small" Pixel 6 a relatively large phone. For comparison, the Pixel 5 (144.7 x 70.4 x 8mm) is smaller in every dimension by a large margin. By all accounts, the Pixel 6 won't be a "small" phone.</p>
<p>While I'm not sure if leaks are yet so accurate that we can trust precise details like bezel sizing at this early stage, what we've seen clearly shows an edge-to-edge but flat display (reportedly 6.4") with a Samsung-style pinhole camera in the center top. Around the side, the power button and volume button are in the same position they usually are: Next to each other on the right, with the power on top.</p>
<p>There's no visible fingerprint sensor on the back or side, and some leaks claim an in-screen fingerprint sensor may be used. Android 12 is also picking up <a href="https://twitter.com/MishaalRahman/status/1362550786601979905?s=20" class="external" rel="nofollow" target="_blank">native support for in-display fingerprint sensors</a>, which may be an indicator of Google's plans.</p>
<h3><span id="Pixel_6_Pro_or_XL_mdash_whatever_they_call_the_big_one">Pixel 6 Pro or XL &mdash; whatever they call the big one</span></h3>
<div class="multi-column ap-gallery"><div class="gallery-display"><div class="gallery-arrow left hidden" aria-label="Previous"></div><a class="gallery-display-link active" href="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-scaled.jpeg" data-image-index="0"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2FPIXEL-6-PRO-5K1-scaled.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><a class="gallery-display-link" href="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K3-scaled.jpeg" data-image-index="1"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2FPIXEL-6-PRO-5K3-scaled.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><a class="gallery-display-link" href="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K2-scaled.jpeg" data-image-index="2"><img title="" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2FPIXEL-6-PRO-5K2-scaled.jpeg&amp;h=340&amp;zc=2" onload="this.parentNode.classList.add('loaded');"></a><div class="ap-loader"></div><div class="gallery-arrow right " aria-label="Next"></div></div><div class="gallery-slider"><div class="gallery-arrow left hidden" aria-label="Previous"></div><div class="slider-mask"><ul class="gallery-thumbs list-unstyled text-center"><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-scaled.jpeg" class="gallery-thumb active" data-image-index="0"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2FPIXEL-6-PRO-5K1-scaled.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K3-scaled.jpeg" class="gallery-thumb" data-image-index="1"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2FPIXEL-6-PRO-5K3-scaled.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li><li><a href="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K2-scaled.jpeg" class="gallery-thumb" data-image-index="2"><img loading="lazy" alt="" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2FPIXEL-6-PRO-5K2-scaled.jpeg&amp;w=118&amp;h=118" width="118" height="118"></a></li></ul></div><div class="gallery-arrow right hidden" aria-label="Next"></div></div></div>
<p>If you've seen the Pixel 6, then you've seen the bigger <a href="https://www.androidpolice.com/2021/05/20/latest-google-pixel-6-pro-leak-gives-us-our-best-look-yet/">Pixel 6 Pro or XL or whatever it ends up being named</a>. It uses the same overall design language, complete with a Cylon-style camera strip and a center-aligned pinhole camera on the front.</p><div class='ains ains-4 ains-ap2_in_post_body_2 ai-track' data-ai='WzQsMl0=' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<style type="text/css">
@media (min-width: 960px) and (max-width: 1159px)  { .ains-ap2_in_post_body_2 { margin-left: -10px !important; margin-right: -10px !important; } }
</style>
<div class="ap_house_slot">
<div id="ezoic-pub-ad-placeholder-116">
<style type="text/css">
.adslot_ap2_in_post_body_2 {  }
@media (min-width: 599px) { .adslot_ap2_in_post_body_2 {  } }
@media (min-width: 768px) { .adslot_ap2_in_post_body_2 {  } }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot adslot_ap2_in_post_body_2" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4443422252" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div></div>
<p>The key differences between the two versions, based on what we've seen so far, come down to size and the rear camera. As you'd expect, the bigger phone has numerically larger dimensions in most aspects: 163.9 x 75.8 x 8.9mm and 11.5mm at the camera, with a 6.7" screen size. That camera strip also has an extra module compared to the smaller version of the phone. Again, I'd hesitate to offer too much certainty during this early period, but current leaks show that the bigger version has a periscope-style telephoto camera that the smaller model lacks, similar to the Galaxy S20 Ultra and S21 Ultra.</p>
<p>The Pixel 6 Pro also has a larger accented forehead above the camera module on the back.</p>
<h2><span id="Back_to_two_phones">Back to two phones</span></h2>
<p>If the previous section didn't make it clear, leaks indicate that the Pixel 6 will come in two sizes: A smaller model and an XL or "Pro" variant, depending on how Google names things. The two models won't be equals, either, not just outside size.</p>
<p>Much as Samsung and Apple's biggest phones snag a few extra features, the bigger version of the Pixel 6 will have an extra camera module &mdash; current leaks indicate the distinction is a periscope-style telephoto camera, but I'd take that with a small grain of salt at this relatively early stage.</p>
<p style="text-align: center;"><a href="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-scaled.jpeg" class=" no-style"><img loading="lazy" class="wp-image-780470 size-large" src="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-668x376.jpeg" alt="" width="668" height="376" srcset="https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-668x376.jpeg 668w, https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-329x185.jpeg 329w, https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-161x91.jpeg 161w, https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-217x122.jpeg 217w, https://www.androidpolice.com/wp-content/uploads/2021/05/21/PIXEL-6-5K1-728x410.jpeg 728w" sizes="(max-width: 668px) 100vw, 668px"></a></p>
<p style="text-align: center;"><em>Renders of the Pixel 6 (above) and Pixel 6 XL or Pro or whatever (below).</em></p><div class='ains ains-5 ains-ap2_in_post_body_3 ai-track' data-ai='WzUsMl0=' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<style type="text/css">
@media (min-width: 960px) and (max-width: 1159px)  { .ains-ap2_in_post_body_3 { margin-left: -10px !important; margin-right: -10px !important; } }
</style>
<div class="ap_house_slot">
<div id="ezoic-pub-ad-placeholder-117">
<style type="text/css">
.adslot_ap2_in_post_body_3 {  }
@media (min-width: 599px) { .adslot_ap2_in_post_body_3 {  } }
@media (min-width: 768px) { .adslot_ap2_in_post_body_3 {  } }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot adslot_ap2_in_post_body_3" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="3307091090" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div></div>
<p style="text-align: center;"><a href="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-scaled.jpeg" class=" no-style"><img loading="lazy" class="wp-image-790829 size-large" src="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-668x376.jpeg" alt="" width="668" height="376" srcset="https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-668x376.jpeg 668w, https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-329x185.jpeg 329w, https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-161x91.jpeg 161w, https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-217x122.jpeg 217w, https://www.androidpolice.com/wp-content/uploads/2021/07/07/PIXEL-6-PRO-5K1-728x410.jpeg 728w" sizes="(max-width: 668px) 100vw, 668px"></a></p>
<p>There could be other differences in specifications between the two devices as well &mdash; <em>probably</em> screen resolution and battery, favoring the larger model in both cases &mdash; though details are still unknown at this early stage, and it's too early to offer much certainty, only educated guesses.</p>
<p>There's also a <a href="https://www.androidpolice.com/2021/06/28/the-pixel-5a-might-be-just-a-few-weeks-away/">Pixel 5a planned</a> that sounds like a <a href="https://www.androidpolice.com/2020/12/17/pixel-4a-5g-review-this-should-actually-be-called-the-pixel-5-lite/">Pixel 4a 5G</a> with a few upgrades, but it sounds like it's not in the 6-series proper.</p>
<h2><span id="What_are_the_specs">What are the specs?</span></h2>
<p>Again, it's still early, so I hesitate to offer too much in the way of certainty or even speculation regarding specifications for the pair of phones, but we do know a&nbsp;<em>few</em> things.</p>
<div class="primary-widget specs table">
<header class="section-header">
<h2 class="header-bg blue-bg"><span id="Specs">Specs</span></h2>
</header><div class="table-wrapper"><table class="ap-table specs" width="100%">
<tr>
<td valign="top" width="30%" class="column-1">Chipset</td>
<td valign="top" width="70%" class="column-2">Google's first-party Whitechapel chip (2x A78, 2x A76, 4x A55, 5nm node)</td>
</tr>
<tr>
<td valign="top" width="30%" class="column-1">Chipset GPU</td>
<td valign="top" width="70%" class="column-2">Mali-G78 (core-size variant as yet unknown)</td>
</tr>
<tr>
<td valign="top" width="30%" class="column-1">Screen size</td>
<td valign="top" width="70%" class="column-2">6.4" (Pixel 6) and 6.7" (Pixel 6 Pro/XL)</td>
</tr>
<tr>
<td valign="top" width="30%" class="column-1">Cameras</td>
<td valign="top" width="70%" class="column-2">Two on the Pixel 6, three on the Pixel 6 Pro/XL</td>
</tr>
</table></div></div>
<p>Google's long-rumored, long-leaked Whitechapel chip is <a href="https://www.androidpolice.com/2021/04/02/the-pixel-6-could-take-on-the-next-iphone-with-a-custom-google-processor/">likely powering the Pixel 6 series</a>, and we know some things about it. For one, it was built at least partly with Samsung's help, with a handful of machine learning customizations specifically designed by Google. Samsung is also producing the chip at a 5nm node, and it should have a pair of big A78 cores, plus a pair of A76 cores, augmented by four smaller A55 cores.</p>
<p><a href="https://www.androidpolice.com/2021/04/06/what-should-we-expect-from-googles-first-custom-smartphone-chip/">Speaking to analysts</a>, current performance estimates for those specifications place it somewhere under the hot-running flagship Snapdragon 888 but certainly above the Snapdragon 765G used in last year's Pixel 5. We also don't know what modem it might use, though Google would be foolish to launch a phone in 2021 without 5G &mdash; especially the faster mmWave variety. Earlier analyst predictions indicated it could have to use a Qualcomm modem (based on current carrier partnerships and requirements) though it's far from certain. An Exynos modem could also be a possibility.</p><div class='ains ains-6 ains-ap2_in_post_body_4 ai-track' data-ai='WzYsMl0=' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<style type="text/css">
@media (min-width: 960px) and (max-width: 1159px)  { .ains-ap2_in_post_body_4 { margin-left: -10px !important; margin-right: -10px !important; } }
</style>
<div class="ap_house_slot">
<div id="ezoic-pub-ad-placeholder-119">
<style type="text/css">
.adslot_ap2_in_post_body_4 {  }
@media (min-width: 599px) { .adslot_ap2_in_post_body_4 {  } }
@media (min-width: 768px) { .adslot_ap2_in_post_body_4 {  } }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot adslot_ap2_in_post_body_4" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="7013745278" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div></div>
<p style="text-align: center;"><a href="https://www.androidpolice.com/wp-content/uploads/2021/04/06/google-whitechapel-ap.png" class=" no-style"><img loading="lazy" class="size-large wp-image-770009" src="https://www.androidpolice.com/wp-content/uploads/2021/04/06/google-whitechapel-ap-668x376.png" alt="" width="668" height="376" srcset="https://www.androidpolice.com/wp-content/uploads/2021/04/06/google-whitechapel-ap-668x376.png 668w, https://www.androidpolice.com/wp-content/uploads/2021/04/06/google-whitechapel-ap-329x185.png 329w, https://www.androidpolice.com/wp-content/uploads/2021/04/06/google-whitechapel-ap-161x91.png 161w, https://www.androidpolice.com/wp-content/uploads/2021/04/06/google-whitechapel-ap-217x122.png 217w, https://www.androidpolice.com/wp-content/uploads/2021/04/06/google-whitechapel-ap-728x410.png 728w, https://www.androidpolice.com/wp-content/uploads/2021/04/06/google-whitechapel-ap.png 1920w" sizes="(max-width: 668px) 100vw, 668px"></a></p>
<p style="text-align: center;"><em>Whitechapel could be a game-changer for Google &mdash; if not in performance, maybe when it comes to updates.&nbsp;</em></p>
<p>That Google-made chip <em>could</em> also mean a longer software window compared to prior Qualcomm-powered models.</p>
<p>Android 12 indicates <a href="https://www.androidpolice.com/2021/06/14/a-more-powerful-pixel-stand-wireless-charger-might-arrive-alongside-the-pixel-6-this-fall/">Google may be working on a new Pixel Stand</a> that features active cooling. That could be an indicator that faster wireless charging is coming to the new phone. Ultra-wideband support <a href="https://www.androidpolice.com/2021/05/02/googles-next-pixel-phone-could-hop-on-the-ultrawide-bandwagon-with-samsung-and-apple/">may also debut</a> in one of the phones for directional applications. For context, UWB can be used for things like <a href="https://www.apple.com/airtag/" class="external" rel="nofollow" target="_blank">AirTag-like functionality</a> and other object tracking.</p>
<p>Rumors have swirled that Google may finally upgrade the primary camera sensor with the new Pixel series, though precise details to date disagree between sources, most of which lack authority to report on. However, the consistency of the rumors may indicate it is true in broad strokes, and Google may finally be moving from the now quite aged Sony IMX363 to something larger and higher resolution.</p>
<h2><span id="Compared_to_the_Pixel_5">Compared to the Pixel 5</span></h2>
<p>There are still a <em>lot</em> of details we don't know, but compared to last year's model, the new Pixel 6 series sounds like an upgrade across the board, with two potential exceptions.</p>
<p>Last year, fans were disappointed there wasn't an "XL" version of the Pixel 5, save the slightly cut-down Pixel 4a 5G (which was more like a Pixel 5 "lite"). This return to a two-phone series means fans of big screens can consider Pixels again. Hardware specifications may still be mostly unknown outside a few details, but it sounds like Google is returning to a flagship mindset as well, compared to the Pixel 5's slightly downmarket move.</p><div class='ains ains-7 ains-ap2_in_post_body_5 ai-track' data-ai='WzcsMl0=' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<style type="text/css">
@media (min-width: 960px) and (max-width: 1159px)  { .ains-ap2_in_post_body_5 { margin-left: -10px !important; margin-right: -10px !important; } }
</style>
<div class="ap_house_slot">
<div id="ezoic-pub-ad-placeholder-121">
<style type="text/css">
.adslot_ap2_in_post_body_5 {  }
@media (min-width: 599px) { .adslot_ap2_in_post_body_5 {  } }
@media (min-width: 768px) { .adslot_ap2_in_post_body_5 {  } }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot adslot_ap2_in_post_body_5" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="1603127186" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div></div>
<p style="text-align: center;"><a href="https://www.androidpolice.com/wp-content/uploads/2020/10/19/pixel-5-14.jpg" class=" no-style"><img loading="lazy" class="size-large wp-image-717702" src="https://www.androidpolice.com/wp-content/uploads/2020/10/19/pixel-5-14-668x445.jpg" alt="" width="668" height="445" srcset="https://www.androidpolice.com/wp-content/uploads/2020/10/19/pixel-5-14-668x445.jpg 668w, https://www.androidpolice.com/wp-content/uploads/2020/10/19/pixel-5-14-329x219.jpg 329w, https://www.androidpolice.com/wp-content/uploads/2020/10/19/pixel-5-14-161x107.jpg 161w, https://www.androidpolice.com/wp-content/uploads/2020/10/19/pixel-5-14-217x145.jpg 217w, https://www.androidpolice.com/wp-content/uploads/2020/10/19/pixel-5-14-728x485.jpg 728w" sizes="(max-width: 668px) 100vw, 668px"></a></p>
<p style="text-align: center;"><em>Most Pixels at least try to be "flagships," but the Pixel 5 stands out as an exception.&nbsp;</em></p>
<p>The new chipset should be faster, the cameras are clearly upgraded (if not assuredly in quality, definitely in quantity in the case of the larger version), and things like faster wireless charging (if it pans out) and an in-display fingerprint sensor are the sorts of perks you expect to see in a higher-end phone. But there are two probable setbacks.</p>
<p>For one, the smaller Pixel 6 isn't objectively going to be a "small" phone &mdash; not by our definition, and <a href="https://www.androidpolice.com/2021/07/04/weekend-poll-what-screen-size-do-you-consider-small-for-a-phone/">not by yours</a>, according to a recent poll. Fans of the Pixel 5 and Pixel 4a's size will likely be disappointed by the much larger Pixel 6. Second: If the Pixel 6 is a return to a true flagship mantra, as it seems to be so far, that will likely come with more expensive flagship pricing, unless Google can work a miracle or future leaks details indicate lower aim.</p>
<h2><span id="How_much_will_it_cost">How much will it cost?</span></h2>
<p>Price so far is unknown, and any numbers would be conjecture. If I had to guess, I would expect it to cost more than last year's Pixel 5 given the spec bump this year and more truly "flagship" design, but we'll have to wait for more information before it's reasonable to offer up any estimates.</p>
<h2><span id="When_will_it_come_out">When will it come out?</span></h2>
<p>Google's flagship Pixels usually land sometime in autumn, at the <a href="https://www.androidpolice.com/2019/09/16/made-by-google-pixel-4-event-set-for-october-15th/">Made By Google event</a>. Last year that was upset by the pandemic and replaced with a more low-key "<a href="https://www.androidpolice.com/2020/09/30/when-and-where-to-watch-googles-launch-night-in-pixel-5-event/">Launch Night In,"</a> but the timing is usually the same.</p>
<p style="text-align: center;"><a href="https://www.androidpolice.com/wp-content/uploads/2019/05/Made-by-Google.jpg" class=" no-style"><img loading="lazy" class="size-large wp-image-564636" src="https://www.androidpolice.com/wp-content/uploads/2019/05/Made-by-Google-668x445.jpg" alt="" width="668" height="445" srcset="https://www.androidpolice.com/wp-content/uploads/2019/05/Made-by-Google-668x445.jpg 668w, https://www.androidpolice.com/wp-content/uploads/2019/05/Made-by-Google-329x219.jpg 329w, https://www.androidpolice.com/wp-content/uploads/2019/05/Made-by-Google-768x512.jpg 768w, https://www.androidpolice.com/wp-content/uploads/2019/05/Made-by-Google-161x107.jpg 161w, https://www.androidpolice.com/wp-content/uploads/2019/05/Made-by-Google-217x145.jpg 217w, https://www.androidpolice.com/wp-content/uploads/2019/05/Made-by-Google-728x485.jpg 728w" sizes="(max-width: 668px) 100vw, 668px"></a></p>
<p>There were a few rumors that the schedule could be moved forward this year (<a href="https://www.androidpolice.com/2019/06/12/google-teased-the-pixel-4-like-its-coming-out-soon-itd-be-better-if-it-were/">as we've been asking for</a>), but supply shortages are also pushing timelines for products further back, so I hesitate to pinpoint even this fall as a certainty. We'll just have to wait and see.</p>
<div class="ap-break"><i class="icon-ap"></i></div>
<p>Leaks for the Pixel 6 series continue, and with each new tidbit, our understanding changes. In the next few months, our coverage will likely change from a pile of unknowns to a full spec table. Be sure to check back in on our coverage regularly as we learn more. But for now, the image is half-formed at best, and many of the details regarding Google's upcoming Pixel 6 remain a mystery.</p>

</div>
<div class="post-footer-meta">
<ul class="horizontal-boxes list-unstyled horizontal-boxes-tags"><li class="title green-border header-bg green-bg">Tags</li><li><a href="https://www.androidpolice.com/tags/everything-we-know/" rel="tag">everything we know</a></li><li><a href="https://www.androidpolice.com/tags/leaks/" rel="tag">leaks</a></li><li><a href="https://www.androidpolice.com/tags/pixel-6/" rel="tag">pixel 6</a></li><li><a href="https://www.androidpolice.com/tags/pixel-6-pro/" rel="tag">pixel 6 pro</a></li><li><a href="https://www.androidpolice.com/tags/pixel-6-xl/" rel="tag">Pixel 6 XL</a></li><li><a href="https://www.androidpolice.com/tags/rumors/" rel="tag">rumors</a></li></ul>
<a href="#" class="btn btn-small btn-pb btn-subscribe" data-trigger="reveal" data-target="card-pb" data-function="apLoadPushbullet"><i class="icon-pushbullet"></i>subscribe</a>
<div class="clear"></div>
<div id="card-pb" class="card card-popup card-pb depth3">
<div class="card-inner"></div>
</div>
<div class="addthis_post_footer addthis_inline_share_toolbox_ax6f" data-url="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/" data-title="Everything we know (and some things we don&#039;t) about Google&#039;s Pixel 6"></div><div class="addthis_fallback"><div class="at-share-btn-elements"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F" target="_blank" class="facebook-color"><span class="icon-facebook"></span></a><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F&text=Everything+we+know+%28and+some+things+we+don%27t%29+about+Google%27s+Pixel+6" target="_blank" class="twitter-color"><span class="icon-twitter"></span></a><a href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F&title=Everything+we+know+%28and+some+things+we+don%27t%29+about+Google%27s+Pixel+6" target="_blank" class="reddit-color"><span class="icon-reddit"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 32 32" version="1.1" role="img" aria-labelledby="at-svg-reddit-3" class="at-icon at-icon-reddit"><g><path d="M27 15.5a2.452 2.452 0 0 1-1.338 2.21c.098.38.147.777.147 1.19 0 1.283-.437 2.47-1.308 3.563-.872 1.092-2.06 1.955-3.567 2.588-1.506.634-3.143.95-4.91.95-1.768 0-3.403-.316-4.905-.95-1.502-.632-2.69-1.495-3.56-2.587-.872-1.092-1.308-2.28-1.308-3.562 0-.388.045-.777.135-1.166a2.47 2.47 0 0 1-1.006-.912c-.253-.4-.38-.842-.38-1.322 0-.678.237-1.26.712-1.744a2.334 2.334 0 0 1 1.73-.726c.697 0 1.29.26 1.78.782 1.785-1.258 3.893-1.928 6.324-2.01l1.424-6.467a.42.42 0 0 1 .184-.26.4.4 0 0 1 .32-.063l4.53 1.006c.147-.306.368-.553.662-.74a1.78 1.78 0 0 1 .97-.278c.508 0 .94.18 1.302.54.36.36.54.796.54 1.31 0 .512-.18.95-.54 1.315-.36.364-.794.546-1.302.546-.507 0-.94-.18-1.295-.54a1.793 1.793 0 0 1-.533-1.308l-4.1-.92-1.277 5.86c2.455.074 4.58.736 6.37 1.985a2.315 2.315 0 0 1 1.757-.757c.68 0 1.256.242 1.73.726.476.484.713 1.066.713 1.744zm-16.868 2.47c0 .513.178.95.534 1.315.356.365.787.547 1.295.547.508 0 .942-.182 1.302-.547.36-.364.54-.802.54-1.315 0-.513-.18-.95-.54-1.31-.36-.36-.794-.54-1.3-.54-.5 0-.93.183-1.29.547a1.79 1.79 0 0 0-.54 1.303zm9.944 4.406c.09-.09.135-.2.135-.323a.444.444 0 0 0-.44-.447c-.124 0-.23.042-.32.124-.336.348-.83.605-1.486.77a7.99 7.99 0 0 1-1.964.248 7.99 7.99 0 0 1-1.964-.248c-.655-.165-1.15-.422-1.486-.77a.456.456 0 0 0-.32-.124.414.414 0 0 0-.306.124.41.41 0 0 0-.135.317.45.45 0 0 0 .134.33c.352.355.837.636 1.455.843.617.207 1.118.33 1.503.366a11.6 11.6 0 0 0 1.117.056c.36 0 .733-.02 1.117-.056.385-.037.886-.16 1.504-.366.62-.207 1.104-.488 1.456-.844zm-.037-2.544c.507 0 .938-.182 1.294-.547.356-.364.534-.802.534-1.315 0-.505-.18-.94-.54-1.303a1.75 1.75 0 0 0-1.29-.546c-.506 0-.94.18-1.3.54-.36.36-.54.797-.54 1.31s.18.95.54 1.315c.36.365.794.547 1.3.547z" fill-rule="evenodd"></path></g></svg></span></a><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.androidpolice.com%2F2021%2F07%2F08%2Fgoogle-pixel-6-pro-xl-specs-price-release-date-leaks%2F&title=Everything+we+know+%28and+some+things+we+don%27t%29+about+Google%27s+Pixel+6" target="_blank" class="linkedin-color"><span class="icon-linkedin"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 32 32" version="1.1" role="img" aria-labelledby="at-svg-linkedin-6" class="at-icon at-icon-linkedin"><g><path d="M26 25.963h-4.185v-6.55c0-1.56-.027-3.57-2.175-3.57-2.18 0-2.51 1.7-2.51 3.46v6.66h-4.182V12.495h4.012v1.84h.058c.558-1.058 1.924-2.174 3.96-2.174 4.24 0 5.022 2.79 5.022 6.417v7.386zM8.23 10.655a2.426 2.426 0 0 1 0-4.855 2.427 2.427 0 0 1 0 4.855zm-2.098 1.84h4.19v13.468h-4.19V12.495z" fill-rule="evenodd"></path></g></svg></span></a></div></div> </div>
<div class='ains ains-10 ains-ap2_below_post_body ai-track' data-ai='WzEwLDJd' style=''>
<div class='ai-adb-hide' data-ai-debug='10'>
<style type="text/css">
.ains-ap2_below_post_body { margin: 10px -10px 0; }
@media (min-width: 540px) { .ains-ap2_below_post_body { margin: 10px -20px 0; } }
@media (min-width: 599px) { .ains-ap2_below_post_body { margin: 20px -20px 0; } }
@media (min-width: 768px) { .ains-ap2_below_post_body { margin: 20px -15px 0; } }
@media (min-width: 960px) { .ains-ap2_below_post_body { margin: 30px -20px 0; } }
@media (min-width: 1160px) { .ains-ap2_below_post_body { margin: 30px -30px 0; } }
</style>
<div id="ezoic-pub-ad-placeholder-129">
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot adslot_ap2_below_post_body" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="7266108282" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div></div>
<div class='ai-adb-show' style='visibility: hidden; display: none;' data-ai-tracking='WzMwLDAsImFwMl9iZWxvd19wb3N0X2JvZHlfYWRiIiwiIiwwXQ==' data-ai-debug='10 <= 30'>
<style type="text/css">
.ap2_below_post_body_adb img{
max-width: 100%;
}
</style>
<a class="ap2_below_post_body_adb" href="https://scroll.com/signup?affiliateId=5e2945ebc82069585a19a2bb&utm_source=androidpolice" target="_blank">
<img src="/wp-content/themes/ap2/images/scroll/scroll-728250-1.png" alt="Try Scroll">
</a></div>
</div>
<div class='ains ains-26 ains-ap2_outbrain ai-track' data-ai='WzI2LDAsImFwMl9vdXRicmFpbiIsIiIsMV0=' style=''>

<div class="OUTBRAIN" data-src="https://www.androidpolice.com/2021/07/08/google-pixel-6-pro-xl-specs-price-release-date-leaks/" data-widget-id="AR_1" data-ob-template="IllogicalRobot"></div>
<script>
  ap_write_scroll_script({
    "type" : "text/javascript",
      "src" : "//widgets.outbrain.com/outbrain.js",
      "async" : "async"
  });
</script></div>
</div>
<div class="post-footer">
<div class="article-nav">
<div class="article-nav-box ">
<a class="comment-btn" href="https://www.androidpolice.com/2021/07/08/ting-flex-is-a-full-fledged-phone-service-with-lte-5g-data-for-as-little-as-15-a-month/#disqus_thread" data-disqus-identifier="790361 https://www.androidpolice.com/?p=790361">0</a> <div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:35.881220869732%;"></div></div> <a href="https://www.androidpolice.com/2021/07/08/ting-flex-is-a-full-fledged-phone-service-with-lte-5g-data-for-as-little-as-15-a-month/">
<div class="article-nav-box-content">
<h4 class="first-heading"><span>Previous</span> Story</h4>
<div class="article-nav-box-title">
<div class="ellipsize">
<h5>Ting Flex is a full-fledged phone service with LTE/5G data for as little as $15 a month</h5>
</div>
</div>
</div>
<div class="frame">
<div class="frame-image-wrapper">
<img class="centered animate" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F05%2FTing-Flex-Plan-Hero.png&h=129&zc=3" height="129" alt="" loading="lazy">
</div>
<img class="bg animate" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F05%2FTing-Flex-Plan-Hero.png&w=150&h=85&zc=1&f=8|8|8|8|8|8|8|8|8|8|8|8|8" width="150" height="85" alt="" loading="lazy">
</div>
</a>
</div>
<div class="article-nav-box article-nav-box-right article-nav-box-disabled">
<h5>This Is The Most Recent Story</h5>
</div>
</div>
<div class="post-footer-inner">
<div class="single-post-widget">


<div id="appopularposts-7" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><header class="section-header"><h4 class="header-bg">Trending</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/01/stadia-game-list/#comments">249</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998968571074%;"></div></div>
<a class="cell-link" href="/2021/07/01/stadia-game-list/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F06%2Fstadia-hero-wide.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>All the games on Google Stadia (Update: Streets of Rage 4 and Darkwood)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/01 <br>9:33am PDT</time><time class="timeago" title="Jul 1, 2021" datetime="2021-07-01T09:33:00-07:00">Jul 1, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/02/new-movies-home-premieres-early-rental-streaming/#comments">149</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998893406397%;"></div></div>
<a class="cell-link" href="/2021/07/02/new-movies-home-premieres-early-rental-streaming/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F10%2F18%2Fmovie_hub_hero.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>All the new movies and early theater releases you can watch at home right now</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/02 <br>5:23pm PDT</time><time class="timeago" title="Jul 2, 2021" datetime="2021-07-02T17:23:00-07:00">Jul 2, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/01/create-convert-pdf-phone-camera-android-free/#comments">109</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.99579677325%;"></div></div>
<a class="cell-link" href="/2021/07/01/create-convert-pdf-phone-camera-android-free/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F07%2FScan-document-PDF-take-photo-of-document.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>How to scan documents and photos into PDFs on Android</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/01 <br>11:13am PDT</time><time class="timeago" title="Jul 1, 2021" datetime="2021-07-01T11:13:00-07:00">Jul 1, 2021</time></span></div>
</div>
</a>
</li></ul></section><div class='ains ains-11 ains-ap2_trending_posts_wrapper ai-track' data-ai='WzExLDJd' style=''>
<style type="text/css">
.ains-ap2_trending_posts_wrapper { }
@media (min-width: 960px) { .ains-ap2_trending_posts_wrapper { float: left; width: 320px; height: 270px; display: flex;align-items: center;justify-content: center;} }
</style>
<div id="ezoic-pub-ad-placeholder-122">
<div class='adslot_ap2_trending_posts_wrapper'>
<style type="text/css">
  @media (max-width: 959px) { .adslot_ap2_trending_posts {width: 336px; min-height: 290px}}
  @media (min-width: 960px) { .adslot_ap2_trending_posts {width: 300px; height: 250px; }}
</style>
<script>
    ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
    </script>

<ins class="adsbygoogle adslot adslot_ap2_trending_posts" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="3021676711" data-full-width-responsive="false"></ins>
<script>
        if(!ap_scrolluser){
           (adsbygoogle = window.adsbygoogle || []).push({});
        }
        </script>
</div>
</div></div>
</div>
</div>
<div id="comments">
<a name="comments"></a>
<header class="section-header ">
<h4 class="header-bg blue-bg">Comments</h4>
</header>
<section>
<div id="disqus_thread"></div>
</section>
</div>
</div>
</div>
<center>
<div class='ains ains-13 ains-ap2_footer_small ai-track' data-ai='WzEzLDJd' style=''>
<div id="ezoic-pub-ad-placeholder-134">
<style type="text/css">
.adslot_ap2_footer_small { margin-bottom: 10px; }
@media (min-width: 599px) { .adslot_ap2_footer_small { margin-bottom: 20px; } }
@media (min-width: 768px) { .adslot_ap2_footer_small { display: none !important; } }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot_ap2_footer_small" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="9594790476" data-ad-format="auto"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div></div>
</center>
</div>
<div id="sbar" class="secondary column">
<ul id="sbar-content" class="list-unstyled">
<li id="ai_widget-6" class="widget-odd widget-first widget-1  none widget ai_widget"></li>


<li id="apfollowwidget-2" class="widget-even widget-2 red widget ap-follow-widget"><header class="section-header"><h4 class="header-bg">Follow Android Police</h4></header>
<section class="card">
<div class="card-inner">
<div class="multi-column"> <div class="one-third">
<a class="ap-follow-btn" title="Like Android Police on Facebook" class="" href="https://facebook.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon facebook-color"><i class="icon-facebook"></i></div>
<span class="ap-sidebar-title">173k</span>
</a>
</div>
<div class="one-third">
<a class="ap-follow-btn" title="Follow Android Police on Twitter" class="" href="https://twitter.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon twitter-color"><i class="icon-twitter"></i></div>
<span class="ap-sidebar-title">506k</span>
</a>
</div>
<div class="one-third">
<a class="ap-follow-btn" title="Subscribe on YouTube" class="" href="https://youtube.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon youtube-color"><i class="icon-youtube"></i></div>
<span class="ap-sidebar-title">362k</span>
</a>
</div>
 </div> </div>
<div class="card-action">
<a class="currents ap-follow-btn" title="Subscribe to the RSS feed" href="/feed" target="_blank">
<div class="ap-follow-icon rss-color"><i class="icon-feed"></i></div>
</a>
<a class="currents ap-follow-btn" title="Read on Feedly" href="https://feedly.com/i/subscription/feed%2Fhttps://www.androidpolice.com/feed" target="_blank">
<div class="ap-follow-icon feedly-color"><i class="icon-feedly"></i></div>
</a>
<a class="currents ap-follow-btn" title="Read on Google News" href="https://news.google.com/publications/CAAqBggKMLuYFDDSzAI" target="_blank">
<div class="ap-follow-icon google-news-color"><img src="https://www.androidpolice.com/wp-content/themes/ap2/images/Google_News_icon.svg" alt="Google News" loading="lazy" width="28" height="28"></div>
</a>
<a class="pushbullet-subscribe-widget fl-right" data-channel="androidpolicefeed" data-widget="button" data-size="small"></a>
</div>
</section>
</li>

<li id="ai_widget-2" class="widget-odd widget-3  none widget ai_widget"><div class='ains ains-14 ains-ap2_sidebar_1 ai-track' data-ai='WzE0LDJd' style=''>
<div id="ezoic-pub-ad-placeholder-123">
<style type="text/css">
.adslot_ap2_sidebar_1 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_1 { display:inline-block; width: 300px; height: 250px;} }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot_ap2_sidebar_1" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="6545105860"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div>
</li>


<li id="custom_html-7" class="widget_text widget-even widget-4 blue widget widget_custom_html"><header class="section-header"><h4 class="header-bg">Android Police Newsletter</h4></header><div class="textwidget custom-html-widget"><section class="ap-sbar-widget-wrapper">
<p>
Subscribe to Android Police's weekly newsletter, with the biggest stories, latest deals, and insight on the week's news. Just enter your email below.
</p>
<script src="https://f.convertkit.com/ckjs/ck.5.js"></script>
<form action="https://app.convertkit.com/forms/1275831/subscriptions" class="seva-form formkit-form" method="post" data-sv-form="1275831" data-uid="333cd6d32a" data-version="5" data-options="{&quot;settings&quot;:{&quot;after_subscribe&quot;:{&quot;action&quot;:&quot;message&quot;,&quot;success_message&quot;:&quot;Success! Now check your email to confirm your subscription.&quot;,&quot;redirect_url&quot;:&quot;&quot;},&quot;analytics&quot;:{&quot;google&quot;:null,&quot;facebook&quot;:null,&quot;segment&quot;:null,&quot;pinterest&quot;:null},&quot;modal&quot;:{&quot;trigger&quot;:&quot;timer&quot;,&quot;scroll_percentage&quot;:null,&quot;timer&quot;:5,&quot;devices&quot;:&quot;all&quot;,&quot;show_once_every&quot;:15},&quot;powered_by&quot;:{&quot;show&quot;:true,&quot;url&quot;:&quot;https://convertkit.com?utm_source=dynamic&amp;utm_medium=referral&amp;utm_campaign=poweredby&amp;utm_content=form&quot;},&quot;recaptcha&quot;:{&quot;enabled&quot;:false},&quot;return_visitor&quot;:{&quot;action&quot;:&quot;show&quot;,&quot;custom_content&quot;:&quot;&quot;},&quot;slide_in&quot;:{&quot;display_in&quot;:&quot;bottom_right&quot;,&quot;trigger&quot;:&quot;timer&quot;,&quot;scroll_percentage&quot;:null,&quot;timer&quot;:5,&quot;devices&quot;:&quot;all&quot;,&quot;show_once_every&quot;:15},&quot;sticky_bar&quot;:{&quot;display_in&quot;:&quot;top&quot;,&quot;trigger&quot;:&quot;timer&quot;,&quot;scroll_percentage&quot;:null,&quot;timer&quot;:5,&quot;devices&quot;:&quot;all&quot;,&quot;show_once_every&quot;:15}},&quot;version&quot;:&quot;5&quot;}" min-width="400 500 600 700 800">
<div data-style="clean">
<ul class="formkit-alert formkit-alert-error" data-element="errors" data-group="alert"></ul>
<div data-element="fields" data-stacked="false" class="seva-fields formkit-fields">
<div class="formkit-field"><input class="formkit-input" name="email_address" placeholder="Your email address" required="" type="email" style="padding: 10px 8px;">
</div><button data-element="submit" class="formkit-submit formkit-submit" style="margin-top:10px; background-color: #af1c1c; color: #fff; width: 100%; border:0;">
<div class="formkit-spinner">
<div></div>
<div></div>
<div></div>
</div><span>Subscribe</span>
</button>
</div><a href="https://convertkit.com?utm_source=dynamic&amp;utm_medium=referral&amp;utm_campaign=poweredby&amp;utm_content=form" class="formkit-powered-by" hidden data-element="powered-by" target="_blank" rel="noopener noreferrer">Powered By
ConvertKit</a>
</div>
<style>
        .formkit-form[data-uid="333cd6d32a"] .formkit-button:hover>span,
        .formkit-form[data-uid="333cd6d32a"] .formkit-submit:hover>span,
        .formkit-form[data-uid="333cd6d32a"] .formkit-button:focus>span,
        .formkit-form[data-uid="333cd6d32a"] .formkit-submit:focus>span {
            background-color: rgba(0, 0, 0, 0.1);
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-button>span,
        .formkit-form[data-uid="333cd6d32a"] .formkit-submit>span {
            display: block;
            -webkit-transition: all 300ms ease-in-out;
            transition: all 300ms ease-in-out;
            padding: 12px 24px;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-alert {
            background: #f9fafb;
            border: 1px solid #e3e3e3;
            border-radius: 5px;
            -webkit-flex: 1 0 auto;
            -ms-flex: 1 0 auto;
            flex: 1 0 auto;
            list-style: none;
            margin: 25px auto;
            padding: 12px;
            text-align: center;
            width: 100%;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-alert:empty {
            display: none;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-alert-success {
            background: #d3fbeb;
            border-color: #10bf7a;
            color: #0c905c;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-alert-error {
            background: #fde8e2;
            border-color: #f2643b;
            color: #ea4110;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-spinner {
            display: -webkit-box;
            display: -webkit-flex;
            display: -ms-flexbox;
            display: flex;
            height: 0px;
            width: 0px;
            margin: 0 auto;
            position: absolute;
            top: 0;
            left: 0;
            right: 0;
            width: 0px;
            overflow: hidden;
            text-align: center;
            -webkit-transition: all 300ms ease-in-out;
            transition: all 300ms ease-in-out;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-spinner>div {
            margin: auto;
            width: 12px;
            height: 12px;
            background-color: #fff;
            opacity: 0.3;
            border-radius: 100%;
            display: inline-block;
            -webkit-animation: formkit-bouncedelay-formkit-form-data-uid-333cd6d32a- 1.4s infinite ease-in-out both;
            animation: formkit-bouncedelay-formkit-form-data-uid-333cd6d32a- 1.4s infinite ease-in-out both;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-spinner>div:nth-child(1) {
            -webkit-animation-delay: -0.32s;
            animation-delay: -0.32s;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-spinner>div:nth-child(2) {
            -webkit-animation-delay: -0.16s;
            animation-delay: -0.16s;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-submit[data-active] .formkit-spinner {
            opacity: 1;
            height: 100%;
            width: 50px;
        }

        .formkit-form[data-uid="333cd6d32a"] .formkit-submit[data-active] .formkit-spinner~span {
            opacity: 0;
        }

        @-webkit-keyframes formkit-bouncedelay-formkit-form-data-uid-333cd6d32a- {

            0%,
            80%,
            100% {
                -webkit-transform: scale(0);
                -ms-transform: scale(0);
                transform: scale(0);
            }

            40% {
                -webkit-transform: scale(1);
                -ms-transform: scale(1);
                transform: scale(1);
            }
        }

        @keyframes formkit-bouncedelay-formkit-form-data-uid-333cd6d32a- {

            0%,
            80%,
            100% {
                -webkit-transform: scale(0);
                -ms-transform: scale(0);
                transform: scale(0);
            }

            40% {
                -webkit-transform: scale(1);
                -ms-transform: scale(1);
                transform: scale(1);
            }
        }

        .formkit-form[data-uid="333cd6d32a"] blockquote {
            padding: 10px 20px;
            margin: 0 0 20px;
            border-left: 5px solid #e1e1e1;
        }
    </style>
</form>
</section></div></li>

<li id="ai_widget-3" class="widget-odd widget-5  none widget ai_widget"><div class='ains ains-15 ains-ap2_sidebar_2 ai-track' data-ai='WzE1LDJd' style=''>
<div class='ai-adb-hide' data-ai-debug='15'>
<div id="ezoic-pub-ad-placeholder-124">
<style type="text/css">
.adslot_ap2_sidebar_2 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_2 { display:inline-block; width: 300px; height: 600px;} }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot_ap2_sidebar_2" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="8764075098"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div>
<div class='ai-adb-show' style='visibility: hidden; display: none;' data-ai-tracking='WzI5LDAsImFwMl9zaWRlYmFyXzJfYWRiIiwiIiwwXQ==' data-ai-debug='15 <= 29'>
<style type="text/css">
.ap2_sidebar_2_adb img{
max-width: 100%;
}
</style>
<a class="ap2_sidebar_2_adb" href="https://scroll.com/signup?affiliateId=5e2945ebc82069585a19a2bb&utm_source=androidpolice" target="_blank">
<img src="/wp-content/themes/ap2/images/scroll/scroll-300250-1.png" alt="Try Scroll">
</a></div>
</div>
</li>


<li id="aprecentpostswidget-2" class="widget-even widget-6 green widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Latest Deals</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/07/these-refurbished-shark-robo-vacs-might-be-cheap-enough-to-make-you-feel-bad-about-your-filthy-filthy-floors/#comments">2</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:27.234509129405%;"></div></div>
<a class="cell-link" href="/2021/07/07/these-refurbished-shark-robo-vacs-might-be-cheap-enough-to-make-you-feel-bad-about-your-filthy-filthy-floors/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2Fshark-rv750-dog-scaled.jpeg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>These refurbished Shark robo-vacs might be cheap enough to make you feel bad about your filthy, filthy floors</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>2:32pm PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T14:32:21-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/07/keep-mom-and-dad-connected-with-a-facebook-portal-plus-now-100-off/#comments">17</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:7.0074711223318%;"></div></div>
<a class="cell-link" href="/2021/07/07/keep-mom-and-dad-connected-with-a-facebook-portal-plus-now-100-off/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F10%2Ffacebook-portal-plus.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Keep mom and dad connected with a Facebook Portal Plus, now $100 off</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>8:12am PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T08:12:29-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/07/android-app-game-sales-july-7-2021/#comments">5</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:39.183692369525%;"></div></div>
<a class="cell-link" href="/2021/07/07/android-app-game-sales-july-7-2021/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2Fwednesday.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>25 temporarily free and 33 on-sale apps and games for Wednesday</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>7:24am PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T07:24:30-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/06/amazfits-bestselling-smartwatch-is-nearly-half-off-today/#comments">6</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:28.792282573376%;"></div></div>
<a class="cell-link" href="/2021/07/06/amazfits-bestselling-smartwatch-is-nearly-half-off-today/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F06%2Famazfit_watch.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Amazfit's bestselling smartwatch is nearly half off today</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/06 <br>3:08pm PDT</time><time class="timeago" title="Jul 6, 2021" datetime="2021-07-06T15:08:34-07:00">Jul 6, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/06/since-were-not-getting-a-new-note-this-year-enjoy-this-deal-on-last-years-model/#comments">12</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-20" style="width:22.059638640833%;"></div></div>
<a class="cell-link" href="/2021/07/06/since-were-not-getting-a-new-note-this-year-enjoy-this-deal-on-last-years-model/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F10%2F06%2FNote20-review-3-scaled.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Since we're not getting a new Note this year, enjoy this deal on last year's model</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/06 <br>11:05am PDT</time><time class="timeago" title="Jul 6, 2021" datetime="2021-07-06T11:05:44-07:00">Jul 6, 2021</time></span></div>
</div>
</a>
</li></ul></section></li>

<li id="ai_widget-4" class="widget-odd widget-7  none widget ai_widget"><div class='ains ains-16 ains-ap2_sidebar_3 ai-track' data-ai='WzE2LDJd' style=''>
<div id="ezoic-pub-ad-placeholder-125">
<style type="text/css">
.adslot_ap2_sidebar_3 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_3 { display:inline-block; width: 300px; height: 250px;} }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot_ap2_sidebar_3" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="2745870776"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div>
</li>


<li id="wpb_widget-4" class="widget-even widget-8 blue widget widget_wpb_widget"><header class="section-header"><h4 class="header-bg">Latest Poll</h4></header><section class="ap-sbar-widget-wrapper noskim"><div id="polls-554" class="wp-polls">
<form id="polls_form_554" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_554_nonce" name="wp-polls-nonce" value="c1d007fa82" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="554" /></p>
<p style="text-align: center;"><strong>Below what screen size do you consider a phone "small" in 2021?</strong></p><div id="polls-554-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li><input type="radio" id="poll-answer-3030" name="poll_554" value="3030" /> <label for="poll-answer-3030">Bigger than 6.5".</label></li>
<li><input type="radio" id="poll-answer-3031" name="poll_554" value="3031" /> <label for="poll-answer-3031">6.5" to 6.3.</label></li>
<li><input type="radio" id="poll-answer-3032" name="poll_554" value="3032" /> <label for="poll-answer-3032">6.29" to 6.1".</label></li>
<li><input type="radio" id="poll-answer-3033" name="poll_554" value="3033" /> <label for="poll-answer-3033">6.09" to 5.9".</label></li>
<li><input type="radio" id="poll-answer-3041" name="poll_554" value="3041" /> <label for="poll-answer-3041">5.89" to 5.7".</label></li>
<li><input type="radio" id="poll-answer-3042" name="poll_554" value="3042" /> <label for="poll-answer-3042">5.69" to 5.5".</label></li>
<li><input type="radio" id="poll-answer-3043" name="poll_554" value="3043" /> <label for="poll-answer-3043">5.49" to 5.3".</label></li>
<li><input type="radio" id="poll-answer-3044" name="poll_554" value="3044" /> <label for="poll-answer-3044">Smaller than 5.3".</label></li>
<li><input type="radio" id="poll-answer-3045" name="poll_554" value="3045" /> <label for="poll-answer-3045">"I know it when I see it."</label></li>
<li><input type="radio" id="poll-answer-3046" name="poll_554" value="3046" /> <label for="poll-answer-3046">I don't know.</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(554);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(554); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-554-loading" class="wp-polls-loading"><img src="https://www.androidpolice.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<div class="center"><p><a href="https://www.androidpolice.com/2021/07/04/weekend-poll-what-screen-size-do-you-consider-small-for-a-phone/" class="primary-btn btn-widget"> Discuss This Poll</a></p></div></section></li>

<li id="ai_widget-5" class="widget-odd widget-9  none widget ai_widget"><div class='ains ains-17 ains-ap2_sidebar_4 ai-track' data-ai='WzE3LDJd' style=''>
<div id="ezoic-pub-ad-placeholder-126">
<style type="text/css">
.adslot_ap2_sidebar_4 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_4 { display:inline-block; width: 300px; height: 600px;} }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot_ap2_sidebar_4" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4881079520"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div>
</div>
</li>


<li id="aprecentpostswidget-3" class="widget-even widget-10 teal widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Recent Reviews</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/06/google-pixel-buds-a-series-review/#comments">32</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-90" style="width:91.913727916073%;"></div></div>
<a class="cell-link" href="/2021/07/06/google-pixel-buds-a-series-review/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F05%2F27%2Fpixel-buds-a-series-review-hero_7xcVn6TrLVng-scaled.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Pixel Buds A-Series review, one month later: Drop beats, not bucks</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/06 <br>10:49am PDT</time><time class="timeago" title="Jul 6, 2021" datetime="2021-07-06T10:49:00-07:00">Jul 6, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/06/oneplus-watch-review-i-dont-have-time-for-this/#comments">32</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:49.522053894208%;"></div></div>
<a class="cell-link" href="/2021/07/06/oneplus-watch-review-i-dont-have-time-for-this/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F04%2F19%2Foneplus-watch-review-hero-scaled.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>OnePlus Watch review, two months later: Time to let go (of the hope this will ever be a good watch)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/06 <br>8:57am PDT</time><time class="timeago" title="Jul 6, 2021" datetime="2021-07-06T08:57:00-07:00">Jul 6, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/03/i-never-knew-i-needed-a-portable-usb-c-desk-lamp-in-my-life-but-here-we-are/#comments">45</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:40.285270900691%;"></div></div>
<a class="cell-link" href="/2021/07/03/i-never-knew-i-needed-a-portable-usb-c-desk-lamp-in-my-life-but-here-we-are/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F02%2Fbaseus-usb-c-desk-lamp-1.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>I never knew I needed a portable USB-C desk lamp in my life, but here we are</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/03 <br>3:00am PDT</time><time class="timeago" title="Jul 3, 2021" datetime="2021-07-03T03:00:00-07:00">Jul 3, 2021</time></span></div>
</div>
</a>
 </li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/02/oneplus-nord-n10-5g-hands-on-review/#comments">47</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-20" style="width:18.962362505781%;"></div></div>
<a class="cell-link" href="/2021/07/02/oneplus-nord-n10-5g-hands-on-review/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F11%2F13%2FOnePlus-Nord-N10-5G-review-Hero-scaled.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>OnePlus Nord N10 5G review: Longer updates make a better phone</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/02 <br>12:34pm PDT</time><time class="timeago" title="Jul 2, 2021" datetime="2021-07-02T12:34:00-07:00">Jul 2, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/02/review-forget-the-chromecast-walmarts-onn-android-tv-is-cheaper-and-just-as-good/#comments">59</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-60" style="width:57.130175764184%;"></div></div>
<a class="cell-link" href="/2021/07/02/review-forget-the-chromecast-walmarts-onn-android-tv-is-cheaper-and-just-as-good/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F02%2Fwalmart_onn_4k_android_tv_hero-mw.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Review: Forget the Chromecast, Walmart's Onn Android TV is cheaper and just as good</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/02 <br>10:48am PDT</time><time class="timeago" title="Jul 2, 2021" datetime="2021-07-02T10:48:18-07:00">Jul 2, 2021</time></span></div>
</div>
</a>
</li></ul></section></li>



<li id="aprecentpostswidget-5" class="widget-odd widget-11 red widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Latest Roundups</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/04/19-new-android-games-from-the-last-week-the-best-worst-and-everything-in-between-6-28-21-7-4-21/#comments">11</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:30.611682604218%;"></div></div>
<a class="cell-link" href="/2021/07/04/19-new-android-games-from-the-last-week-the-best-worst-and-everything-in-between-6-28-21-7-4-21/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>19 new Android games from the last week: The best, worst, and everything in between (6/28/21 - 7/4/21)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/04 <br>6:54am PDT</time><time class="timeago" title="Jul 4, 2021" datetime="2021-07-04T06:54:45-07:00">Jul 4, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/03/14-new-and-notable-android-apps-from-the-last-two-weeks-including-stadia-for-android-tv-elabels-and-zoom-for-chrome-6-19-21-7-3-21/#comments">4</a>
 <div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:39.693686383708%;"></div></div>
<a class="cell-link" href="/2021/07/03/14-new-and-notable-android-apps-from-the-last-two-weeks-including-stadia-for-android-tv-elabels-and-zoom-for-chrome-6-19-21-7-3-21/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_apps-01.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>14 new and notable Android apps from the last two weeks including Stadia for Android TV, eLabels, and Zoom for Chrome (6/19/21 - 7/3/21)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/03 <br>6:53am PDT</time><time class="timeago" title="Jul 3, 2021" datetime="2021-07-03T06:53:09-07:00">Jul 3, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/06/27/10-new-android-games-from-the-last-week-the-best-worst-and-everything-in-between-6-21-21-6-27-21/#comments">5</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:27.046895285725%;"></div></div>
<a class="cell-link" href="/2021/06/27/10-new-android-games-from-the-last-week-the-best-worst-and-everything-in-between-6-21-21-6-27-21/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>10 new Android games from the last week: The best, worst, and everything in between (6/21/21 - 6/27/21)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/06/27 <br>9:20am PDT</time><time class="timeago" title="Jun 27, 2021" datetime="2021-06-27T09:20:10-07:00">Jun 27, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/06/20/12-new-android-games-from-the-last-week-the-best-worst-and-everything-in-between-6-14-21-6-20-21/#comments">3</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-20" style="width:22.591592572106%;"></div></div>
<a class="cell-link" href="/2021/06/20/12-new-android-games-from-the-last-week-the-best-worst-and-everything-in-between-6-14-21-6-20-21/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>12 new Android games from the last week: The best, worst, and everything in between (6/14/21 - 6/20/21)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/06/20 <br>6:28am PDT</time><time class="timeago" title="Jun 20, 2021" datetime="2021-06-20T06:28:15-07:00">Jun 20, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/06/19/9-new-and-notable-android-apps-from-the-last-two-weeks-including-microsoft-edge-beta-opera-gx-and-expensify-cash-6-5-21-6-19-21/#comments">4</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:39.714236119684%;"></div></div>
<a class="cell-link" href="/2021/06/19/9-new-and-notable-android-apps-from-the-last-two-weeks-including-microsoft-edge-beta-opera-gx-and-expensify-cash-6-5-21-6-19-21/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_apps-01.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>9 new and notable Android apps from the last two weeks including Microsoft Edge Beta, Opera GX, and Expensify.cash (6/5/21 - 6/19/21)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/06/19 <br>7:26am PDT</time><time class="timeago" title="Jun 19, 2021" datetime="2021-06-19T07:26:22-07:00">Jun 19, 2021</time></span></div>
</div>
</a>
</li></ul></section></li>



<li id="aprecentpostswidget-4" class="widget-even widget-12 blue widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Recent Apps and Games</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/08/chrome-for-android-is-testing-a-better-way-to-thumb-through-google-results/#comments">0</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:35.787730126916%;"></div></div>
<a class="cell-link" href="/2021/07/08/chrome-for-android-is-testing-a-better-way-to-thumb-through-google-results/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F08%2Fchrome-continuous-search-navigation-alt.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Chrome for Android is testing a better way to thumb through Google results</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/08 <br>7:02am PDT</time><time class="timeago" title="Jul 8, 2021" datetime="2021-07-08T07:02:44-07:00">Jul 8, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/07/google-opinion-rewards-brings-its-free-play-store-credit-to-five-more-countries/#comments">19</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:32.836201639636%;"></div></div>
<a class="cell-link" href="/2021/07/07/google-opinion-rewards-brings-its-free-play-store-credit-to-five-more-countries/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F11%2FGoogle-Play-Rewards-hero.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Google Opinion Rewards brings its free Play Store credit to five more countries</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>4:00pm PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T16:00:12-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/07/google-just-got-handed-a-massive-multi-state-antitrust-lawsuit-over-play-store-fees/#comments">17</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:34.037984435318%;"></div></div>
<a class="cell-link" href="/2021/07/07/google-just-got-handed-a-massive-multi-state-antitrust-lawsuit-over-play-store-fees/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2Fgoogle-gavel.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Google just got handed a massive multi-state antitrust lawsuit over Play Store fees</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>3:04pm PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T15:04:10-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/07/truecaller-beats-google-to-the-punch-with-otp-cleanup-and-adds-dark-souls-style-caller-comments/#comments">15</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:30.847795462828%;"></div></div>
<a class="cell-link" href="/2021/07/07/truecaller-beats-google-to-the-punch-with-otp-cleanup-and-adds-dark-souls-style-caller-comments/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2Ftruecaller-dark-souls.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Truecaller beats Google to the punch with OTP cleanup, and adds Dark Souls-style caller comments</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>2:19pm PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T14:19:47-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2021/07/07/firefox-90-fully-removes-ftp-support-and-reorganizes-some-settings-apk-download/#comments">6</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:35.910823899528%;"></div></div>
<a class="cell-link" href="/2021/07/07/firefox-90-fully-removes-ftp-support-and-reorganizes-some-settings-apk-download/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2Ffirefox-hero-phone-mockup.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Firefox follows in Chrome's footsteps and drops FTP support (APK Download)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>8:11am PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T08:11:45-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li></ul></section></li>



<li id="apblastfromthepast-2" class="widget-odd widget-last widget-13 red widget ap-blast-from-past"><header class="section-header"><h4 class="header-bg">Blast from the Past</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/07/07/upcoming-google-home-improvements-include-oem-made-assistant-routines/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:98.191828540774%;"></div></div>
<a class="cell-link" href="/2020/07/07/upcoming-google-home-improvements-include-oem-made-assistant-routines/">
<h3 class="ap-sidebar-title"><span>1 Year Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F07%2F07%2Fgoogle-home-google-assistant-hero.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Upcoming Google Home improvements include Assistant routines from device makers</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/07/07 <br>7:00pm PDT</time><time class="timeago" title="Jul 7, 2020" datetime="2020-07-07T19:00:28-07:00">Jul 7, 2020</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/07/07/weekend-discussion-whats-your-favorite-feature-in-android-q-so-far/#comments">180</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-80" style="width:84.134474606854%;"></div></div>
<a class="cell-link" href="/2019/07/07/weekend-discussion-whats-your-favorite-feature-in-android-q-so-far/">
<h3 class="ap-sidebar-title"><span>2 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F07%2FAndroid-Q-Developer-Blog-Hero.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Weekend discussion: What's your favorite feature in Android Q so far?</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/07/07 <br>9:31am PDT</time><time class="timeago" title="Jul 7, 2019" datetime="2019-07-07T09:31:03-07:00">Jul 7, 2019</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2018/07/07/android-p-shows-current-weather-conditions-lock-screen-ambient-mode/#comments">161</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.918475099388%;"></div></div>
<a class="cell-link" href="/2018/07/07/android-p-shows-current-weather-conditions-lock-screen-ambient-mode/">
<h3 class="ap-sidebar-title"><span>3 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F05%2Fandroid-p-lockscreen.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>[Update: Working again] Android P shows current weather conditions on the lock screen and in ambient mode</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2018/07/07 <br>4:56pm PDT</time><time class="timeago" title="Jul 7, 2018" datetime="2018-07-07T16:56:00-07:00">Jul 7, 2018</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2017/07/07/oneplus-launcher-now-play-store-currently-full-limited-beta/#comments">71</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.997803703684%;"></div></div>
<a class="cell-link" href="/2017/07/07/oneplus-launcher-now-play-store-currently-full-limited-beta/">
<h3 class="ap-sidebar-title"><span>4 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F07%2Fnexus2cee_OnePlus-Launcher-Google-Play-Beta-Hero.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>[Update: And it's gone] OnePlus Launcher is now on the Play Store in a (currently full) limited beta</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/07/07 <br>5:45pm PDT</time><time class="timeago" title="Jul 7, 2017" datetime="2017-07-07T17:45:48-07:00">Jul 7, 2017</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2016/07/07/pokemon-go-now-live-several-countries-including-australia-new-zealand-possibly/#comments">269</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.987951077717%;"></div></div>
<a class="cell-link" href="/2016/07/07/pokemon-go-now-live-several-countries-including-australia-new-zealand-possibly/">
<h3 class="ap-sidebar-title"><span>5 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F07%2Fnexus2cee_poke.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>[Update: US too] Pokémon GO is now live in several countries including Australia, New Zealand, and possibly more [APK download]</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2016/07/07 <br>1:00am PDT</time><time class="timeago" title="Jul 7, 2016" datetime="2016-07-07T01:00:57-07:00">Jul 7, 2016</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2015/07/07/next-play-store-update-will-include-tweaks-to-characters-section-animation-and-whats-new-box/#comments">58</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.334792563959%;"></div></div>
<a class="cell-link" href="/2015/07/07/next-play-store-update-will-include-tweaks-to-characters-section-animation-and-whats-new-box/">
<h3 class="ap-sidebar-title"><span>6 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2015%2F04%2Fnexus2cee_GooglePlayStore-Thumb.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Next Play Store Update Will Include Tweaks To 'Characters' Section Animation And What's New Box [Update: APK Download]</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2015/07/07 <br>3:12pm PDT</time><time class="timeago" title="Jul 7, 2015" datetime="2015-07-07T15:12:29-07:00">Jul 7, 2015</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2014/07/07/27-best-and-5-wtf-new-android-games-from-the-last-2-weeks-62414-7714/#comments">20</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2014/07/07/27-best-and-5-wtf-new-android-games-from-the-last-2-weeks-62414-7714/">
<h3 class="ap-sidebar-title"><span>7 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2014%2F07%2Fnexusae0_gameroundup_icon_large.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>27 Best (And 5 WTF) New Android Games From The Last 2 Weeks (6/24/14 - 7/7/14)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2014/07/07 <br>6:00pm PDT</time><time class="timeago" title="Jul 7, 2014" datetime="2014-07-07T18:00:00-07:00">Jul 7, 2014</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2013/07/07/lenovos-budget-friendly-a1000-a3000-and-s6000-tablets-are-now-on-sale/#comments">5</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2013/07/07/lenovos-budget-friendly-a1000-a3000-and-s6000-tablets-are-now-on-sale/">
<h3 class="ap-sidebar-title"><span>8 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2013%2F07%2Fnexusae0_8959247cv3a.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Lenovo Quietly Launches Budget-Friendly A1000, A3000, And S6000 Tablets</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2013/07/07 <br>11:37pm PDT</time><time class="timeago" title="Jul 7, 2013" datetime="2013-07-07T23:37:00-07:00">Jul 7, 2013</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2012/07/07/espn-replaces-its-old-crappy-espn-radio-app-with-brand-new-ics-ready-hotness/#comments">11</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2012/07/07/espn-replaces-its-old-crappy-espn-radio-app-with-brand-new-ics-ready-hotness/">
<h3 class="ap-sidebar-title"><span>9 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2012%2F07%2Fespnradio.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>ESPN Replaces Its Old, Crappy ESPN Radio App With Brand New, ICS-Ready Hotness</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2012/07/07 <br>8:37pm PDT</time><time class="timeago" title="Jul 7, 2012" datetime="2012-07-07T20:37:44-07:00">Jul 7, 2012</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2011/07/07/sprint-offering-50-incentive-to-customer-close-to-the-end-of-their-contract/#comments">9</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2011/07/07/sprint-offering-50-incentive-to-customer-close-to-the-end-of-their-contract/">
<h3 class="ap-sidebar-title"><span>10 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2011%2F07%2Fimages1.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Sprint Offering $50 Incentive To Customers Close To The End Of Their Contract</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2011/07/07 <br>9:21pm PDT</time><time class="timeago" title="Jul 7, 2011" datetime="2011-07-07T21:21:20-07:00">Jul 7, 2011</time></span></div>
</div>
</a>
</li></ul></section></li>

</ul>
</div>
<div class='ains ains-18 ains-ap2_sidebar_5 ai-track' data-ai='WzE4LDJd' style=''>
<div class='ai-adb-hide' data-ai-debug='18'>
<style type="text/css">
.ains-ap2_sidebar_5 { display: none; text-align: center;}
@media (min-width: 768px) { .ains-ap2_sidebar_5 { display:block; width: 300px; height: 250px; float: right; position: sticky; position: -webkit-sticky; top: 20px; margin-bottom: 20px; }
.adslot_ap2_sidebar_5{width: 300px; height: 250px; margin: 0 auto; }}
</style>
<div id="ezoic-pub-ad-placeholder-142">
<script>
  ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
  </script>

<ins class="adsbygoogle adslot_ap2_sidebar_5" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="3575448930"></ins>
<script>
  if(!ap_scrolluser){
     (adsbygoogle = window.adsbygoogle || []).push({});
  }
  </script>
</div></div>
<div class='ai-adb-show' style='visibility: hidden; display: none;' data-ai-tracking='WzI3LDAsImFwMl9zaWRlYmFyXzVfYWRiIiwiIiwwXQ==' data-ai-debug='18 <= 27'>
<style type="text/css">
.ap2_sidebar_5_adb img{
max-width: 100%;
}
</style>
<a class="ap2_sidebar_5_adb" href="https://scroll.com/signup?affiliateId=5e2945ebc82069585a19a2bb&utm_source=androidpolice" target="_blank">
<img src="/wp-content/themes/ap2/images/scroll/scroll-300250-1.png" alt="Try Scroll">
</a></div>
</div>
</div>
</div>
<script type="text/javascript">
    var ajaxurl = 'https://www.androidpolice.com/wordpress/wp-admin/admin-ajax.php';
    var postid = 790784</script>
<center>
<div class='ains ains-12 ains-ap2_footer_large ai-track' data-ai='WzEyLDJd' style=''>
<div id="ezoic-pub-ad-placeholder-127">
<style type="text/css">
.adslot_ap2_footer_large { display: none; }
@media (min-width: 768px) { .adslot_ap2_footer_large { display:inline-block; width: 728px; height: 90px; margin-bottom: 10px} }
@media (min-width: 970px) { .adslot_ap2_footer_large { display:inline-block; width: 970px; height: 250px; margin-bottom: 20px} }
</style>
<script>
ap_write_scroll_script({"async":"async","src":"//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"});
</script>

<ins class="adsbygoogle adslot_ap2_footer_large" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="9594790476"></ins>
<script>
if(!ap_scrolluser){
   (adsbygoogle = window.adsbygoogle || []).push({});
}
</script>
</div></div>
</center>
<div class="band footer">
<div class="container">
<div class="ap-hottest-content-wrapper">
<header class="section-header"><h4>What's Hot</h4></header>
<div class="one-third column alpha">


<div id="appopularposts-5" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 24 Hours</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/07/oneplus-faces-accusations-of-hobbling-latest-flagships-performance/#comments">122</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.959236602237%;"></div></div>
<a class="cell-link" href="/2021/07/07/oneplus-faces-accusations-of-hobbling-latest-flagships-performance/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F03%2F22%2FOnePlus-9-Pro-3_pkcaZvZrgrbI-scaled.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>OnePlus confirms it throttled the performance of 300 popular apps</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>11:07am PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T11:07:00-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/08/you-might-not-want-to-update-your-chromebook-to-the-latest-chrome-os-release-just-yet/#comments">28</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:97.416338474128%;"></div></div>
<a class="cell-link" href="/2021/07/08/you-might-not-want-to-update-your-chromebook-to-the-latest-chrome-os-release-just-yet/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F02%2FPile-of-Chromebook-Chrome-OS-Generic-Hero-1.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Google pulls latest Chromebook update amidst slowdowns, introducing another problem in the process</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/08 <br>4:24am PDT</time><time class="timeago" title="Jul 8, 2021" datetime="2021-07-08T04:24:00-07:00">Jul 8, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/07/choetech-is-the-latest-budget-electronics-brand-to-disappear-from-amazon/#comments">31</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:44.94279410331%;"></div></div>
<a class="cell-link" href="/2021/07/07/choetech-is-the-latest-budget-electronics-brand-to-disappear-from-amazon/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F05%2Fchoetech-5-coil-top.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Amazon kicks yet another budget electronics brand off the store</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>1:30pm PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T13:30:03-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/07/pixels-get-julys-updates-a-few-days-late-and-a-few-changes-light/#comments">37</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:40.572293744838%;"></div></div>
<a class="cell-link" href="/2021/07/07/pixels-get-julys-updates-a-few-days-late-and-a-few-changes-light/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F04%2F04%2Fpixel-5-header.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Pixels get July's updates a few days late and a few changes light</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>10:47am PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T10:47:12-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/08/ting-flex-is-a-full-fledged-phone-service-with-lte-5g-data-for-as-little-as-15-a-month/#comments">0</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:35.881220869732%;"></div></div>
<a class="cell-link" href="/2021/07/08/ting-flex-is-a-full-fledged-phone-service-with-lte-5g-data-for-as-little-as-15-a-month/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F05%2FTing-Flex-Plan-Hero.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Ting Flex is a full-fledged phone service with LTE/5G data for as little as $15 a month</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/08 <br>8:00am PDT</time><time class="timeago" title="Jul 8, 2021" datetime="2021-07-08T08:00:00-07:00">Jul 8, 2021</time></span></div>
</div>
</a>
</li></ul></section></div>
</div>
<div class="one-third column">


<div id="appopularposts-6" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 7 Days</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/01/stadia-game-list/#comments">249</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998968571074%;"></div></div>
<a class="cell-link" href="/2021/07/01/stadia-game-list/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F06%2Fstadia-hero-wide.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>All the games on Google Stadia (Update: Streets of Rage 4 and Darkwood)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/01 <br>9:33am PDT</time><time class="timeago" title="Jul 1, 2021" datetime="2021-07-01T09:33:00-07:00">Jul 1, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/02/new-movies-home-premieres-early-rental-streaming/#comments">149</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998893406397%;"></div></div>
<a class="cell-link" href="/2021/07/02/new-movies-home-premieres-early-rental-streaming/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F10%2F18%2Fmovie_hub_hero.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>All the new movies and early theater releases you can watch at home right now</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/02 <br>5:23pm PDT</time><time class="timeago" title="Jul 2, 2021" datetime="2021-07-02T17:23:00-07:00">Jul 2, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/01/create-convert-pdf-phone-camera-android-free/#comments">109</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.99579677325%;"></div></div>
<a class="cell-link" href="/2021/07/01/create-convert-pdf-phone-camera-android-free/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F07%2FScan-document-PDF-take-photo-of-document.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>How to scan documents and photos into PDFs on Android</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/01 <br>11:13am PDT</time><time class="timeago" title="Jul 1, 2021" datetime="2021-07-01T11:13:00-07:00">Jul 1, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/07/oneplus-faces-accusations-of-hobbling-latest-flagships-performance/#comments">122</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.959236602237%;"></div></div>
<a class="cell-link" href="/2021/07/07/oneplus-faces-accusations-of-hobbling-latest-flagships-performance/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F03%2F22%2FOnePlus-9-Pro-3_pkcaZvZrgrbI-scaled.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>OnePlus confirms it throttled the performance of 300 popular apps</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>11:07am PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T11:07:00-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/07/a-new-open-world-gacha-game-is-coming-to-take-down-genshin-impact/#comments">46</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.804177005407%;"></div></div>
<a class="cell-link" href="/2021/07/07/a-new-open-world-gacha-game-is-coming-to-take-down-genshin-impact/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F07%2F07%2FPunishing-Gray-Raven-hero.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>A new gacha game is coming to take down Genshin Impact</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>6:30am PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T06:30:04-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li></ul></section></div>
</div>
<div class="one-third column omega">


<div id="appopularposts-9" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 30 Days</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/01/stadia-game-list/#comments">249</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998968571074%;"></div></div>
<a class="cell-link" href="/2021/07/01/stadia-game-list/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F06%2Fstadia-hero-wide.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>All the games on Google Stadia (Update: Streets of Rage 4 and Darkwood)</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/01 <br>9:33am PDT</time><time class="timeago" title="Jul 1, 2021" datetime="2021-07-01T09:33:00-07:00">Jul 1, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/02/new-movies-home-premieres-early-rental-streaming/#comments">149</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998893406397%;"></div></div>
<a class="cell-link" href="/2021/07/02/new-movies-home-premieres-early-rental-streaming/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F10%2F18%2Fmovie_hub_hero.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>All the new movies and early theater releases you can watch at home right now</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/02 <br>5:23pm PDT</time><time class="timeago" title="Jul 2, 2021" datetime="2021-07-02T17:23:00-07:00">Jul 2, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/01/create-convert-pdf-phone-camera-android-free/#comments">109</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.99579677325%;"></div></div>
<a class="cell-link" href="/2021/07/01/create-convert-pdf-phone-camera-android-free/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F07%2FScan-document-PDF-take-photo-of-document.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>How to scan documents and photos into PDFs on Android</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/01 <br>11:13am PDT</time><time class="timeago" title="Jul 1, 2021" datetime="2021-07-01T11:13:00-07:00">Jul 1, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/06/29/google-home-resurrects-some-of-the-features-killed-in-google-wifi/#comments">34</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.965983618544%;"></div></div>
<a class="cell-link" href="/2021/06/29/google-home-resurrects-some-of-the-features-killed-in-google-wifi/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F03%2F16%2Fgoogle-home-opposite-colors.png&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>Google Home resurrects some of the features killed in Google Wifi</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/06/29 <br>9:28am PDT</time><time class="timeago" title="Jun 29, 2021" datetime="2021-06-29T09:28:52-07:00">Jun 29, 2021</time></span></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2021/07/07/oneplus-faces-accusations-of-hobbling-latest-flagships-performance/#comments">122</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.959236602237%;"></div></div>
<a class="cell-link" href="/2021/07/07/oneplus-faces-accusations-of-hobbling-latest-flagships-performance/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2021%2F03%2F22%2FOnePlus-9-Pro-3_pkcaZvZrgrbI-scaled.jpg&w=60&h=60" loading="lazy">
<div class="cell-content">
<h4>OnePlus confirms it throttled the performance of 300 popular apps</h4>
<div class="post-meta"><span class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2021/07/07 <br>11:07am PDT</time><time class="timeago" title="Jul 7, 2021" datetime="2021-07-07T11:07:00-07:00">Jul 7, 2021</time></span></div>
</div>
</a>
</li></ul></section></div>
</div>
</div>
<div class="sixteen columns">
</div>
<div class="sixteen columns ">
<div class="footer-notes">
<div id='footer_signature'>
Notice a bug? <a target="_blank" href="https://github.com/android-police/androidpolice-public/issues">Let us know here.</a><br />
Link monetization by <a target="_blank" href="http://skimlinks.com">Skimlinks</a>
<span class="footer-break">
<a href="https://www.androidpolice.com/androidpolice-com-privacy-policy/">Privacy Policy</a>
<a id="post-consent-ui" href="#" onclick="googlefc.showRevocationMessage();return false;">| Change Consent </a> | <a href="https://www.androidpolice.com/dmca-copyright-infringement-notification/">DMCA Disclaimer</a>
| <a href="https://www.androidpolice.com/about/">About</a>
| <a href="https://www.androidpolice.com/advertise/">Advertise</a>
| <a href="https://www.androidpolice.com/contact/">Contact</a><br /></span>
<span class="ap-rel-parent page_stats">
34 queries | 0.493s | citadel | ap <span id="this_page_stats" hidden>Original page cache stats:<br>34 queries | 0.493s | citadel | ap<br>This request stats: <br> 18 queries | 0.093s | hive | </span> </span>
<span class="footer-break">
Android is a trademark of Google Inc. | &copy; Illogical Robot LLC, 2009-2021 </span>
</div>
</div>
</div>
</div>
</div>
<div id="tip-us">
<div id="tip-us-container" class="container">
<div class="sixteen columns">
<div class="tip-us-wrapper">
<div class="tip-us-header">
<a href="#" class="btn-close" title="Close"><i class="icon-exit"></i></a>
<h2 class="modal-heading">Tip Us</h2>
</div>
<div class="tip-us-body">
<div class="ap-loader"></div>
</div>
</div>
</div>
</div>
</div>

<img src="https://www.androidpolice.com/wp-content/plugins/ap-hotness/aph-post-view-counter.php?post_id=790784" alt=""><script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidpolice"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"790784 https:\/\/www.androidpolice.com\/?p=790784","disqusShortname":"androidpolice","disqusTitle":"Everything we know (and some things we don't) about Google's Pixel 6","disqusUrl":"http:\/\/androidpolice.com\/2021\/07\/08\/google-pixel-6-pro-xl-specs-price-release-date-leaks\/","postId":"790784"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.androidpolice.com\/wordpress\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/mistape/assets/js/modernizr.custom.js?ver=1.3.9' id='modernizr-js'></script>
<script type='text/javascript' id='mistape-front-js-extra'>
/* <![CDATA[ */
var decoMistape = {"ajaxurl":"https:\/\/www.androidpolice.com\/wordpress\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/mistape/assets/js/mistape-front.js?ver=1607618018' id='mistape-front-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/nivo-lightbox.js?ver=1608062112' id='nivo-lightbox-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jRespond.js?ver=1.0' id='jRespond-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/mousetrap/mousetrap.js?ver=1.4.6' id='mousetrap-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.flexslider.js?ver=1.0' id='jquery.flexslider-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/androidpolice.js?ver=1625001572' id='androidpolice-js'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/wp-embed.js?ver=5.7.2' id='wp-embed-js'></script>
<script src='https://stats.wp.com/e-202127.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6',blog:'12245754',post:'790784',tz:'-7',srv:'www.androidpolice.com'} ]);
	_stq.push([ 'clickTrackerInit', '12245754', '790784' ]);
</script>
<div id="mistape_dialog" data-mode="comment" data-dry-run="0">
<div class="dialog__overlay"></div><div class="dialog__content"><div id="mistape_confirm_dialog" class="mistape_dialog_screen">
<div class="dialog-wrap">
<div class="dialog-wrap-top">
<h2>Spelling error report</h2>
<div class="mistape_dialog_block">
<h3>The following text will be sent to our editors:</h3>
<div id="mistape_reported_text"></div>
</div>
</div>
<div class="dialog-wrap-bottom">
<div class="mistape_dialog_block comment">
<div class="mistape-contact-row">
<div class="mistape-contact-column">
<h3><label for="ap_mistape_name">Your name (required):</label></h3>
<input type="text" name="ap_mistape_name" id="ap_mistape_name" required="required" />
</div>
<div class="mistape-contact-column">
<h3><label for="ap_mistape_email">Your email (optional):</label></h3>
<input type="email" name="ap_mistape_email" id="ap_mistape_email" />
</div>
</div>
</div>
<h3><label for="mistape_comment">Your comment (optional):</label></h3>
<textarea id="mistape_comment" cols="60" rows="3" maxlength="1000"></textarea>
</div><div class="pos-relative">
</div>
</div>
</div>
<div class="mistape_dialog_block">
<a class="mistape_action" data-action="send" data-id="790784" role="button">Send</a>
<a class="mistape_action" data-dialog-close role="button" style="display:none">Cancel</a>
</div>
<div class="mistape-letter-front letter-part">
<div class="front-left"></div>
<div class="front-right"></div>
<div class="front-bottom"></div>
</div>
<div class="mistape-letter-back letter-part">
<div class="mistape-letter-back-top"></div>
</div>
<div class="mistape-letter-top letter-part"></div>
</div></div></div>

<div id="banner-advert-container" class="adsense sponsor-ad" style="position:absolute; z-index: -10; height: 1px; width: 1px; top: -1px; left: -1px;"><img id="im_popupFixed" class="ad-inserter adsense ad-img ad-index" src="https://www.androidpolice.com/wp-content/plugins/ad-inserter-pro/images/ads.png"></div>
<img id="ai-adb-adnxs" src="" style="position:absolute; z-index: -10; width: 1px; height: 1px; top: -1px; left: -1px;">
<script async id="ai-adb-ga" src="https://www.google-analytics.com/analytics.js"></script>
<script async id="ai-adb-mn" src="//contextual.media.net/dmedianet.js"></script>
<script async id="ai-adb-ads" src="https://www.androidpolice.com/wp-content/plugins/ad-inserter-pro/js/ads.js?ver=2.6.19-1580162770"></script>
<script async id="ai-adb-sponsors" src="https://www.androidpolice.com/wp-content/plugins/ad-inserter-pro/js/sponsors.js?ver=2.6.19-1615915841"></script>
<script async id="ai-adb-advertising" src="https://www.androidpolice.com/wp-content/plugins/ad-inserter-pro/js/advertising.js?ver=2.6.19-1580162770"></script>
<script async id="ai-adb-adverts" src="https://www.androidpolice.com/wp-content/plugins/ad-inserter-pro/js/adverts.js?ver=2.6.19-1537401505"></script>


<script>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</script>
<script type="text/javascript">
	var templateDir = "https://www.androidpolice.com/wp-content/themes/ap2";
  var ajaxurl = "https://www.androidpolice.com/wordpress/wp-admin/admin-ajax.php";
  var blogurl = "https://www.androidpolice.com";
</script>

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5c5b5d52974ebd54"></script>

<script src="//instant.page/3.0.0" type="module" defer integrity="sha384-OeDn4XE77tdHo8pGtE1apMPmAipjoxUQ++eeJa6EtJCfHlvijigWiJpD7VDPWXV1"></script>


<script type="text/javascript">(function(){var a=document.createElement('script');a.type='text/javascript';a.async=true;a.src='https://widget.pushbullet.com/dynamic.js';var b=document.getElementsByTagName('script')[0];b.parentNode.insertBefore(a,b);})();</script>

<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>

<script type="text/javascript">
if(!ap_scrolluser){
 try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=651&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} 
}</script>


<script>
    ap_write_scroll_script({
      "type" : "text/javascript",
      "src" : "//ads.pro-market.net/ads/scripts/site-130167.js"
    });
</script>


<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-95hmrIiT9zWMo"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-95hmrIiT9zWMo.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>


<img src="https://sb.scorecardresearch.com/p?c1=2&c2=15235859&cv=2.0&cj=1" />


<script type="text/javascript" src="//s.skimresources.com/js/85009X1537243.skimlinks.js"></script>


<iframe src="https://d2r7bmv6l6bnd1.cloudfront.net/1405.html" style="position:absolute;left:-10px;width:1px;height:1px;"></iframe>


<a rel="me" href="https://mstdn.social/@androidpolice" style="display: none !important">Mastodon</a>
<script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"66ba90ec5cd5cebc","token":"a8ce4878c95b4c46a3e337c0a39e65c9","version":"2021.6.0","si":10}'></script>
</body>
</html>
