<!DOCTYPE html>
<html lang="en-US">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="pingback" href="https://www.androidpolice.com/wordpress/xmlrpc.php" />
<meta property="og:site_name" content="Android Police" />
<meta name="theme-color" content="#0041C8">
<link rel="publisher" href="https://plus.google.com/103876278794381402383" />

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=3">

<link href='//fonts.googleapis.com/css?family=Oswald|Roboto:700,500,400|Roboto+Slab' rel='stylesheet' type='text/css'>
<!--[if lt IE 9]>
    <script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
   <![endif]-->

<link rel="shortcut icon" type="image/png" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-114x114.png">
<script>
  var ap_naag_timeset = parseFloat(localStorage['naag-timeset']),
                  ap_naag_expiry  = ap_naag_timeset + 600000,
                  ap_naag_article_count = parseFloat(localStorage['naag-article-count']),
                  naag_d = new Date(),
                  naag_time = naag_d.getTime();

              console.log('APDEBUG ARTICLE COUNT: ' + ap_naag_article_count );</script>

<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-6275685-2', 'auto');
    ga('require', 'linkid', 'linkid.js');
    ga('send', 'pageview');
  </script>

<script data-ad-client="ca-pub-8776668743582988" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<title>Google’s adjusted 90-day Project Zero policy gives developers more time to deploy patches</title>
<meta name="description" content="Google announced Project Zero back in 2014 in a quest to make the internet more secure by researching software exploits and informing affected developers" />
<link rel="canonical" href="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Google’s adjusted 90-day Project Zero policy gives developers more time to deploy patches" />
<meta property="og:description" content="Google announced Project Zero back in 2014 in a quest to make the internet more secure by researching software exploits and informing affected developers" />
<meta property="og:url" content="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/" />
<meta property="og:site_name" content="Android Police - Android news, reviews, apps, games, phones, tablets" />
<meta property="article:publisher" content="https://www.facebook.com/AndroidPolice" />
<meta property="article:tag" content="Google" />
<meta property="article:tag" content="patches" />
<meta property="article:tag" content="project zero" />
<meta property="article:tag" content="security" />
<meta property="article:tag" content="security patches" />
<meta property="article:tag" content="Security Research" />
<meta property="article:tag" content="vulnerability disclosure" />
<meta property="article:section" content="Google" />
<meta property="article:published_time" content="2020-01-08T12:21:42-08:00" />
<meta property="og:image" content="https://www.androidpolice.com/wp-content/uploads/2019/11/security-bug-bounty-hero-668x445.jpg" />
<meta property="og:image:secure_url" content="https://www.androidpolice.com/wp-content/uploads/2019/11/security-bug-bounty-hero-668x445.jpg" />
<meta property="og:image:width" content="668" />
<meta property="og:image:height" content="445" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Google announced Project Zero back in 2014 in a quest to make the internet more secure by researching software exploits and informing affected developers" />
<meta name="twitter:title" content="Google’s adjusted 90-day Project Zero policy gives developers more time to deploy patches" />
<meta name="twitter:site" content="@AndroidPolice" />
<meta name="twitter:image" content="https://www.androidpolice.com/wp-content/uploads/2019/11/security-bug-bounty-hero.jpg" />
<meta name="twitter:creator" content="@ManuelVonau" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.androidpolice.com/#organization","name":"AndroidPolice","url":"https://www.androidpolice.com/","sameAs":["https://www.facebook.com/AndroidPolice","https://www.instagram.com/androidpolice/","https://www.youtube.com/androidpolice","https://twitter.com/AndroidPolice"],"logo":{"@type":"ImageObject","@id":"https://www.androidpolice.com/#logo","url":"https://www.androidpolice.com/wp-content/uploads/2019/07/android_police_extended_text_logo_white1.png","width":367,"height":60,"caption":"AndroidPolice"},"image":{"@id":"https://www.androidpolice.com/#logo"}},{"@type":"WebSite","@id":"https://www.androidpolice.com/#website","url":"https://www.androidpolice.com/","name":"Android Police - Android news, reviews, apps, games, phones, tablets","publisher":{"@id":"https://www.androidpolice.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.androidpolice.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/#primaryimage","url":"https://www.androidpolice.com/wp-content/uploads/2019/11/security-bug-bounty-hero.jpg","width":5184,"height":3456},{"@type":"WebPage","@id":"https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/#webpage","url":"https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/","inLanguage":"en-US","name":"Google\u2019s adjusted 90-day Project Zero policy gives developers more time to deploy patches","isPartOf":{"@id":"https://www.androidpolice.com/#website"},"primaryImageOfPage":{"@id":"https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/#primaryimage"},"datePublished":"2020-01-08T12:21:42-08:00","dateModified":"2020-01-08T12:21:42-08:00","description":"Google announced Project Zero back in 2014 in a quest to make the internet more secure by researching software exploits and informing affected developers"},{"@type":"NewsArticle","@id":"https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/#article","isPartOf":{"@id":"https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/#webpage"},"author":{"@id":"https://www.androidpolice.com/#/schema/person/d70c941d1c8748558c83605cb41e30c3"},"headline":"Google\u2019s adjusted 90-day Project Zero policy gives developers more time to deploy patches","datePublished":"2020-01-08T12:21:42-08:00","dateModified":"2020-01-08T12:21:42-08:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/#webpage"},"publisher":{"@id":"https://www.androidpolice.com/#organization"},"image":{"@id":"https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/#primaryimage"},"keywords":"Google,patches,project zero,security,security patches,Security Research,vulnerability disclosure","articleSection":"Google,News,Security","copyrightYear":"2020","copyrightHolder":{"@id":"https://www.androidpolice.com#organization"}},{"@type":["Person"],"@id":"https://www.androidpolice.com/#/schema/person/d70c941d1c8748558c83605cb41e30c3","name":"Manuel Vonau","image":{"@type":"ImageObject","@id":"https://www.androidpolice.com/#authorlogo","url":"https://secure.gravatar.com/avatar/b447ee27a4ac763a63290f2351c08251?s=96&d=mm&r=x","caption":"Manuel Vonau"},"description":"Manuel is a tech enthusiast and Android fan based in Berlin. When he's not writing articles for Android Police, he's either out and about as a videographer or working on a script.","sameAs":["https://twitter.com/ManuelVonau"]}]}</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; Feed" href="https://www.androidpolice.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; Comments Feed" href="https://www.androidpolice.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; Google’s adjusted 90-day Project Zero policy gives developers more time to deploy patches Comments Feed" href="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.androidpolice.com\/wordpress\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style type="text/css">
			.mistape-test, .mistape_mistake_inner {color: #E42029 !important;}
			#mistape_dialog h2::before, #mistape_dialog .mistape_action, .mistape-letter-back {background-color: #E42029 !important; }
			#mistape_reported_text:before, #mistape_reported_text:after {border-color: #E42029 !important;}
            .mistape-letter-front .front-left {border-left-color: #E42029 !important;}
            .mistape-letter-front .front-right {border-right-color: #E42029 !important;}
            .mistape-letter-front .front-bottom, .mistape-letter-back > .mistape-letter-back-top, .mistape-letter-top {border-bottom-color: #E42029 !important;}
            .mistape-logo svg {fill: #E42029 !important;}
		</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.androidpolice.com/wordpress/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='avatar-manager-css' href='https://www.androidpolice.com/wp-content/plugins/avatar-manager/assets/css/avatar-manager.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='qc-choice-css' href='https://www.androidpolice.com/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpappbox-css' href='https://www.androidpolice.com/wp-content/plugins/wp-appbox/css/styles.min.css?ver=4.1.25' type='text/css' media='screen' />
<link rel='stylesheet' id='wp-polls-css' href='https://www.androidpolice.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.androidpolice.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='mistape-front-css' href='https://www.androidpolice.com/wp-content/plugins/mistape/assets/css/mistape-front.css?ver=1.3.8' type='text/css' media='all' />
<link rel='stylesheet' id='layout-css' href='https://www.androidpolice.com/wp-content/themes/ap2/stylesheets/layout.css?ver=1575481108' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.androidpolice.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.10' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.androidpolice.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.9.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ai_front = {"wp_ai":"5.3.2+2.5.10","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/ad-inserter-pro/includes/js/ai-jquery.js?ver=5.3.2+2.5.10'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/avatar-manager/assets/js/avatar-manager.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=1.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var qc_choice_init = "{\"Publisher Purpose IDs\":[1,2,3,4,5],\"No Option\":false,\"Display UI\":\"inEU\",\"Min Days Between UI Displays\":90,\"Non-Consent Display Frequency\":90,\"Publisher Name\":\"Illogical Robot LLC\",\"Publisher Logo\":\"https:\\\/\\\/www.androidpolice.com\\\/wp-content\\\/themes\\\/ap2\\\/images\\\/android-police-logo-599.png\",\"Initial Screen Title Text\":\"We value your privacy\",\"Initial Screen Body Text\":\"The quality content and information we provide to you depends on the revenue we generate from advertising. We and our partners use your personal data in order to serve personalised advertising, measure activity on the site and deliver personalised features and content to you. Click below to consent to the use of your data. You can revisit your choices at any time.\",\"Initial Screen Reject Button Text\":\"I do not accept\",\"Initial Screen Accept Button Text\":\"I accept\",\"Initial Screen Purpose Link Text\":\"Show Purposes\",\"Purpose Screen Header Title Text\":\"Privacy Settings\",\"Purpose Screen Title Text\":\"We value your privacy\",\"Purpose Screen Body Text\":\"You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.\",\"Purpose Screen Enable All Button Text\":\"Enable all purposes\",\"Purpose Screen Vendor Link Text\":\"See full vendor list\",\"Purpose Screen Cancel Button Text\":\"Cancel\",\"Purpose Screen Save and Exit Button Text\":\"Save & Exit\",\"Vendor Screen Title Text\":\"We value your privacy\",\"Vendor Screen Body Text\":\"You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.\",\"Vendor Screen Reject All Button Text\":\"Reject All\",\"Vendor Screen Accept All Button Text\":\"Accept all\",\"Vendor Screen Purposes Link Text\":\"Back to purposes\",\"Vendor Screen Cancel Button Text\":\"Cancel\",\"Vendor Screen Save and Exit Button Text\":\"Save & Exit\",\"Language\":\"EN\",\"Initial Screen Body Text Option\":1,\"UI Layout\":\"banner\",\"Custom Links Displayed on Initial Screen\":[\"[Find out more by reading our privacy and cookie policies](https:\\\/\\\/www.androidpolice.com\\\/androidpolice-com-privacy-policy\\\/)\",\"[How Google uses information from sites](https:\\\/\\\/policies.google.com\\\/technologies\\\/partner-sites)\"]}";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/quantcast-choice/public/js/script.async.min.js?ver=1.2.1'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.androidpolice.com/wordpress/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.androidpolice.com/wordpress/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://www.androidpolice.com/?p=653434' />
<link rel="alternate" type="application/json+oembed" href="https://www.androidpolice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.androidpolice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style><link rel="amphtml" href="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/?amp">

<meta name="flattr:id" content="j099pg">

</head>
<body class="post-template-default single single-post postid-653434 single-format-image">

<div id="tip-us">
<div id="tip-us-container" class="container">
<div class="sixteen columns">
<div class="tip-us-wrapper">
<div class="tip-us-header">
<a href="#" class="btn-close" title="Close"><i class="icon-exit"></i></a>
<h2 class="modal-heading">Tip Us</h2>
</div>
<div class="tip-us-body">
<div class="ap-loader"></div>
</div>
</div>
</div>
</div>
</div>
<div class="band header hidden-phone">
<div class="container">
<div class="sixteen columns">
<a href="https://www.androidpolice.com"><h1 class="logo">Android Police</h1></a>
<div class='ains ains-1 ains-ap2_header_1' data-ai='WzEsMCwiYXAyX2hlYWRlcl8xIiwiIl0=' style=''>
<style type="text/css">
.ains-1,
.adslot_ap2_header_1 { display: none; }
@media (min-width: 768px) {
  .adslot_ap2_header_1 { display:inline-block; width: 728px; height: 90px;} 
  .band.header .sixteen.columns{
  	display: flex;
  	height: 120px;
  }
  .ains-1{
  	width: 100%;
  	display: flex;
  	align-items: center;
  	justify-content: center;
  }
  .ains-1 .ezoic-ad.box-2{
  	min-height: auto !important;
  	margin: 0 !important;
  }
}
</style>
<div id="ezoic-pub-ad-placeholder-130">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_header_1" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="3439725683"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
</div>
</div>
</div>
<div class="band nav">
<div class="ap-nav-wrapper">
<div class="container">
<ul class="mobile-nav list-unstyled">
<li class="depth-priority">
<a id="ap-menu-button" href="#" class="menu">
<span class="ap-bar"></span>
<span class="ap-bar"></span>
<span class="ap-bar"></span>
</a>
<a class="search-box-close visible-handheld hidden">
<i class="icon-backarrow"></i>
</a>
</li>
<li>
<a href="https://www.androidpolice.com" id="ap-logo-small">
<i class="icon-ap"></i>
</a>
</li>
<li>
<a id="search-btn-a" class="search-btn depth-priority" onclick="firstIconClick(event)"><i class="icon-search"></i></a>
<div class="search-box" id="search-box">
<form role="search" method="get" id="searchform" action="https://www.androidpolice.com/" autocomplete="off">
<input class="textfield" type="search" name="s" id="s" placeholder="Search" value="" autocomplete="off" />
<input type="hidden" name="order" value="rel" />
<div class="cat-select">
<ul class="cat-ul list-unstyled">
</ul>
</div>
</form>
</div>
</li>
<li class="ap-new-articles">
<a class="ap-new-articles-btn ap-btn-red" href="#">
<span id="ap-new-articles-num" class="ap-new-articles-num"></span>
<script>
              apNewArticlesNum = document.getElementById("ap-new-articles-num");
              console.log('APDEBUG EL: ' + apNewArticlesNum);
              console.log('APDEBUG ARTICLE COUNT: naag_time = ' + naag_time + ', ap_naag_expiry = ' + ap_naag_expiry);
              if ( !isNaN(ap_naag_article_count) && naag_time < ap_naag_expiry ) {
                apNewArticlesNum.innerHTML = ap_naag_article_count;
                console.log('APDEBUG ARTICLE COUNT: updating content with ' + ap_naag_article_count);
              }
              else {
                console.log('APDEBUG ARTICLE COUNT: DID NOT UPDATE');
              }
            </script>
<span class="ap-new-articles-lable">New<br>Articles</span>
<i class="icon-sort-down"></i>
</a>
</li>
</ul>
<ul id="menu-primary-nav" class="primary-nav ap-panel" role="navigation">
<li id="nav-menu-item-294419" rel="news"><a class='ap-nav-primary' href="https://www.androidpolice.com/news/">News<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294419'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294423" rel="news"><a class='ap-nav-sub' href="https://www.androidpolice.com/news/">Latest news</a></li>
<li id="nav-menu-item-567472" rel="android-10"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/android-10/">Android 10</a></li>
<li id="nav-menu-item-516250" rel="android-9-pie"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/android-9-pie/">Android 9 Pie</a></li>
<li id="nav-menu-item-294428" rel="android-os"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/">Android OS</a></li>
<li id="nav-menu-item-294429" rel="wearables"><a class='ap-nav-sub' href="https://www.androidpolice.com/wearables/">Smartwatches &#038; Wearables</a></li>
<li id="nav-menu-item-294598" rel="android-tv-android-os"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/android-tv-android-os/">Android TV</a></li>
<li id="nav-menu-item-294597" rel="android-auto"><a class='ap-nav-sub' href="https://www.androidpolice.com/android-os/android-auto/">Android Auto</a></li>
<li id="nav-menu-item-294426" rel="dev-development"><a class='ap-nav-sub' href="https://www.androidpolice.com/dev-development/">Development</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/news/'>More News...</a></div></div>
</li>
<li id="nav-menu-item-294420" rel="applications-games"><a class='ap-nav-primary' href="https://www.androidpolice.com/applications-games/">Apps/Games<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294420'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294425" rel="games"><a class='ap-nav-sub' href="https://www.androidpolice.com/applications-games/games/">Games</a></li>
<li id="nav-menu-item-294424" rel="apps"><a class='ap-nav-sub' href="https://www.androidpolice.com/applications-games/apps/">Applications</a></li>
<li id="nav-menu-item-294430" rel="roundups"><a class='ap-nav-sub' href="https://www.androidpolice.com/roundups/">Roundups</a></li>
<li id="nav-menu-item-294431" rel="app-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/app-reviews/">App Reviews</a></li>
<li id="nav-menu-item-294432" rel="game-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/game-reviews/">Game Reviews</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/applications-games/'>More Apps/Games...</a></div></div>
</li>
<li id="nav-menu-item-294421" rel="reviews"><a class='ap-nav-primary' href="https://www.androidpolice.com/reviews/">Reviews<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294421'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294435" rel="reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/">All reviews</a></li>
<li id="nav-menu-item-294434" rel="phone-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/phone-reviews/">Phone Reviews</a></li>
<li id="nav-menu-item-294436" rel="tablet-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/tablet-reviews/">Tablet Reviews</a></li>
<li id="nav-menu-item-294437" rel="wearable-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/wearable-reviews/">Wearable Reviews</a></li>
<li id="nav-menu-item-294433" rel="other-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/reviews/other-reviews/">Other Reviews</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/reviews/'>More Reviews...</a></div></div>
</li>
<li id="nav-menu-item-294422" rel="phones-devices"><a class='ap-nav-primary' href="https://www.androidpolice.com/phones-devices/">Devices<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294422'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-535290" rel="google-phones-devices"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/google-phones-devices/">Google</a></li>
<li id="nav-menu-item-294438" rel="samsung"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/samsung/">Samsung</a></li>
<li id="nav-menu-item-294594" rel="lg"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/lg/">LG</a></li>
<li id="nav-menu-item-535291" rel="xiaomi"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/xiaomi/">Xiaomi</a></li>
<li id="nav-menu-item-294440" rel="motorola"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/motorola/">Motorola</a></li>
<li id="nav-menu-item-294441" rel="sony"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/sony/">Sony</a></li>
<li id="nav-menu-item-294439" rel="htc"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/htc/">HTC</a></li>
<li id="nav-menu-item-294595" rel="huawei"><a class='ap-nav-sub' href="https://www.androidpolice.com/phones-devices/huawei/">Huawei</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/phones-devices/'>More Devices...</a></div></div>
</li>
<li id="menu-item-294411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294411"><a href="https://www.androidpolice.com/news/leak/">Leaks</a></li>
<li id="menu-item-294412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294412"><a href="https://www.androidpolice.com/news/exclusive/">Exclusives</a></li>
<li id="menu-item-294413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294413"><a href="https://www.androidpolice.com/downloads/">Downloads</a></li>
<li id="menu-item-294414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294414"><a href="https://www.androidpolice.com/deals/">Deals</a></li>
<li id="menu-item-294415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294415"><a href="https://www.androidpolice.com/contests/">Giveaways</a></li>
<li id="menu-item-294416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294416"><a href="https://www.androidpolice.com/features/">Features</a></li>
<li id="menu-item-294417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294417"><a href="https://www.androidpolice.com/editorials/">Editorials</a></li>
<li id="menu-item-435701" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435701"><a title="donate" href="https://www.androidpolice.com/subscribe-donate/">Donate</a></li>
<li><a class="tip-us" href="https://www.androidpolice.com/contact">Tip Us</a></li> </ul>
</div>
<div class="ap-panel ap-panel-news">
<div class="container">
<div id="news-slider"></div>
<div class="fs-navigation">
<a href="" class="fs-control fs-control-prev"><i class='icon-caret-left'></i> Prev</a>
<div class="fs-control fs-control-filters disabled">
<span>Posts in the last </span>
<div class="ap-dropdown ap-filter-time">
<a class="ap-dropdown-trigger active" href=""><span>24 Hours</span><i class="icon-sort-down"></i></a>
<ul class="list-unstyled ap-dropdown-content ap-dropdown-content-bottom depth3">
<li><a class="active" href="" data-function="ap_news_updater" data-time="24">24 Hours</a></li>
<li><a href="" data-function="ap_news_updater" data-time="48">48 Hours</a></li>
<li><a href="" data-function="ap_news_updater" data-time="72">72 Hours</a></li>
</ul>
</div>
<span>sorted by </span>
<div class="ap-dropdown ap-filter-criteria">
<a class="ap-dropdown-trigger active" href="#"><span>Hottest</span><i class="icon-sort-down"></i></a>
<ul class="list-unstyled ap-dropdown-content ap-dropdown-content-bottom depth3">
<li><a class="active" href="" data-function="ap_news_updater" data-criteria="hottest">Hottest</a></li>
<li><a href="" data-function="ap_news_updater" data-criteria="latest">Latest</a></li>
<li><a href="" data-function="ap_news_updater" data-criteria="comments">Comments</a></li>
</ul>
</div>
</div>
<a href="" class="fs-control fs-control-next">Next <i class='icon-caret-right'></i></a>
</div>
</div>
</div>
</div>

</div>
<div class="band sub-nav main">
<div class="container">
<div class="sixteen columns">
<nav>
<ul id="menu-quick-menu-1" class="sub-nav"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294411"><a href="https://www.androidpolice.com/news/leak/">Leaks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294412"><a href="https://www.androidpolice.com/news/exclusive/">Exclusives</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294413"><a href="https://www.androidpolice.com/downloads/">Downloads</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294414"><a href="https://www.androidpolice.com/deals/">Deals</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294415"><a href="https://www.androidpolice.com/contests/">Giveaways</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294416"><a href="https://www.androidpolice.com/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294417"><a href="https://www.androidpolice.com/editorials/">Editorials</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435701"><a title="donate" href="https://www.androidpolice.com/subscribe-donate/">Donate</a></li>
<li class="fl-right"><a class="tip-us ap-btn-red" href="https://www.androidpolice.com/contact" data-lightbox-type="ajax">Tip Us</a></li></ul>
</nav>
</div>
</div>
</div>
<div class="band content main single">
<div class="container" id="ap-body">
<div class="primary column">
<div class='ains ains-2 ains-ap2_header_2' data-ai='WzIsMCwiYXAyX2hlYWRlcl8yIiwiIl0=' style=''>
<style type="text/css">
.ains-2 { margin: 0 auto 10px; }
@media (min-width: 599px) { .ains-2 { margin-top: 0px; margin-bottom: 20px } }
@media (min-width: 768px) { .ains-2 { display: none !important; } }
</style>
<div id="ezoic-pub-ad-placeholder-133">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_header_2" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="8936001924" data-ad-format="horizontal" data-full-width-responsive="false"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<div class="large-post single post post-653434 type-post status-publish format-image has-post-thumbnail hentry category-google-phones-devices category-news category-security tag-google tag-patches tag-project-zero tag-security tag-security-patches tag-security-research tag-vulnerability-disclosure post_format-post-format-image" id="post-653434">
<header class="post-header">
<a class="comment-btn" href="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/#disqus_thread">0</a><div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:37.93269983681%;"></div></div><h2 itemprop="name"><a href="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/">Google’s adjusted 90-day Project Zero policy gives developers more time to deploy patches</a></h2><div class="post-meta">
<a class="author-pic hidden-phone" href="https://www.androidpolice.com/author/manuel-vonau/"><img alt='' src='https://secure.gravatar.com/avatar/b447ee27a4ac763a63290f2351c08251?s=50&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/b447ee27a4ac763a63290f2351c08251?s=100&#038;d=mm&#038;r=x 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>
<span class="post-author"><a class="author-name" href="https://www.androidpolice.com/author/manuel-vonau/ ">Manuel Vonau</a></span><div class="card card-small card-popup card-author depth3">
<div class="card-inner">
</div>
<div class="card-action"><a href="https://twitter.com/ManuelVonau" class="twitter-follow-button fl-left" data-show-count="false" data-size="medium" data-show-screen-name="false">Follow</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if (!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><a href="https://www.androidpolice.com/author/manuel-vonau/" class="card-action-btn fl-right">View All Posts</a>
</div>
</div><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/08 4:21am PST</time><time class="timeago" datetime="2020-01-08T04:21:42-08:00">Jan 8, 2020</time></div> </div><div class="share-box"><div class="addthis_inline_share_toolbox" data-url="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/" data-title="Google’s adjusted 90-day Project Zero policy gives developers more time to deploy patches"></div><div class="addthis_fallback"><div class="at-share-btn-elements"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F" target="_blank" class="facebook-color"><span class="icon-facebook"></span></a><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F&text=Google%E2%80%99s+adjusted+90-day+Project+Zero+policy+gives+developers+more+time+to+deploy+patches" target="_blank" class="twitter-color"><span class="icon-twitter"></span></a><a href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F&title=Google%E2%80%99s+adjusted+90-day+Project+Zero+policy+gives+developers+more+time+to+deploy+patches" target="_blank" class="reddit-color"><span class="icon-reddit"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 32 32" version="1.1" role="img" aria-labelledby="at-svg-reddit-3" class="at-icon at-icon-reddit"><g><path d="M27 15.5a2.452 2.452 0 0 1-1.338 2.21c.098.38.147.777.147 1.19 0 1.283-.437 2.47-1.308 3.563-.872 1.092-2.06 1.955-3.567 2.588-1.506.634-3.143.95-4.91.95-1.768 0-3.403-.316-4.905-.95-1.502-.632-2.69-1.495-3.56-2.587-.872-1.092-1.308-2.28-1.308-3.562 0-.388.045-.777.135-1.166a2.47 2.47 0 0 1-1.006-.912c-.253-.4-.38-.842-.38-1.322 0-.678.237-1.26.712-1.744a2.334 2.334 0 0 1 1.73-.726c.697 0 1.29.26 1.78.782 1.785-1.258 3.893-1.928 6.324-2.01l1.424-6.467a.42.42 0 0 1 .184-.26.4.4 0 0 1 .32-.063l4.53 1.006c.147-.306.368-.553.662-.74a1.78 1.78 0 0 1 .97-.278c.508 0 .94.18 1.302.54.36.36.54.796.54 1.31 0 .512-.18.95-.54 1.315-.36.364-.794.546-1.302.546-.507 0-.94-.18-1.295-.54a1.793 1.793 0 0 1-.533-1.308l-4.1-.92-1.277 5.86c2.455.074 4.58.736 6.37 1.985a2.315 2.315 0 0 1 1.757-.757c.68 0 1.256.242 1.73.726.476.484.713 1.066.713 1.744zm-16.868 2.47c0 .513.178.95.534 1.315.356.365.787.547 1.295.547.508 0 .942-.182 1.302-.547.36-.364.54-.802.54-1.315 0-.513-.18-.95-.54-1.31-.36-.36-.794-.54-1.3-.54-.5 0-.93.183-1.29.547a1.79 1.79 0 0 0-.54 1.303zm9.944 4.406c.09-.09.135-.2.135-.323a.444.444 0 0 0-.44-.447c-.124 0-.23.042-.32.124-.336.348-.83.605-1.486.77a7.99 7.99 0 0 1-1.964.248 7.99 7.99 0 0 1-1.964-.248c-.655-.165-1.15-.422-1.486-.77a.456.456 0 0 0-.32-.124.414.414 0 0 0-.306.124.41.41 0 0 0-.135.317.45.45 0 0 0 .134.33c.352.355.837.636 1.455.843.617.207 1.118.33 1.503.366a11.6 11.6 0 0 0 1.117.056c.36 0 .733-.02 1.117-.056.385-.037.886-.16 1.504-.366.62-.207 1.104-.488 1.456-.844zm-.037-2.544c.507 0 .938-.182 1.294-.547.356-.364.534-.802.534-1.315 0-.505-.18-.94-.54-1.303a1.75 1.75 0 0 0-1.29-.546c-.506 0-.94.18-1.3.54-.36.36-.54.797-.54 1.31s.18.95.54 1.315c.36.365.794.547 1.3.547z" fill-rule="evenodd"></path></g></svg></span></a><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F&title=Google%E2%80%99s+adjusted+90-day+Project+Zero+policy+gives+developers+more+time+to+deploy+patches" target="_blank" class="linkedin-color"><span class="icon-linkedin"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 32 32" version="1.1" role="img" aria-labelledby="at-svg-linkedin-6" class="at-icon at-icon-linkedin"><g><path d="M26 25.963h-4.185v-6.55c0-1.56-.027-3.57-2.175-3.57-2.18 0-2.51 1.7-2.51 3.46v6.66h-4.182V12.495h4.012v1.84h.058c.558-1.058 1.924-2.174 3.96-2.174 4.24 0 5.022 2.79 5.022 6.417v7.386zM8.23 10.655a2.426 2.426 0 0 1 0-4.855 2.427 2.427 0 0 1 0 4.855zm-2.098 1.84h4.19v13.468h-4.19V12.495z" fill-rule="evenodd"></path></g></svg></span></a></div></div></div></header><div class="categories"><ul class="post-categories list-unstyled"><li><a class="cat cat-google-phones-devices" href="https://www.androidpolice.com/phones-devices/google-phones-devices/" title="View all posts in Google">Google</a></li><li><a class="cat cat-news" href="https://www.androidpolice.com/news/" title="View all posts in News"><i class="icon-news"></i>News</a></li><li><a class="cat cat-security" href="https://www.androidpolice.com/security/" title="View all posts in Security">Security</a></li></ul></div><a class="post-hero post-hero-single" href="https://www.androidpolice.com/wp-content/uploads/2019/11/security-bug-bounty-hero.jpg"><img class="img-hero" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F11%2Fsecurity-bug-bounty-hero.jpg&w=728"></a>
<div class="post-content">
<div class='ains ains-8 ains-ap2_above_post_body' data-ai='WzgsMCwiYXAyX2Fib3ZlX3Bvc3RfYm9keSIsIiJd' style=''>
<style type="text/css">
.ains-8 { margin: 10px -10px; }
@media (min-width: 540px)  { .ains-8 { margin: 10px -20px; } }
@media (min-width: 768px)  { .ains-8 { margin: 10px -15px; } }
@media (min-width: 960px)  { .ains-8 { margin: 10px -20px; } }
@media (min-width: 1160px) { .ains-8 { margin: 10px -30px; } }
</style>
<div id="ezoic-pub-ad-placeholder-128">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_above_post_body" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4825925002" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<p></p>
<p>Google announced Project Zero <a href="https://www.androidpolice.com/2014/07/15/google-announces-project-zero-sets-its-sights-on-making-the-internet-more-secure/">back in 2014</a> in a quest to make the internet more secure by researching software exploits and informing affected developers about them. The company soon adopted a 90-days public disclosure deadline in order to speed up the patching process. In 2020, this policy will change just a little bit. Previously, vulnerabilities were published as soon as developers fixed them, but now, Google will always wait the full 90 days until it reports to the public. That's meant to ensure that patches have rolled out to more users before potential bad actors know about the exploits, thus leaving fewer people vulnerable.</p>
<p><span id="more-653434"></span></p>
<p>This change is a reaction to software vendors who believe that disclosures are harmful before a patch has reached enough users. While Google says it doesn't agree, it has still adjusted the 90 days policy to incentive these vendors to patch security holes even faster so that they have additional time to distribute the bug fixes. Google also hopes that developers will use the remaining time until disclosure to search for root causes of exploits or ripple effects of patches so that attackers can't just make minor changes to their existing strategies and continue their practices. Under mutual agreement, reports can still be published earlier, though.</p><div class="ains ains-33 ains-ap2_in_post_body_ezoic_1" data-ai="WzMzLDAsImFwMl9pbl9wb3N0X2JvZHlfZXpvaWNfMSIsIiJd" style="margin: 8px auto; text-align: center; display: block; clear: both;">
<style type="text/css">
@media (min-width: 960px) and (max-width: 1159px)  { .ains-33 { margin-left: -10px !important; margin-right: -10px !important; } }
</style>
<div id="ezoic-pub-ad-placeholder-113">
</div></div>
<p>At the same time, Google is getting stricter about actually enforcing the 90-days rule. Reports used to be published manually by researchers, but starting 2020, they'll be posted automatically on day 90. If a bug is fixed within the additional 14-day grace period on top of the 90 days vendors can ask for, the corresponding report will also be published immediately after.</p>
<p style="text-align: center;"><a href="https://www.androidpolice.com/wp-content/uploads/2020/01/project-zero-changes-2020.png" class=" no-style"><img class="alignnone size-large wp-image-653436" src="https://www.androidpolice.com/wp-content/uploads/2020/01/project-zero-changes-2020-668x499.png" alt="" width="668" height="499" srcset="https://www.androidpolice.com/wp-content/uploads/2020/01/project-zero-changes-2020-668x499.png 668w, https://www.androidpolice.com/wp-content/uploads/2020/01/project-zero-changes-2020-329x246.png 329w, https://www.androidpolice.com/wp-content/uploads/2020/01/project-zero-changes-2020-161x120.png 161w, https://www.androidpolice.com/wp-content/uploads/2020/01/project-zero-changes-2020-217x162.png 217w, https://www.androidpolice.com/wp-content/uploads/2020/01/project-zero-changes-2020-728x544.png 728w, https://www.androidpolice.com/wp-content/uploads/2020/01/project-zero-changes-2020.png 1440w" sizes="(max-width: 668px) 100vw, 668px"></a></p>
<p>Additionally, Google wants to improve how it handles incomplete fixes. While it used to file these issues either as separate vulnerabilities or added them to existing reports in the past, it now consistently wants to add them to the corresponding existing report &mdash; even when it's already published.</p><div class="ains ains-3 ains-ap2_in_post_body_1" data-ai="WzMsMCwiYXAyX2luX3Bvc3RfYm9keV8xIiwiIl0=" style="margin: 8px auto; text-align: center; display: block; clear: both;">
<style type="text/css">
@media (min-width: 960px) and (max-width: 1159px)  { .ains-3 { margin-left: -10px !important; margin-right: -10px !important; } }
</style>
<div class="ap_house_slot">
<div id="ezoic-pub-ad-placeholder-114">
<style type="text/css">
.adslot_ap2_in_post_body_1 {  }
@media (min-width: 599px) { .adslot_ap2_in_post_body_1 {  } }
@media (min-width: 768px) { .adslot_ap2_in_post_body_1 {  } }

</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_in_post_body_1" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4273329030" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div></div>
<p>Overall, Google deems Project Zero as successful since 97.7% of vulnerabilities are usually fixed within the 90-days timeframe. The changes are meant to improve the cooperation between Project Zero and software vendors. That said, the new policies are only a test run for now, and Google knows that it's hard to please everyone involved in the process. The Project Zero team wants to re-evaluate whether the changes work and might adjust the program again in late 2020.</p>
<div class="clear pre-horizontal-boxes"></div><ul class="list-unstyled list-inline list-emphasis"><li class="title"><strong>Source: </strong></li><li><a href="https://googleprojectzero.blogspot.com/2020/01/policy-and-disclosure-2020-edition.html" class="external" rel="nofollow" target="_blank">Google</a></li></ul>
</div>
<div class="post-footer-meta">
<ul class="horizontal-boxes list-unstyled horizontal-boxes-tags"><li class="title green-border header-bg green-bg">Tags</li><li><a href="https://www.androidpolice.com/tags/google/" rel="tag">Google</a></li><li><a href="https://www.androidpolice.com/tags/patches/" rel="tag">patches</a></li><li><a href="https://www.androidpolice.com/tags/project-zero/" rel="tag">project zero</a></li><li><a href="https://www.androidpolice.com/tags/security/" rel="tag">security</a></li><li><a href="https://www.androidpolice.com/tags/security-patches/" rel="tag">security patches</a></li><li><a href="https://www.androidpolice.com/tags/security-research/" rel="tag">Security Research</a></li><li><a href="https://www.androidpolice.com/tags/vulnerability-disclosure/" rel="tag">vulnerability disclosure</a></li></ul>
<a href="#" class="btn btn-small btn-pb btn-subscribe" data-trigger="reveal" data-target="card-pb" data-function="apLoadPushbullet"><i class="icon-pushbullet"></i>subscribe</a>
<div class="clear"></div>
<div id="card-pb" class="card card-popup card-pb depth3">
<div class="card-inner"></div>
</div>
<div class="addthis_post_footer addthis_inline_share_toolbox_ax6f" data-url="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/" data-title="Google’s adjusted 90-day Project Zero policy gives developers more time to deploy patches"></div><div class="addthis_fallback"><div class="at-share-btn-elements"><a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F" target="_blank" class="facebook-color"><span class="icon-facebook"></span></a><a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F&text=Google%E2%80%99s+adjusted+90-day+Project+Zero+policy+gives+developers+more+time+to+deploy+patches" target="_blank" class="twitter-color"><span class="icon-twitter"></span></a><a href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F&title=Google%E2%80%99s+adjusted+90-day+Project+Zero+policy+gives+developers+more+time+to+deploy+patches" target="_blank" class="reddit-color"><span class="icon-reddit"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 32 32" version="1.1" role="img" aria-labelledby="at-svg-reddit-3" class="at-icon at-icon-reddit"><g><path d="M27 15.5a2.452 2.452 0 0 1-1.338 2.21c.098.38.147.777.147 1.19 0 1.283-.437 2.47-1.308 3.563-.872 1.092-2.06 1.955-3.567 2.588-1.506.634-3.143.95-4.91.95-1.768 0-3.403-.316-4.905-.95-1.502-.632-2.69-1.495-3.56-2.587-.872-1.092-1.308-2.28-1.308-3.562 0-.388.045-.777.135-1.166a2.47 2.47 0 0 1-1.006-.912c-.253-.4-.38-.842-.38-1.322 0-.678.237-1.26.712-1.744a2.334 2.334 0 0 1 1.73-.726c.697 0 1.29.26 1.78.782 1.785-1.258 3.893-1.928 6.324-2.01l1.424-6.467a.42.42 0 0 1 .184-.26.4.4 0 0 1 .32-.063l4.53 1.006c.147-.306.368-.553.662-.74a1.78 1.78 0 0 1 .97-.278c.508 0 .94.18 1.302.54.36.36.54.796.54 1.31 0 .512-.18.95-.54 1.315-.36.364-.794.546-1.302.546-.507 0-.94-.18-1.295-.54a1.793 1.793 0 0 1-.533-1.308l-4.1-.92-1.277 5.86c2.455.074 4.58.736 6.37 1.985a2.315 2.315 0 0 1 1.757-.757c.68 0 1.256.242 1.73.726.476.484.713 1.066.713 1.744zm-16.868 2.47c0 .513.178.95.534 1.315.356.365.787.547 1.295.547.508 0 .942-.182 1.302-.547.36-.364.54-.802.54-1.315 0-.513-.18-.95-.54-1.31-.36-.36-.794-.54-1.3-.54-.5 0-.93.183-1.29.547a1.79 1.79 0 0 0-.54 1.303zm9.944 4.406c.09-.09.135-.2.135-.323a.444.444 0 0 0-.44-.447c-.124 0-.23.042-.32.124-.336.348-.83.605-1.486.77a7.99 7.99 0 0 1-1.964.248 7.99 7.99 0 0 1-1.964-.248c-.655-.165-1.15-.422-1.486-.77a.456.456 0 0 0-.32-.124.414.414 0 0 0-.306.124.41.41 0 0 0-.135.317.45.45 0 0 0 .134.33c.352.355.837.636 1.455.843.617.207 1.118.33 1.503.366a11.6 11.6 0 0 0 1.117.056c.36 0 .733-.02 1.117-.056.385-.037.886-.16 1.504-.366.62-.207 1.104-.488 1.456-.844zm-.037-2.544c.507 0 .938-.182 1.294-.547.356-.364.534-.802.534-1.315 0-.505-.18-.94-.54-1.303a1.75 1.75 0 0 0-1.29-.546c-.506 0-.94.18-1.3.54-.36.36-.54.797-.54 1.31s.18.95.54 1.315c.36.365.794.547 1.3.547z" fill-rule="evenodd"></path></g></svg></span></a><a href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.androidpolice.com%2F2020%2F01%2F08%2Fgoogle-project-zero-90-day-policy-adjusted%2F&title=Google%E2%80%99s+adjusted+90-day+Project+Zero+policy+gives+developers+more+time+to+deploy+patches" target="_blank" class="linkedin-color"><span class="icon-linkedin"><svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 32 32" version="1.1" role="img" aria-labelledby="at-svg-linkedin-6" class="at-icon at-icon-linkedin"><g><path d="M26 25.963h-4.185v-6.55c0-1.56-.027-3.57-2.175-3.57-2.18 0-2.51 1.7-2.51 3.46v6.66h-4.182V12.495h4.012v1.84h.058c.558-1.058 1.924-2.174 3.96-2.174 4.24 0 5.022 2.79 5.022 6.417v7.386zM8.23 10.655a2.426 2.426 0 0 1 0-4.855 2.427 2.427 0 0 1 0 4.855zm-2.098 1.84h4.19v13.468h-4.19V12.495z" fill-rule="evenodd"></path></g></svg></span></a></div></div> </div>
<div class='ains ains-9 ains-ap2_below_post_body' data-ai='WzksMCwiYXAyX2JlbG93X3Bvc3RfYm9keSIsIiJd' style=''>
<style type="text/css">
.ains-9 { margin: 10px -10px 0; }
@media (min-width: 540px) { .ains-9 { margin: 10px -20px 0; } }
@media (min-width: 599px) { .ains-9 { margin: 20px -20px 0; } }
@media (min-width: 768px) { .ains-9 { margin: 20px -15px 0; } }
@media (min-width: 960px) { .ains-9 { margin: 30px -20px 0; } }
@media (min-width: 1160px) { .ains-9 { margin: 30px -30px 0; } }
</style>
<div id="ezoic-pub-ad-placeholder-129">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_below_post_body" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="7266108282" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
<div class="OUTBRAIN" data-src="https://www.androidpolice.com/2020/01/08/google-project-zero-90-day-policy-adjusted/" data-widget-id="AR_1" data-ob-template="IllogicalRobot"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
</div>
<div class="post-footer">
 <div class="article-nav">
<div class="article-nav-box ">
<a href="https://www.androidpolice.com/2020/01/08/xiaomi-mi-box-s-android-9-pie-beta/#disqus_thread" class="comment-btn">...</a>
<a href="https://www.androidpolice.com/2020/01/08/xiaomi-mi-box-s-android-9-pie-beta/">
<div class="article-nav-box-content">
<h4 class="first-heading"><span>Previous</span> Story</h4>
<div class="article-nav-box-title">
<div class="ellipsize">
<h5>Xiaomi's Mi Box S Android TV picks up Pie beta (Update: Stable rolling out)</h5>
</div>
</div>
</div>
<div class="frame">
<div class="frame-image-wrapper">
<img class="centered animate" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F10%2Fmi-box-s-hero.png&h=129&zc=3" alt="">
</div>
<img class="bg animate" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F10%2Fmi-box-s-hero.png&w=150&h=85&zc=1&f=8|8|8|8|8|8|8|8|8|8|8|8|8" alt="">
</div>
</a>
</div>
<div class="article-nav-box ">
<a href="https://www.androidpolice.com/2020/01/08/plex-streaming-channels-rentals-purchases-deep-links/#disqus_thread" class="comment-btn">...</a>
<a href="https://www.androidpolice.com/2020/01/08/plex-streaming-channels-rentals-purchases-deep-links/">
<div class="article-nav-box-content">
<h4 class="first-heading"><span>Next</span> Story</h4>
<div class="article-nav-box-title">
<div class="ellipsize">
<h5>Plex details upcoming features including subscription channels, rentals, and purchases</h5>
</div>
</div>
</div>
<div class="frame">
<div class="frame-image-wrapper">
<img class="centered animate" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fplex-hero.png&h=129&zc=3" alt="">
</div>
<img class="bg animate" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fplex-hero.png&w=150&h=85&zc=1&f=8|8|8|8|8|8|8|8|8|8|8|8|8" alt="">
</div>
</a>
</div>
</div>
<div class="post-footer-inner">
<div class="single-post-widget">
<div id="appopularposts-7" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><header class="section-header"><h4 class="header-bg">Trending</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/08/galaxy-note10-note10-android-10/#comments">146</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999997244674%;"></div></div>
<a class="cell-link" href="/2020/01/08/galaxy-note10-note10-android-10/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F08%2Fgalaxy-note10-01804.jpg&w=60&h=60">
<div class="cell-content">
<h4>Stable Android 10 starts hitting the Galaxy Note10 and Note10+ (Update: UK Note10+ 5G, Indonesia)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/08 3:25am PST</time><time class="timeago" datetime="2020-01-08T03:25:24-08:00">Jan 8, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/12/26/android-10-oneplus-6t-oxygenos-10/#comments">132</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998231386094%;"></div></div>
<a class="cell-link" href="/2019/12/26/android-10-oneplus-6t-oxygenos-10/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F11%2FOnePlus-6T-Thunder-Purple-hero.jpg&w=60&h=60">
<div class="cell-content">
<h4>OnePlus 6 and 6T Android 10 update rolling out again as Oxygen OS 10.0.1 (Update: 10.3.0 ROMs)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/26 3:12pm PST</time><time class="timeago" datetime="2019-12-26T15:12:28-08:00">Dec 26, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/12/12/google-pixel-pin-lock-screen-loop-help/#comments">198</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.993920251845%;"></div></div>
<a class="cell-link" href="/2019/12/12/google-pixel-pin-lock-screen-loop-help/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F09%2Fpixel-xl-pin-lock-screen-loop.gif&w=60&h=60">
<div class="cell-content">
<h4>Pixel lockscreen PIN bug is making phones unusable (Update: OnePlus, Sony devices affected)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/12 8:11am PST</time><time class="timeago" datetime="2019-12-12T08:11:12-08:00">Dec 12, 2019</time></div></div>
</div>
</a>
</li></ul></section><div class='ains ains-11 ains-ap2_trending_posts_wrapper' data-ai='WzExLDAsImFwMl90cmVuZGluZ19wb3N0c193cmFwcGVyIiwiIl0=' style=''>
<style type="text/css">
.ains-11 { }
@media (min-width: 960px) { .ains-11 { float: left; width: 320px; height: 270px; display: flex;align-items: center;justify-content: center;} }
</style>
<div id="ezoic-pub-ad-placeholder-122">
<div class='adslot_ap2_trending_posts_wrapper'>
<style type="text/css">
    .adslot_ap2_trending_posts {width: 336px; height: 280px}
    @media (min-width: 960px) { .adslot_ap2_trending_posts { width: 300px; height: 250px; } }
    </style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_trending_posts" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="3021676711" data-full-width-responsive="false"></ins>
<script>
    (adsbygoogle = window.adsbygoogle || []).push({});
    </script>
</div>
</div></div>
</div> </div>
<div id="comments">
<header class="section-header ">
<h4 class="header-bg blue-bg">Comments</h4>
</header>
<a name="comments"></a>
<section>
<div id="disqus_thread"></div>
</section>
</div>
</div>
</div>
<center>
<div class='ains ains-13 ains-ap2_footer_small' data-ai='WzEzLDAsImFwMl9mb290ZXJfc21hbGwiLCIiXQ==' style=''>
<div id="ezoic-pub-ad-placeholder-134">
<style type="text/css">
.adslot_ap2_footer_little { margin-bottom: 10px; }
@media (min-width: 599px) { .adslot_ap2_footer_little { margin-bottom: 20px; } }
@media (min-width: 768px) { .adslot_ap2_footer_little { display: none !important; } }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_footer_little" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="9594790476" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
</center>
</div>
<div id="sbar" class="secondary column">
<ul id="sbar-content" class="list-unstyled">
<li id="ai_widget-2" class="widget-odd widget-first widget-1  none widget ai_widget"><div class='ains ains-14 ains-ap2_sidebar_1' data-ai='WzE0LDJd' style=''>
<div id="ezoic-pub-ad-placeholder-123">
<div class="adslot_ap2_sidebar_1">
<script type="text/javascript">
if (window.matchMedia("(min-width: 768px)").matches) {
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - 300x250_sidebar_1 */
google_ad_slot = "1402978658";
google_ad_width = 300;
google_ad_height = 250;
//-->

document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}
</script>
</div>
</div></div>
</li>
<li id="apfollowwidget-2" class="widget-even widget-2 red widget ap-follow-widget"><header class="section-header"><h4 class="header-bg">Follow Android Police</h4></header>
<section class="card">
<div class="card-inner">
<div class="multi-column"> <div class="one-third">
<a class="ap-follow-btn" title="Follow Android Police on Twitter" class="" href="https://twitter.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon twitter-color"><i class="icon-twitter"></i></div>
<span class="ap-sidebar-title">499k</span>
</a>
</div>
<div class="one-third">
<a class="ap-follow-btn" title="Like Android Police on Facebook" class="" href="https://facebook.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon facebook-color"><i class="icon-facebook"></i></div>
<span class="ap-sidebar-title"></span>
</a>
</div>
<div class="one-third">
<a class="ap-follow-btn" title="Subscribe on YouTube" class="" href="https://youtube.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon youtube-color"><i class="icon-youtube"></i></div>
<span class="ap-sidebar-title">318k</span>
</a>
</div>
</div><div class="multi-column"> <div class="one-third">
<a class="ap-follow-btn" title="Follow on Twitch" class="" href="https://twitch.tv/androidpolice" target="_blank">
<div class="ap-follow-icon twitch-color"><i class="icon-twitch"></i></div>
<span class="ap-sidebar-title">8.89k</span>
</a>
</div>
</div>
</div>
<div class="card-action">
<a class="currents ap-follow-btn" title="Subscribe to the RSS feed" href="/feed" target="_blank">
<div class="ap-follow-icon rss-color"><i class="icon-feed"></i></div>
</a>
<a class="currents ap-follow-btn" title="Read on Feedly" href="https://feedly.com/i/subscription/feed%2Fhttps://www.androidpolice.com/feed" target="_blank">
<div class="ap-follow-icon ap-follow-icon-feedly"></div>
</a>
<a class="currents ap-follow-btn" title="Read on Google Play Newsstand" href="https://news.google.com/publications/CAAqBggKMLuYFDDSzAI" target="_blank">
<div class="ap-follow-icon newsstand-color"><i class="icon-newsstand"></i></div>
</a>
<a class="pushbullet-subscribe-widget fl-right" data-channel="androidpolicefeed" data-widget="button" data-size="small"></a>
</div>
</section>
</li>
<li id="ai_widget-3" class="widget-odd widget-3  none widget ai_widget"><div class='ains ains-15 ains-ap2_sidebar_2' data-ai='WzE1LDFd' style=''>
<div id="ezoic-pub-ad-placeholder-124">
<style type="text/css">
.adslot_ap2_sidebar_2 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_2 { display:inline-block; width: 300px; height: 600px;} }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_sidebar_2" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="8764075098"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</li>
<li id="aprecentpostswidget-2" class="widget-even widget-4 green widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Latest Deals</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/07/the-jbl-charge-4-waterproof-speaker-is-just-95-55-off-today-only/#comments">2</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-20" style="width:21.93085126007%;"></div></div>
<a class="cell-link" href="/2020/01/07/the-jbl-charge-4-waterproof-speaker-is-just-95-55-off-today-only/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fjbl-charge-4-hero.jpg&w=60&h=60">
<div class="cell-content">
<h4>The JBL Charge 4 waterproof speaker is just $95 ($55 off) today only</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 1:09pm PST</time><time class="timeago" datetime="2020-01-07T13:09:16-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/06/42-temporarily-free-and-47-on-sale-apps-and-games-for-monday/#comments">1</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:38.397837799709%;"></div></div>
<a class="cell-link" href="/2020/01/06/42-temporarily-free-and-47-on-sale-apps-and-games-for-monday/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fnexus2cee_monday.png&w=60&h=60">
<div class="cell-content">
<h4>42 temporarily free and 47 on-sale apps and games for Monday</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/06 8:43am PST</time><time class="timeago" datetime="2020-01-06T08:43:20-08:00">Jan 6, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/03/arlo-ultra-security-camera-is-only-180-68-off-recent-sales-at-amazon/#comments">2</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:32.929811123196%;"></div></div>
<a class="cell-link" href="/2020/01/03/arlo-ultra-security-camera-is-only-180-68-off-recent-sales-at-amazon/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F06%2FArlo-Ultra-3.jpg&w=60&h=60">
<div class="cell-content">
<h4>Arlo Ultra security camera is only $180 ($68 off recent sales) at Amazon</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/03 3:19pm PST</time><time class="timeago" datetime="2020-01-03T15:19:30-08:00">Jan 3, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/03/android-app-game-sales-jan-3-2020/#comments">3</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:46.271593527241%;"></div></div>
<a class="cell-link" href="/2020/01/03/android-app-game-sales-jan-3-2020/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fnexus2cee_friday-1.png&w=60&h=60">
<div class="cell-content">
<h4>24 temporarily free and 57 on-sale apps and games for Friday</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/03 9:28am PST</time><time class="timeago" datetime="2020-01-03T09:28:49-08:00">Jan 3, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/02/get-an-open-box-galaxy-watch-active2-44mm-for-220-80-less-than-retail/#comments">4</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:29.686591281373%;"></div></div>
<a class="cell-link" href="/2020/01/02/get-an-open-box-galaxy-watch-active2-44mm-for-220-80-less-than-retail/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F10%2Fsamsung-galaxy-watch-active2-review-6.jpg&w=60&h=60">
<div class="cell-content">
<h4>Get an open-box Galaxy Watch Active2 44mm for $220 ($80 less than retail)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/02 10:55am PST</time><time class="timeago" datetime="2020-01-02T10:55:50-08:00">Jan 2, 2020</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="ai_widget-4" class="widget-odd widget-5  none widget ai_widget"><div class='ains ains-16 ains-ap2_sidebar_3' data-ai='WzE2LDJd' style=''>
<div id="ezoic-pub-ad-placeholder-125">
<div class="adslot_ap2_sidebar_3">
<script type="text/javascript">
if (window.matchMedia("(min-width: 768px)").matches) {
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - 300x250_sidebar_3 */
google_ad_slot = "3019439258";
google_ad_width = 300;
google_ad_height = 250;
//-->

document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}
</script>
</div>
</div></div>
</li>
<li id="wpb_widget-3" class="widget-even widget-6 blue widget widget_wpb_widget"><header class="section-header"><h4 class="header-bg">Latest Poll</h4></header><section class="ap-sbar-widget-wrapper noskim"><div id="polls-483" class="wp-polls">
<form id="polls_form_483" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_483_nonce" name="wp-polls-nonce" value="d193651d4e" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="483" /></p>
<p style="text-align: center;"><strong>Do you have the Play Store set to automatically update apps?</strong></p><div id="polls-483-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li><input type="radio" id="poll-answer-2515" name="poll_483" value="2515" /> <label for="poll-answer-2515">Yes, for all apps.</label></li>
<li><input type="radio" id="poll-answer-2516" name="poll_483" value="2516" /> <label for="poll-answer-2516">Yes, but I have some apps excluded.</label></li>
<li><input type="radio" id="poll-answer-2517" name="poll_483" value="2517" /> <label for="poll-answer-2517">Nope, I don't auto-update apps.</label></li>
<li><input type="radio" id="poll-answer-2518" name="poll_483" value="2518" /> <label for="poll-answer-2518">I don't know/whatever the default setting is.</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(483);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(483); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-483-loading" class="wp-polls-loading"><img src="https://www.androidpolice.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<div class="center"><p><a href="https://www.androidpolice.com/2020/01/05/weekend-poll-is-your-phone-set-to-update-apps-on-the-play-store-automatically/" class="primary-btn btn-widget"> Discuss This Poll</a></p></div></section></li>
<li id="ai_widget-5" class="widget-odd widget-7  none widget ai_widget"><div class='ains ains-17 ains-ap2_sidebar_4' data-ai='WzE3LDFd' style=''>
<div id="ezoic-pub-ad-placeholder-126">
<style type="text/css">
.adslot_ap2_sidebar_4 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_4 { display:inline-block; width: 300px; height: 600px;} }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_sidebar_4" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4881079520"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>
</li>
<li id="aprecentpostswidget-3" class="widget-even widget-8 teal widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Recent Reviews</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/04/fossil-hybrid-hr-review-this-hybrid-smartwatch-is-off-to-a-rough-start/#comments">43</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:45.135583014347%;"></div></div>
<a class="cell-link" href="/2020/01/04/fossil-hybrid-hr-review-this-hybrid-smartwatch-is-off-to-a-rough-start/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F11%2Ffossil-hybrid-hr-review-hero-1.jpg&w=60&h=60">
<div class="cell-content">
<h4>Fossil Hybrid HR review: Not quite the next Pebble, but a good start (Updated)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/04 8:54am PST</time><time class="timeago" datetime="2020-01-04T08:54:57-08:00">Jan 4, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/03/pixel-3a-revisited-android-10-makes-this-an-even-better-budget-phone/#comments">88</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:50.914029258764%;"></div></div>
<a class="cell-link" href="/2020/01/03/pixel-3a-revisited-android-10-makes-this-an-even-better-budget-phone/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F05%2FDSC01566.jpg&w=60&h=60">
<div class="cell-content">
<h4>Pixel 3a, revisited: Android 10 makes this an even better budget phone</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/03 8:00am PST</time><time class="timeago" datetime="2020-01-03T08:00:42-08:00">Jan 3, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/12/27/oneplus-7t-pro-mclaren-5g-review/#comments">51</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:35.049699360036%;"></div></div>
<a class="cell-link" href="/2019/12/27/oneplus-7t-pro-mclaren-5g-review/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F12%2FOP-5G-Hero-2-scaled.jpg&w=60&h=60">
<div class="cell-content">
<h4>OnePlus 7T Pro 5G McLaren review: Trading battery life for an extra G</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/27 8:45am PST</time><time class="timeago" datetime="2019-12-27T08:45:34-08:00">Dec 27, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/12/19/schlage-encode-smart-wifi-deadbolt-review/#comments">32</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:31.821006551365%;"></div></div>
<a class="cell-link" href="/2019/12/19/schlage-encode-smart-wifi-deadbolt-review/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F12%2Fschlage-front-hero.png&w=60&h=60">
<div class="cell-content">
<h4>Schlage Encode Smart WiFi Deadbolt review: A lock this good is 'key' to smartening up your home</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/19 7:58am PST</time><time class="timeago" datetime="2019-12-19T07:58:05-08:00">Dec 19, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/12/18/apollo-max-review-graphene-is-finally-more-than-science-fiction-but-dont-buy-this-portable-charger/#comments">7</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:46.07076070053%;"></div></div>
<a class="cell-link" href="/2019/12/18/apollo-max-review-graphene-is-finally-more-than-science-fiction-but-dont-buy-this-portable-charger/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F12%2FApollo-Max-31-scaled.jpg&w=60&h=60">
<div class="cell-content">
<h4>Apollo Max review: Graphene is finally more than science fiction, but don't buy this portable charger</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/18 7:13am PST</time><time class="timeago" datetime="2019-12-18T07:13:37-08:00">Dec 18, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="aprecentpostswidget-5" class="widget-odd widget-9 red widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Latest Roundups</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/04/12-new-and-notable-android-apps-from-the-last-three-weeks-including-typewise-keyboard-fairemail-and-knobby-volume-control-12-14-19-1-4-20/#comments">4</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-70" style="width:71.629391449088%;"></div></div>
<a class="cell-link" href="/2020/01/04/12-new-and-notable-android-apps-from-the-last-three-weeks-including-typewise-keyboard-fairemail-and-knobby-volume-control-12-14-19-1-4-20/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_apps-01.png&w=60&h=60">
<div class="cell-content">
<h4>12 new and notable Android apps from the last three weeks including Typewise Keyboard, FairEmail, and Knobby volume control (12/14/19 - 1/4/20)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/04 7:12am PST</time><time class="timeago" datetime="2020-01-04T07:12:52-08:00">Jan 4, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/12/31/best-android-apps-2019/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:36.281237668183%;"></div></div>
<a class="cell-link" href="/2019/12/31/best-android-apps-2019/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F12%2FBest-android-apps-2019.png&w=60&h=60">
<div class="cell-content">
<h4>Best Android apps of 2019 for your new phone, tablet, or Chromebook</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/31 9:52am PST</time><time class="timeago" datetime="2019-12-31T09:52:38-08:00">Dec 31, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/12/29/new-android-games-vodobanka-pro-mission-ammunition-age-of-civilizations-ii-europe/#comments">5</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:26.701762774462%;"></div></div>
<a class="cell-link" href="/2019/12/29/new-android-games-vodobanka-pro-mission-ammunition-age-of-civilizations-ii-europe/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60">
<div class="cell-content">
<h4>15 new Android games from the week of December 23rd, 2019: Vodobanka Pro, Mission Ammunition, and Age of Civilizations II Europe</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/29 5:58am PST</time><time class="timeago" datetime="2019-12-29T05:58:21-08:00">Dec 29, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/12/24/best-android-games-2019/#comments">10</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:42.407138623939%;"></div></div>
<a class="cell-link" href="/2019/12/24/best-android-games-2019/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F12%2Fnexus2cee_dsc01349.jpg&w=60&h=60">
<div class="cell-content">
<h4>Best Android games of 2019 for your new phone, tablet, or Chromebook</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/24 7:30am PST</time><time class="timeago" datetime="2019-12-24T07:30:59-08:00">Dec 24, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/12/22/20-new-android-games-snowman-story-my-winter-album-little-white-rocket/#comments">4</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-20" style="width:15.865525393146%;"></div></div>
<a class="cell-link" href="/2019/12/22/20-new-android-games-snowman-story-my-winter-album-little-white-rocket/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60">
<div class="cell-content">
<h4>20 new Android games from the week of December 16th, 2019: Snowman Story, My Winter Album, and Little White Rocket</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/22 6:48am PST</time><time class="timeago" datetime="2019-12-22T06:48:20-08:00">Dec 22, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="aprecentpostswidget-4" class="widget-even widget-10 blue widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Recent Apps and Games</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/08/plex-streaming-channels-rentals-purchases-deep-links/#comments">0</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:38.401644093088%;"></div></div>
<a class="cell-link" href="/2020/01/08/plex-streaming-channels-rentals-purchases-deep-links/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fplex-hero.png&w=60&h=60">
<div class="cell-content">
<h4>Plex details upcoming features including subscription channels, rentals, and purchases</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/08 5:00am PST</time><time class="timeago" datetime="2020-01-08T05:00:46-08:00">Jan 8, 2020</time></div></div>
</div>
</a>
 </li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/07/reddit-is-fun-now-called-rif-is-fun-for-reddit-due-to-licensing-issues/#comments">31</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:45.178577986373%;"></div></div>
<a class="cell-link" href="/2020/01/07/reddit-is-fun-now-called-rif-is-fun-for-reddit-due-to-licensing-issues/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Frif-is-fun-for-reddit-hero.jpg&w=60&h=60">
<div class="cell-content">
<h4>Reddit is Fun now called 'rif is fun for reddit' due to licensing issues</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 11:02am PST</time><time class="timeago" datetime="2020-01-07T11:02:44-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/07/razer-kishi-universal-mobile-gaming-controller-android/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:36.422794559167%;"></div></div>
<a class="cell-link" href="/2020/01/07/razer-kishi-universal-mobile-gaming-controller-android/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2FKishi-scaled.jpg&w=60&h=60">
<div class="cell-content">
<h4>Razer reveals new universal, low-latency game controller for phones</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 10:19am PST</time><time class="timeago" datetime="2020-01-07T10:19:26-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/07/totok-messaging-app-quietly-returns-to-play-store-after-spying-accusations/#comments">12</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:30.441374795208%;"></div></div>
<a class="cell-link" href="/2020/01/07/totok-messaging-app-quietly-returns-to-play-store-after-spying-accusations/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2FScreenshot_2020-01-07-ToTok-Messenger-HD-video-call-and-voice-chat-for-free.png&w=60&h=60">
<div class="cell-content">
<h4>ToTok messaging app quietly returns to Play Store after spying accusations</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 10:09am PST</time><time class="timeago" datetime="2020-01-07T10:09:31-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2020/01/07/g-i-joe-war-on-cobra-android-pre-reg/#comments">7</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:36.232356191677%;"></div></div>
<a class="cell-link" href="/2020/01/07/g-i-joe-war-on-cobra-android-pre-reg/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2FG.I.-Joe-War-On-Cobra.png&w=60&h=60">
<div class="cell-content">
<h4>G.I. Joe: War On Cobra is a collection-based strategy game coming to Android Jan. 20, pre-reg now open</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 9:09am PST</time><time class="timeago" datetime="2020-01-07T09:09:26-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="apblastfromthepast-2" class="widget-odd widget-last widget-11 red widget ap-blast-from-past"><header class="section-header"><h4 class="header-bg">Blast from the Past</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/01/08/internet-tricksters-hijack-chromecasts-to-promote-pewdiepie/#comments">98</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-90" style="width:87.079676526916%;"></div></div>
<a class="cell-link" href="/2019/01/08/internet-tricksters-hijack-chromecasts-to-promote-pewdiepie/">
<h3 class="ap-sidebar-title"><span>1 Year Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F01%2FScreen_Shot_2019_01_02_at_1.03.21_PM.0.png&w=60&h=60">
<div class="cell-content">
<h4>[Update: Google shares network security tips] Internet tricksters hijack Chromecasts to promote PewDiePie</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/01/08 3:27pm PST</time><time class="timeago" datetime="2019-01-08T15:27:49-08:00">Jan 8, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2018/01/08/sony-announces-android-auto-car-audio-system-astonishingly-flat-touchscreen/#comments">38</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.746257142928%;"></div></div>
<a class="cell-link" href="/2018/01/08/sony-announces-android-auto-car-audio-system-astonishingly-flat-touchscreen/">
<h3 class="ap-sidebar-title"><span>2 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F01%2Fnexus2cee_sony_-XAV-AX5000.jpeg&w=60&h=60">
<div class="cell-content">
<h4>Sony announces Android Auto car audio system with "astonishingly flat" touchscreen</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2018/01/08 7:17pm PST</time><time class="timeago" datetime="2018-01-08T19:17:41-08:00">Jan 8, 2018</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2017/01/08/two-months-google-homes-release-still-cant-perform-many-basic-tasks/#comments">132</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-90" style="width:93.591361235818%;"></div></div>
<a class="cell-link" href="/2017/01/08/two-months-google-homes-release-still-cant-perform-many-basic-tasks/">
<h3 class="ap-sidebar-title"><span>3 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F12%2Fnexus2cee_home_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>Two months after the Google Home's release, it still can't perform many basic tasks</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/01/08 12:42pm PST</time><time class="timeago" datetime="2017-01-08T12:42:51-08:00">Jan 8, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2016/01/08/google-is-testing-a-new-colorful-gradient-based-cartoonish-and-detailed-weather-card/#comments">121</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.943944340309%;"></div></div>
<a class="cell-link" href="/2016/01/08/google-is-testing-a-new-colorful-gradient-based-cartoonish-and-detailed-weather-card/">
<h3 class="ap-sidebar-title"><span>4 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F01%2Fnexus2cee_new-google-weather-card.png&w=60&h=60">
<div class="cell-content">
<h4>Google Is Testing A New Colorful, Gradient-Based, Cartoonish, And Detailed Weather Card</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2016/01/08 5:35am PST</time><time class="timeago" datetime="2016-01-08T05:35:29-08:00">Jan 8, 2016</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2015/01/08/apk-teardown-google-search-v4-1-hints-at-notifications-read-aloud-project-hera-social-networking-and-a-whole-lot-more/#comments">83</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.932667888488%;"></div></div>
<a class="cell-link" href="/2015/01/08/apk-teardown-google-search-v4-1-hints-at-notifications-read-aloud-project-hera-social-networking-and-a-whole-lot-more/">
<h3 class="ap-sidebar-title"><span>5 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2015%2F01%2Fnexus2cee_Search-Teardown_2.png&w=60&h=60">
<div class="cell-content">
<h4>[APK Teardown] Google Search v4.1 Hints At Notifications Read Aloud, Project Hera, Social Networking, And A Whole Lot More</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2015/01/08 10:25am PST</time><time class="timeago" datetime="2015-01-08T10:25:00-08:00">Jan 8, 2015</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2014/01/08/apk-download-gmail-4-7-2-update-adds-promised-auto-show-images-feature/#comments">59</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2014/01/08/apk-download-gmail-4-7-2-update-adds-promised-auto-show-images-feature/">
<h3 class="ap-sidebar-title"><span>6 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2014%2F01%2Fnexusae0_unnamed3.png&w=60&h=60">
<div class="cell-content">
<h4>[APK Download] Gmail 4.7.2 Update Adds Promised Auto-Show Images Feature</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2014/01/08 7:39pm PST</time><time class="timeago" datetime="2014-01-08T19:39:00-08:00">Jan 8, 2014</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2013/01/08/ces-2013-hands-on-with-ztes-5-1080p-flagship-the-grand-s-video/#comments">8</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2013/01/08/ces-2013-hands-on-with-ztes-5-1080p-flagship-the-grand-s-video/">
<h3 class="ap-sidebar-title"><span>7 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2013%2F01%2Fnexusae0_wm_IMG_1594.jpg&w=60&h=60">
<div class="cell-content">
<h4>[CES 2013] Hands-On With ZTE's 5&quot; 1080p Flagship - The Grand S (Video)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2013/01/08 10:18pm PST</time><time class="timeago" datetime="2013-01-08T22:18:00-08:00">Jan 8, 2013</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2012/01/08/lenovo-unveils-k91-the-worlds-first-ice-cream-sandwich-powered-tv/#comments">18</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2012/01/08/lenovo-unveils-k91-the-worlds-first-ice-cream-sandwich-powered-tv/">
<h3 class="ap-sidebar-title"><span>8 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2012%2F01%2FK91-553D_03.jpg&w=60&h=60">
<div class="cell-content">
<h4>[Update: First Look Video, We're Kind Of In Love] CES 2012: Lenovo Announces K91, The World&rsquo;s First Ice Cream Sandwich-Powered TV</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2012/01/08 11:05pm PST</time><time class="timeago" datetime="2012-01-08T23:05:00-08:00">Jan 8, 2012</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2011/01/08/the-coolest-android-gadget-at-ces-2011-recons-android-powered-gps-enabled-camera-streaming-snow-goggles-video/#comments">8</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2011/01/08/the-coolest-android-gadget-at-ces-2011-recons-android-powered-gps-enabled-camera-streaming-snow-goggles-video/">
<h3 class="ap-sidebar-title"><span>9 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2011%2F01%2FIMG_8328.jpg&w=60&h=60">
<div class="cell-content">
<h4>The Coolest Android Gadget At CES 2011: Recon's Android-Powered, GPS-Enabled, Camera-Streaming Snow Goggles [Video]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2011/01/08 8:30pm PST</time><time class="timeago" datetime="2011-01-08T20:30:00-08:00">Jan 8, 2011</time></div></div>
</div>
</a>
</li></ul></section></li>
</ul>
</div> </div>
</div>
<script type="text/javascript">
    var ajaxurl = 'https://www.androidpolice.com/wordpress/wp-admin/admin-ajax.php';
    var postid = 653434</script>
<center>
<div class='ains ains-12 ains-ap2_footer_large' data-ai='WzEyLDAsImFwMl9mb290ZXJfbGFyZ2UiLCIiXQ==' style=''>
<div id="ezoic-pub-ad-placeholder-127">
<style type="text/css">
.adslot_ap2_footer_large { display: none; }
@media (min-width: 768px) { .adslot_ap2_footer_large { display:inline-block; width: 728px; height: 90px; margin-bottom: 10px} }
@media (min-width: 970px) { .adslot_ap2_footer_large { display:inline-block; width: 970px; height: 250px; margin-bottom: 20px} }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_footer_large" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="9594790476"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
</center>
<div class="band footer">
<div class="container">
<div class="ap-hottest-content-wrapper">
<header class="section-header"><h4>What's Hot</h4></header>
<div class="one-third column alpha">
<div id="appopularposts-5" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 24 Hours</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/08/galaxy-note10-note10-android-10/#comments">146</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999997241196%;"></div></div>
<a class="cell-link" href="/2020/01/08/galaxy-note10-note10-android-10/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F08%2Fgalaxy-note10-01804.jpg&w=60&h=60">
<div class="cell-content">
<h4>Stable Android 10 starts hitting the Galaxy Note10 and Note10+ (Update: UK Note10+ 5G, Indonesia)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/08 3:25am PST</time><time class="timeago" datetime="2020-01-08T03:25:24-08:00">Jan 8, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/07/epson-unveils-new-mini-laser-projector-with-android-tv-and-netflix-support/#comments">12</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:98.412465940072%;"></div></div>
<a class="cell-link" href="/2020/01/07/epson-unveils-new-mini-laser-projector-with-android-tv-and-netflix-support/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Fimg_5e14b44762f54.png&w=60&h=60">
<div class="cell-content">
<h4>Epson unveils new mini laser projector with Android TV and Netflix support</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 9:11am PST</time><time class="timeago" datetime="2020-01-07T09:11:30-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/07/google-announces-scheduled-actions-for-assistant-plus-a-handful-of-other-new-features/#comments">45</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:97.828503964894%;"></div></div>
<a class="cell-link" href="/2020/01/07/google-announces-scheduled-actions-for-assistant-plus-a-handful-of-other-new-features/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2FGoogle-Playground-Assistant-Hey-Google-Slide-Hero-CES-2020-scaled.jpg&w=60&h=60">
<div class="cell-content">
<h4>Google announces scheduled actions for Assistant, plus a handful of other new features</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 10:00am PST</time><time class="timeago" datetime="2020-01-07T10:00:50-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/08/nokia-6-1-plus-gets-android-10-stable/#comments">18</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-90" style="width:85.021824780462%;"></div></div>
<a class="cell-link" href="/2020/01/08/nokia-6-1-plus-gets-android-10-stable/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F07%2F61p.jpg&w=60&h=60">
<div class="cell-content">
<h4>Nokia 6.1 Plus gets Android 10 stable (Update: Nokia 6.1 and 7 Plus too)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/08 3:52am PST</time><time class="timeago" datetime="2020-01-08T03:52:24-08:00">Jan 8, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/07/signal-ephemeral-media-beta/#comments">25</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-80" style="width:79.325957427834%;"></div></div>
<a class="cell-link" href="/2020/01/07/signal-ephemeral-media-beta/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2FSignal-hero.jpg&w=60&h=60">
<div class="cell-content">
<h4>Signal introduces ephemeral media messages in its beta app</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 5:43am PST</time><time class="timeago" datetime="2020-01-07T05:43:41-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li></ul></section></div> </div>
<div class="one-third column">
<div id="appopularposts-6" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 7 Days</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/08/galaxy-note10-note10-android-10/#comments">146</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999997241196%;"></div></div>
<a class="cell-link" href="/2020/01/08/galaxy-note10-note10-android-10/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F08%2Fgalaxy-note10-01804.jpg&w=60&h=60">
<div class="cell-content">
<h4>Stable Android 10 starts hitting the Galaxy Note10 and Note10+ (Update: UK Note10+ 5G, Indonesia)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/08 3:25am PST</time><time class="timeago" datetime="2020-01-08T03:25:24-08:00">Jan 8, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/05/best-android-smartphones/#comments">346</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.715807904397%;"></div></div>
<a class="cell-link" href="/2020/01/05/best-android-smartphones/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F10%2FMost-Wanted-Phones.jpg&w=60&h=60">
<div class="cell-content">
<h4>The best Android smartphones you can buy right now (Early 2020)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/05 10:00am PST</time><time class="timeago" datetime="2020-01-05T10:00:48-08:00">Jan 5, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/07/oneplus-unveils-optimized-charging-feature-designed-to-protect-your-battery/#comments">61</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.587111637047%;"></div></div>
<a class="cell-link" href="/2020/01/07/oneplus-unveils-optimized-charging-feature-designed-to-protect-your-battery/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2020%2F01%2Foneplus-optimized-charging.png&w=60&h=60">
<div class="cell-content">
<h4>OnePlus unveils Optimized Charging feature designed to protect your battery</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/07 4:31am PST</time><time class="timeago" datetime="2020-01-07T04:31:31-08:00">Jan 7, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/04/qualcomm-quick-charge-4-devices/#comments">161</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.539638356295%;"></div></div>
<a class="cell-link" href="/2020/01/04/qualcomm-quick-charge-4-devices/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F10%2Frazer-2.jpg&w=60&h=60">
<div class="cell-content">
<h4>The big list of phones and tablets with Qualcomm Quick Charge 4/4+</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/04 11:24am PST</time><time class="timeago" datetime="2020-01-04T11:24:27-08:00">Jan 4, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/04/qualcomm-quick-charge-2-and-3-devices/#comments">132</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.202243320642%;"></div></div>
<a class="cell-link" href="/2020/01/04/qualcomm-quick-charge-2-and-3-devices/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F03%2Fnexus2cee_DSC09695.jpg&w=60&h=60">
<div class="cell-content">
<h4>The big list of phones and tablets with Qualcomm Quick Charge 2.0 and 3.0</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/04 7:52am PST</time><time class="timeago" datetime="2020-01-04T07:52:00-08:00">Jan 4, 2020</time></div></div>
</div>
</a>
</li></ul></section></div> </div>
<div class="one-third column omega">
<div id="appopularposts-9" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 30 Days</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2020/01/08/galaxy-note10-note10-android-10/#comments">146</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999997241196%;"></div></div>
<a class="cell-link" href="/2020/01/08/galaxy-note10-note10-android-10/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F08%2Fgalaxy-note10-01804.jpg&w=60&h=60">
<div class="cell-content">
<h4>Stable Android 10 starts hitting the Galaxy Note10 and Note10+ (Update: UK Note10+ 5G, Indonesia)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2020/01/08 3:25am PST</time><time class="timeago" datetime="2020-01-08T03:25:24-08:00">Jan 8, 2020</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/12/26/android-10-oneplus-6t-oxygenos-10/#comments">132</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998231386094%;"></div></div>
<a class="cell-link" href="/2019/12/26/android-10-oneplus-6t-oxygenos-10/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F11%2FOnePlus-6T-Thunder-Purple-hero.jpg&w=60&h=60">
<div class="cell-content">
<h4>OnePlus 6 and 6T Android 10 update rolling out again as Oxygen OS 10.0.1 (Update: 10.3.0 ROMs)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/26 3:12pm PST</time><time class="timeago" datetime="2019-12-26T15:12:28-08:00">Dec 26, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/12/12/google-pixel-pin-lock-screen-loop-help/#comments">198</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.993920251845%;"></div></div>
<a class="cell-link" href="/2019/12/12/google-pixel-pin-lock-screen-loop-help/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F09%2Fpixel-xl-pin-lock-screen-loop.gif&w=60&h=60">
<div class="cell-content">
<h4>Pixel lockscreen PIN bug is making phones unusable (Update: OnePlus, Sony devices affected)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/12 8:11am PST</time><time class="timeago" datetime="2019-12-12T08:11:12-08:00">Dec 12, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/12/21/samsung-galaxy-s10-series-android-10/#comments">222</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.98735966587%;"></div></div>
<a class="cell-link" href="/2019/12/21/samsung-galaxy-s10-series-android-10/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F11%2F2019-11-07-Samsung-Galaxy-S10-01-1.png&w=60&h=60">
<div class="cell-content">
<h4>Android 10 rolling out to Samsung Galaxy S10 series (Update: New Zealand, Philippines, Romania)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/21 12:58am PST</time><time class="timeago" datetime="2019-12-21T00:58:56-08:00">Dec 21, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/12/30/verizon-att-sprint-tmobile-5g-cities/#comments">170</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.981054863305%;"></div></div>
<a class="cell-link" href="/2019/12/30/verizon-att-sprint-tmobile-5g-cities/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F07%2Fcell-tower-antennas-roof.png&w=60&h=60">
<div class="cell-content">
<h4>Every 5G city and region for every major carrier in the US (Verizon, AT&#038;T, T-Mobile, and Sprint) (Update: New AT&#038;T markets)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/12/30 11:08am PST</time><time class="timeago" datetime="2019-12-30T11:08:18-08:00">Dec 30, 2019</time></div></div>
</div>
</a>
</li></ul></section></div> </div>
</div>
<div class="sixteen columns">
</div>
<div class="sixteen columns ">
<div class="footer-notes">
<div id='footer_signature'>
Notice a bug? <a target="_blank" href="https://github.com/android-police/androidpolice-public/issues">Let us know here.</a><br />
Link monetization by <a target="_blank" href="http://skimlinks.com">Skimlinks</a>
<span class="footer-break">
<a href="https://www.androidpolice.com/androidpolice-com-privacy-policy/">Privacy Policy</a>
| <a href="https://www.androidpolice.com/dmca-copyright-infringement-notification/">DMCA Disclaimer</a>
| <a href="https://www.androidpolice.com/about/">About</a>
| <a href="https://www.androidpolice.com/advertise/">Advertise</a>
| <a href="https://www.androidpolice.com/contact/">Contact</a><br /></span>
<span class="ap-rel-parent page_stats">
145 queries | 0.471s | hive <span id="this_page_stats" hidden>Original page cache stats:<br>145 queries | 0.471s | hive<br>This request stats: <br> 26 queries | 0.086s | nexus2</span> </span>
<span class="footer-break">
Android is a trademark of Google Inc. | &copy; Illogical Robot LLC, 2009-2020 </span>
</div>
</div>
</div>
</div>
</div>

<img src="https://www.androidpolice.com/wp-content/plugins/ap-hotness/aph-post-view-counter.php?post_id=653434" alt=""><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidpolice"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"653434 https:\/\/www.androidpolice.com\/?p=653434","disqusShortname":"androidpolice","disqusTitle":"Google\u2019s adjusted 90-day Project Zero policy gives developers more time to deploy patches","disqusUrl":"http:\/\/androidpolice.com\/2020\/01\/08\/google-project-zero-90-day-policy-adjusted\/","postId":"653434"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202002'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tocplus = {"smooth_scroll":"1","smooth_scroll_offset":"10"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=1509'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.androidpolice.com\/wordpress\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/mistape/assets/js/modernizr.custom.js?ver=1.3.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var decoMistape = {"ajaxurl":"https:\/\/www.androidpolice.com\/wordpress\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/mistape/assets/js/mistape-front.js?ver=1555527908'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.easing.1.4.1.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/nivo-lightbox.js?ver=1572373555'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jRespond.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/mousetrap/mousetrap.min.js?ver=1.4.6'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.timeago.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.flexslider.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/androidpolice.js?ver=1575481108'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.countTo.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/ap.single.js?ver=1496874322'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/waypoints-combined.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202002.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9.1',blog:'12245754',post:'653434',tz:'-8',srv:'www.androidpolice.com'} ]);
	_stq.push([ 'clickTrackerInit', '12245754', '653434' ]);
</script>
<div id="mistape_dialog" data-mode="comment" data-dry-run="0">
<div class="dialog__overlay"></div><div class="dialog__content"><div id="mistape_confirm_dialog" class="mistape_dialog_screen">
<div class="dialog-wrap">
<div class="dialog-wrap-top">
<h2>Spelling error report</h2>
<div class="mistape_dialog_block">
<h3>The following text will be sent to our editors:</h3>
<div id="mistape_reported_text"></div>
</div>
</div>
<div class="dialog-wrap-bottom">
<div class="mistape_dialog_block comment">
<div class="mistape-contact-row">
<div class="mistape-contact-column">
<h3><label for="ap_mistape_name">Your name (required):</label></h3>
<input type="text" name="ap_mistape_name" id="ap_mistape_name" required="required" />
</div>
<div class="mistape-contact-column">
<h3><label for="ap_mistape_email">Your email (optional):</label></h3>
<input type="email" name="ap_mistape_email" id="ap_mistape_email" />
</div>
</div>
</div>
<h3><label for="mistape_comment">Your comment (optional):</label></h3>
<textarea id="mistape_comment" cols="60" rows="3" maxlength="1000"></textarea>
</div><div class="pos-relative">
</div>
</div>
</div>
<div class="mistape_dialog_block">
<a class="mistape_action" data-action="send" data-id="653434" role="button">Send</a>
<a class="mistape_action" data-dialog-close role="button" style="display:none">Cancel</a>
</div>
<div class="mistape-letter-front letter-part">
<div class="front-left"></div>
<div class="front-right"></div>
<div class="front-bottom"></div>
</div>
<div class="mistape-letter-back letter-part">
<div class="mistape-letter-back-top"></div>
</div>
<div class="mistape-letter-top letter-part"></div>
</div></div></div><script>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</script>
<script type="text/javascript">
	var templateDir = "https://www.androidpolice.com/wp-content/themes/ap2";
  var ajaxurl = "https://www.androidpolice.com/wordpress/wp-admin/admin-ajax.php";
  var blogurl = "https://www.androidpolice.com";
</script>

<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5c5b5d52974ebd54"></script>

<script src="//instant.page/1.2.2" type="module" integrity="sha384-2xV8M5griQmzyiY3CDqh1dn4z3llDVqZDqzjzcY+jCBCk/a5fXJmuZ/40JJAPeoU"></script>


<script type="text/javascript">(function(){var a=document.createElement('script');a.type='text/javascript';a.async=true;a.src='https://widget.pushbullet.com/dynamic.js';var b=document.getElementsByTagName('script')[0];b.parentNode.insertBefore(a,b);})();</script>

<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
<script type="text/javascript" src="https://www.androidpolice.com/wp-content/themes/ap2/js/tablepress.search-fix.js"></script>

<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=651&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>


<script type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-130167.js"></script>


<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-95hmrIiT9zWMo"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-95hmrIiT9zWMo.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>


<img src="https://sb.scorecardresearch.com/p?c1=2&c2=15235859&cv=2.0&cj=1" />


<script type="text/javascript" src="//s.skimresources.com/js/85009X1537243.skimlinks.js"></script>

</body>
</html>
