<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="pingback" href="https://www.androidpolice.com/wordpress/xmlrpc.php" />
<meta property="og:site_name" content="Android Police" />
<meta name="theme-color" content="#0041C8">
<link rel="publisher" href="https://plus.google.com/103876278794381402383" />

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=3">

<link href='//fonts.googleapis.com/css?family=Oswald|Roboto:700,500,400|Roboto+Slab' rel='stylesheet' type='text/css'>
<!--[if lt IE 9]>
    <script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
   <![endif]-->

<link rel="shortcut icon" type="image/png" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-114x114.png">
<script src="//tags-cdn.deployads.com/a/androidpolice.com.js" async></script>
<script>
  var ap_naag_timeset = parseFloat(localStorage['naag-timeset']),
                  ap_naag_expiry  = ap_naag_timeset + 600000,
                  ap_naag_article_count = parseFloat(localStorage['naag-article-count']),
                  naag_d = new Date(),
                  naag_time = naag_d.getTime();

              console.log('APDEBUG ARTICLE COUNT: ' + ap_naag_article_count );</script>

<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-6275685-2', 'auto');
    ga('require', 'linkid', 'linkid.js');
    ga('send', 'pageview');

  </script>
<script type="text/javascript">var postid = 558076;</script><script type="text/javascript">var aphDir = "https://www.androidpolice.com/wp-content/plugins/ap-hotness"</script>

<title>AMP pages will now show original URL in Chrome&#039;s address bar, fundamentally changing how the web works</title>
<meta name="description" content="Google had its 2019 &#039;AMP Conf&#039; in Tokyo today, and announced a series of changes and new features coming to the company&#039;s Accelerated Mobile Pages... by Corbin Davenport in Google, News" />
<link rel="canonical" href="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/" />
<link rel="publisher" href="https://plus.google.com/+AndroidPolice" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="AMP pages will now show original URL in Chrome&#039;s address bar, fundamentally changing how the web works" />
<meta property="og:description" content="Google had its 2019 &#039;AMP Conf&#039; in Tokyo today, and announced a series of changes and new features coming to the company&#039;s Accelerated Mobile Pages... by Corbin Davenport in Google, News" />
<meta property="og:url" content="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/" />
<meta property="og:site_name" content="Android Police - Android news, reviews, apps, games, phones, tablets" />
<meta property="article:publisher" content="https://www.facebook.com/AndroidPolice" />
<meta property="article:author" content="https://www.facebook.com/corbin.davenport.50" />
<meta property="article:tag" content="accelerated mobile pages" />
<meta property="article:tag" content="amp" />
<meta property="article:tag" content="amp real url" />
<meta property="article:tag" content="Google" />
<meta property="article:section" content="Google" />
<meta property="article:published_time" content="2019-04-17T05:05:52-07:00" />
<meta property="og:image" content="https://www.androidpolice.com/wp-content/uploads/2019/04/vlcsnap-2019-04-17-00h58m00s057-728x407.jpg" />
<meta property="og:image:secure_url" content="https://www.androidpolice.com/wp-content/uploads/2019/04/vlcsnap-2019-04-17-00h58m00s057-728x407.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Google had its 2019 &#039;AMP Conf&#039; in Tokyo today, and announced a series of changes and new features coming to the company&#039;s Accelerated Mobile Pages... by Corbin Davenport in Google, News" />
<meta name="twitter:title" content="AMP pages will now show original URL in Chrome&#039;s address bar, fundamentally changing how the web works" />
<meta name="twitter:site" content="@AndroidPolice" />
<meta name="twitter:image" content="https://www.androidpolice.com/wp-content/uploads/2019/04/vlcsnap-2019-04-17-00h58m00s057-728x407.jpg" />
<meta name="twitter:creator" content="@corbindavenport" />

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; Feed" href="https://www.androidpolice.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; Comments Feed" href="https://www.androidpolice.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Android Police - Android news, reviews, apps, games, phones, tablets &raquo; AMP pages will now show original URL in Chrome&#039;s address bar, fundamentally changing how the web works Comments Feed" href="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.androidpolice.com\/wordpress\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.androidpolice.com/wordpress/wp-includes/css/dist/block-library/style.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='qc-choice-css' href='https://www.androidpolice.com/wp-content/plugins/quantcast-choice/public/css/style.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpappbox-css' href='https://www.androidpolice.com/wp-content/plugins/wp-appbox/css/styles.min.css?ver=4.1.3' type='text/css' media='screen' />
<link rel='stylesheet' id='wp-polls-css' href='https://www.androidpolice.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.androidpolice.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='layout-css' href='https://www.androidpolice.com/wp-content/themes/ap2/stylesheets/layout.css?ver=1554852685' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.androidpolice.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.androidpolice.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/ad-inserter-pro/includes/js/ai-jquery.js?ver=5.1.1'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.androidpolice.com/wordpress/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.androidpolice.com/wordpress/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.1.1" />
<link rel='shortlink' href='https://www.androidpolice.com/?p=558076' />
<link rel="alternate" type="application/json+oembed" href="https://www.androidpolice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidpolice.com%2F2019%2F04%2F16%2Famp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.androidpolice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.androidpolice.com%2F2019%2F04%2F16%2Famp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works%2F&#038;format=xml" />

<script type="application/ld+json">{"@context":"http:\/\/schema.org\/","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.androidpolice.com\/2019\/04\/16\/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works\/"},"url":"https:\/\/www.androidpolice.com\/2019\/04\/16\/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works\/","headline":"AMP pages will now show original URL in Chrome's address bar, fundamentally changing how the web works","datePublished":"2019-04-16T22:05:52-07:00","dateModified":"2019-04-16T22:05:52-07:00","publisher":{"@type":"Organization","@id":"https:\/\/www.androidpolice.com\/#organization","name":"Android Police - Android news, reviews, apps, games, phones, tablets","logo":{"@type":"ImageObject","url":"https:\/\/www.androidpolice.com\/wp-content\/uploads\/2018\/07\/android_police_extended_text_logo_white.png","width":600,"height":60}},"image":{"@type":"ImageObject","url":"https:\/\/www.androidpolice.com\/wp-content\/uploads\/2019\/04\/vlcsnap-2019-04-17-00h58m00s057-728x407.jpg","width":696,"height":"373"},"articleSection":"Google","description":"Google had its 2019 'AMP Conf' in Tokyo today, and announced a series of changes and new features coming to the company's Accelerated Mobile Pages project. The most important announcement was that AMP pages will now show the original URL in the address bar, which should solve the platform's","author":{"@type":"Person","name":"Corbin Davenport","url":"https:\/\/www.androidpolice.com\/author\/corbin-davenport\/","description":"Corbin is a tech writer, browser extension developer, and web developer living in Georgia.","image":{"@type":"ImageObject","url":"https:\/\/secure.gravatar.com\/avatar\/aa992ac846ab841a1796544fd113e5a1?s=96&d=mm&r=x","height":96,"width":96},"sameAs":["https:\/\/plus.google.com\/+CorbinDavenport","https:\/\/www.facebook.com\/corbin.davenport.50","https:\/\/twitter.com\/corbindavenport"]}}</script>
<style type='text/css'>img#wpstats{display:none}</style>

<script type="text/javascript">
      (function() {
          function async_load(script_url){
              var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
              var s = document.createElement('script'); s.src = protocol + script_url;
              var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
          }
          bm_website_code = 'ADCF24FB71BE47D4';
          jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
          jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
      })();
  </script>


<meta name="flattr:id" content="j099pg">

</head>
<body class="post-template-default single single-post postid-558076 single-format-image">

<div id="tip-us">
<div id="tip-us-container" class="container">
<div class="sixteen columns">
<div class="tip-us-wrapper">
<div class="tip-us-header">
<a href="#" class="btn-close" title="Close"><i class="icon-exit"></i></a>
<h2 class="modal-heading">Tip Us</h2>
</div>
<div class="tip-us-body">
<div class="ap-loader"></div>
</div>
</div>
</div>
</div>
</div>
<div class="band header hidden-phone">
<div class="container">
<div class="sixteen columns">
<a href="https://www.androidpolice.com"><h1 class="logo">Android Police</h1></a>
<div class='ains ains-1' data-ai='WzEsMCwiYXAyX2hlYWRlcl8xIiwiIl0=' style=''>
<style type="text/css">
.adslot_ap2_header_1 { display: none; }
@media (min-width: 768px) { .adslot_ap2_header_1 { display:inline-block; width: 728px; height: 90px; float:right; margin: 16px 0;} }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_header_1" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="3439725683"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div>
<div class="band nav">
<div class="ap-nav-wrapper">
<div class="container">
<ul class="mobile-nav list-unstyled">
<li class="depth-priority">
<a id="ap-menu-button" href="#" class="menu">
<span class="ap-bar"></span>
<span class="ap-bar"></span>
<span class="ap-bar"></span>
</a>
<a class="search-box-close visible-handheld hidden">
<i class="icon-backarrow"></i>
</a>
</li>
<li>
<a href="https://www.androidpolice.com" id="ap-logo-small">
<i class="icon-ap"></i>
</a>
</li>
<li>
<a id="search-btn-a" class="search-btn depth-priority" onclick="firstIconClick(event)"><i class="icon-search"></i></a>
<div class="search-box" id="search-box">
<form role="search" method="get" id="searchform" action="https://www.androidpolice.com/" autocomplete="off">
<input class="textfield" type="search" name="s" id="s" placeholder="Search" value="" autocomplete="off" />
<input type="hidden" name="order" value="rel" />
<div class="cat-select">
<ul class="cat-ul list-unstyled">
</ul>
</div>
</form>
</div>
</li>
<li class="ap-new-articles">
<a class="ap-new-articles-btn ap-btn-red" href="#">
<span id="ap-new-articles-num" class="ap-new-articles-num"></span>
<script>
              apNewArticlesNum = document.getElementById("ap-new-articles-num");
              console.log('APDEBUG EL: ' + apNewArticlesNum);
              console.log('APDEBUG ARTICLE COUNT: naag_time = ' + naag_time + ', ap_naag_expiry = ' + ap_naag_expiry);
              if ( !isNaN(ap_naag_article_count) && naag_time < ap_naag_expiry ) {
                apNewArticlesNum.innerHTML = ap_naag_article_count;
                console.log('APDEBUG ARTICLE COUNT: updating content with ' + ap_naag_article_count);
              }
              else {
                console.log('APDEBUG ARTICLE COUNT: DID NOT UPDATE');
              }
            </script>
<span class="ap-new-articles-lable">New<br>Articles</span>
<i class="icon-sort-down"></i>
</a>
</li>
</ul>
<ul id="menu-primary-nav" class="primary-nav ap-panel" role="navigation">
<li id="nav-menu-item-294419" rel="news"><a class='ap-nav-primary' href="https://www.androidpolice.com/topics/news/">News<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294419'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294423" rel="news"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/news/">Latest news</a></li>
<li id="nav-menu-item-516250" rel="android-9-pie"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/android-os/android-9-pie/">Android 9 Pie</a></li>
<li id="nav-menu-item-414169" rel="android-8-0-oreo"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/android-os/android-8-0-oreo/">Android 8.0 Oreo</a></li>
<li id="nav-menu-item-294428" rel="android-os"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/android-os/">Android OS</a></li>
<li id="nav-menu-item-294429" rel="wearables"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/wearables/">Smartwatches &#038; Wearables</a></li>
<li id="nav-menu-item-294598" rel="android-tv-android-os"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/android-os/android-tv-android-os/">Android TV</a></li>
<li id="nav-menu-item-294597" rel="android-auto"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/android-os/android-auto/">Android Auto</a></li>
<li id="nav-menu-item-294426" rel="dev-development"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/dev-development/">Development</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/topics/news/'>More News...</a></div></div>
</li>
<li id="nav-menu-item-294420" rel="applications-games"><a class='ap-nav-primary' href="https://www.androidpolice.com/topics/applications-games/">Apps/Games<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294420'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294425" rel="games"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/applications-games/games/">Games</a></li>
<li id="nav-menu-item-294424" rel="apps"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/applications-games/apps/">Applications</a></li>
<li id="nav-menu-item-294430" rel="roundups"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/roundups/">Roundups</a></li>
<li id="nav-menu-item-294431" rel="app-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/reviews/app-reviews/">App Reviews</a></li>
<li id="nav-menu-item-294432" rel="game-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/reviews/game-reviews/">Game Reviews</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/topics/applications-games/'>More Apps/Games...</a></div></div>
</li>
<li id="nav-menu-item-294421" rel="reviews"><a class='ap-nav-primary' href="https://www.androidpolice.com/topics/reviews/">Reviews<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294421'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294435" rel="reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/reviews/">All reviews</a></li>
<li id="nav-menu-item-294434" rel="phone-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/reviews/phone-reviews/">Phone Reviews</a></li>
<li id="nav-menu-item-294436" rel="tablet-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/reviews/tablet-reviews/">Tablet Reviews</a></li>
<li id="nav-menu-item-294437" rel="wearable-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/reviews/wearable-reviews/">Wearable Reviews</a></li>
<li id="nav-menu-item-294433" rel="other-reviews"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/reviews/other-reviews/">Other Reviews</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/topics/reviews/'>More Reviews...</a></div></div>
</li>
<li id="nav-menu-item-294422" rel="phones-devices"><a class='ap-nav-primary' href="https://www.androidpolice.com/topics/phones-devices/">Devices<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294422'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-535290" rel="google-phones-devices"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/phones-devices/google-phones-devices/">Google</a></li>
<li id="nav-menu-item-294438" rel="samsung"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/phones-devices/samsung/">Samsung</a></li>
<li id="nav-menu-item-294594" rel="lg"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/phones-devices/lg/">LG</a></li>
<li id="nav-menu-item-535291" rel="xiaomi"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/phones-devices/xiaomi/">Xiaomi</a></li>
<li id="nav-menu-item-294440" rel="motorola"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/phones-devices/motorola/">Motorola</a></li>
<li id="nav-menu-item-294441" rel="sony"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/phones-devices/sony/">Sony</a></li>
<li id="nav-menu-item-294439" rel="htc"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/phones-devices/htc/">HTC</a></li>
<li id="nav-menu-item-294595" rel="huawei"><a class='ap-nav-sub' href="https://www.androidpolice.com/topics/phones-devices/huawei/">Huawei</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='https://www.androidpolice.com/topics/phones-devices/'>More Devices...</a></div></div>
</li>
<li id="menu-item-294411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294411"><a href="https://www.androidpolice.com/topics/news/leak/">Leaks</a></li>
<li id="menu-item-294412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294412"><a href="https://www.androidpolice.com/topics/news/exclusive/">Exclusives</a></li>
<li id="menu-item-294413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294413"><a href="https://www.androidpolice.com/topics/downloads/">Downloads</a></li>
<li id="menu-item-294414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294414"><a href="https://www.androidpolice.com/topics/deals/">Deals</a></li>
<li id="menu-item-294415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294415"><a href="https://www.androidpolice.com/topics/contests/">Giveaways</a></li>
<li id="menu-item-294416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294416"><a href="https://www.androidpolice.com/topics/features/">Features</a></li>
<li id="menu-item-294417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294417"><a href="https://www.androidpolice.com/topics/editorials/">Editorials</a></li>
<li id="menu-item-435701" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435701"><a title="donate" href="https://www.androidpolice.com/subscribe-donate/">Donate</a></li>
<li><a class="tip-us" href="https://www.androidpolice.com/contact">Tip Us</a></li> </ul>
</div>
<div class="ap-panel ap-panel-news">
<div class="container">
<div id="news-slider"></div>
<div class="fs-navigation">
<a href="" class="fs-control fs-control-prev"><i class='icon-caret-left'></i> Prev</a>
<div class="fs-control fs-control-filters disabled">
<span>Posts in the last </span>
<div class="ap-dropdown ap-filter-time">
<a class="ap-dropdown-trigger active" href=""><span>24 Hours</span><i class="icon-sort-down"></i></a>
<ul class="list-unstyled ap-dropdown-content ap-dropdown-content-bottom depth3">
<li><a class="active" href="" data-function="ap_news_updater" data-time="24">24 Hours</a></li>
<li><a href="" data-function="ap_news_updater" data-time="48">48 Hours</a></li>
<li><a href="" data-function="ap_news_updater" data-time="72">72 Hours</a></li>
</ul>
</div>
<span>sorted by </span>
<div class="ap-dropdown ap-filter-criteria">
<a class="ap-dropdown-trigger active" href="#"><span>Hottest</span><i class="icon-sort-down"></i></a>
<ul class="list-unstyled ap-dropdown-content ap-dropdown-content-bottom depth3">
<li><a class="active" href="" data-function="ap_news_updater" data-criteria="hottest">Hottest</a></li>
<li><a href="" data-function="ap_news_updater" data-criteria="latest">Latest</a></li>
<li><a href="" data-function="ap_news_updater" data-criteria="comments">Comments</a></li>
</ul>
</div>
</div>
<a href="" class="fs-control fs-control-next">Next <i class='icon-caret-right'></i></a>
</div>
</div>
</div>
</div>

</div>
<div class="band sub-nav main">
<div class="container">
<div class="sixteen columns">
<nav>
<ul id="menu-quick-menu-1" class="sub-nav"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294411"><a href="https://www.androidpolice.com/topics/news/leak/">Leaks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294412"><a href="https://www.androidpolice.com/topics/news/exclusive/">Exclusives</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294413"><a href="https://www.androidpolice.com/topics/downloads/">Downloads</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294414"><a href="https://www.androidpolice.com/topics/deals/">Deals</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294415"><a href="https://www.androidpolice.com/topics/contests/">Giveaways</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294416"><a href="https://www.androidpolice.com/topics/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294417"><a href="https://www.androidpolice.com/topics/editorials/">Editorials</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-435701"><a title="donate" href="https://www.androidpolice.com/subscribe-donate/">Donate</a></li>
<li class="fl-right"><a class="tip-us ap-btn-red" href="https://www.androidpolice.com/contact" data-lightbox-type="ajax">Tip Us</a></li></ul>
</nav>
</div>
</div>
</div>
<div class="band content main single">
<div class="container" id="ap-body">
<div class="primary column">
<div class='ains ains-2' data-ai='WzIsMCwiYXAyX2hlYWRlcl8yIiwiIl0=' style=''>
<style type="text/css">
.adslot_ap2_header_2 { margin: 0 auto 10px; }
@media (min-width: 599px) { .adslot_ap2_header_2 { margin-top: 0px; margin-bottom: 20px } }
@media (min-width: 768px) { .adslot_ap2_header_2 { display: none !important; } }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_header_2" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="8936001924" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="large-post single post-558076 post type-post status-publish format-image hentry category-google-phones-devices category-news tag-accelerated-mobile-pages tag-amp tag-amp-real-url tag-google post_format-post-format-image" id="post-558076">
<header class="post-header">
<a class="comment-btn" href="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/#disqus_thread">...</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:43.081262028658%;"></div></div>
<h2 itemprop="name"><a href="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/">AMP pages will now show original URL in Chrome's address bar, fundamentally changing how the web works</a></h2><div class="post-meta">
<a class="author-pic hidden-phone" href="https://www.androidpolice.com/author/corbin-davenport/"><img alt='' src='https://secure.gravatar.com/avatar/aa992ac846ab841a1796544fd113e5a1?s=50&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/aa992ac846ab841a1796544fd113e5a1?s=100&#038;d=mm&#038;r=x 2x' class='avatar avatar-50 photo' height='50' width='50' /></a>
<span class="post-author"><a class="author-name" href="https://www.androidpolice.com/author/corbin-davenport/ ">Corbin Davenport</a></span><div class="card card-small card-popup card-author depth3">
<div class="card-inner">
</div>
<div class="card-action"><div class="fl-left"><div class="g-follow" data-annotation="none" data-height="20" data-href="https://plus.google.com/+CorbinDavenport" data-rel="author"></div></div><a href="https://twitter.com/corbindavenport" class="twitter-follow-button fl-left" data-show-count="false" data-size="medium" data-show-screen-name="false">Follow</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if (!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><a href="https://www.androidpolice.com/author/corbin-davenport/" class="card-action-btn fl-right">View All Posts</a>
</div>
</div><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 10:05pm PDT</time><time class="timeago" datetime="2019-04-16T22:05:52-07:00">Apr 16, 2019</time></div> </div><div class="share-box">
<ul class="share-btns list-unstyled">
<li>
<a class="share-btn-gplus"><i class="icon-google-plus"></i><span></span></a>
<div class="share-btn gplus-widget">
<a href="https://plus.google.com/share?url=https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/" class="socialite googleplus-one" data-text="AMP pages will now show original URL in Chrome&#039;s address bar, fundamentally changing how the web works" data-href="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/" data-size="medium" data-align="right" rel="nofollow" target="_blank">
Plus 1 on G+
</a>
</div>
</li>
<li>
<a><i class="icon-facebook"></i><span>36</span></a>
<div class="share-btn">
<a class="socialite facebook-like" data-layout="button_count" data-show-faces="false" href="http://www.facebook.com/sharer.php?u=https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/&amp;t=AMP pages will now show original URL in Chrome&#039;s address bar, fundamentally changing how the web works" data-href="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/" target="_blank">
Share on Facebook
</a>
</div>
</li>
<li>
<a><i class="icon-twitter"></i><span>14</span></a>
<div class="share-btn">
<a href="http://twitter.com/share" class="socialite twitter-share" data-text="AMP pages will now show original URL in Chrome&#039;s address bar, fundamentally changing how the web works" data-url="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/" data-align="right" rel="nofollow" target="_blank">
Share on Twitter
</a>
</div>
</li>
</ul>
<div class="shares">
<span>Total Shares</span><span class="count">50</span>
</div>
</div></header><div class="categories"><ul class="post-categories list-unstyled"><li><a class="cat cat-google-phones-devices" href="https://www.androidpolice.com/topics/phones-devices/google-phones-devices/" title="View all posts in Google">Google</a></li><li><a class="cat cat-news" href="https://www.androidpolice.com/topics/news/" title="View all posts in News"><i class="icon-news"></i>News</a></li></ul></div><a class="post-hero post-hero-single" href="https://www.androidpolice.com/wp-content/uploads/2019/04/vlcsnap-2019-04-17-00h58m00s057.jpg"><img class="img-hero" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fvlcsnap-2019-04-17-00h58m00s057.jpg&w=728"></a>
<div class="post-content">
<div class='ains ains-8' data-ai='WzgsMCwiYXAyX2Fib3ZlX3Bvc3RfYm9keSIsIiJd' style=''>
<style type="text/css">
.adslot_ap2_above_post_body { margin: 10px -10px; }
@media (min-width: 540px) { .adslot_ap2_above_post_body { margin: 10px -20px; } }
@media (min-width: 768px) { .adslot_ap2_above_post_body { margin: 10px -15px; } }
@media (min-width: 960px) { .adslot_ap2_above_post_body { margin: 10px -20px; } }
@media (min-width: 1160px) { .adslot_ap2_above_post_body { margin: 10px -30px; } }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_above_post_body" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4825925002" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><a href="https://www.androidpolice.com/wp-content/uploads/2019/04/vlcsnap-2019-04-17-00h58m00s057.jpg" class=" no-style"></a></p>
<p>Google had its 2019 'AMP Conf' in Tokyo today, and announced a series of changes and new features coming to the company's <a href="https://www.amp.org/" class="external" rel="nofollow" target="_blank">Accelerated Mobile Pages project</a>. The most important announcement was that AMP pages will now show the original URL in the address bar, which should solve the platform's greatest point of confusion <span class="ILfuVd">&mdash;</span> but it's only making things worse.<span id="more-558076"></span></p>
<p>When you tap on an AMP link from Google Search, you aren't actually taken to the optimized page on the site's own server. Instead, you get a cached version stored on Google's own servers (to improve performance), with a bar at the top providing you with the original URL in case you want it.</p>
<p style="text-align: center;"><a href="https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800.png" class=" no-style"><img class="alignnone size-medium wp-image-493918" src="https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800-329x585.png" alt="" width="329" height="585" srcset="https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800-329x585.png 329w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800-768x1365.png 768w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800-668x1188.png 668w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800-161x286.png 161w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800-217x386.png 217w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800-728x1294.png 728w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211800.png 1080w" sizes="(max-width: 329px) 100vw, 329px"></a> <a href="https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728.png" class=" no-style"><img class="alignnone size-medium wp-image-493919" src="https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728-329x585.png" alt="" width="329" height="585" srcset="https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728-329x585.png 329w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728-768x1365.png 768w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728-668x1188.png 668w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728-161x286.png 161w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728-217x386.png 217w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728-728x1294.png 728w, https://www.androidpolice.com/wp-content/uploads/2018/05/Screenshot_20180522-211728.png 1080w" sizes="(max-width: 329px) 100vw, 329px"></a></p>
<p style="text-align: center;"><em><strong>Left:</strong> Normal article; <strong>Right:</strong> AMP article loaded from Google Search</em></p>
<p>Google began testing a possible solution <a href="https://www.androidpolice.com/2018/01/09/google-finally-fixing-urls-amp-pages/">last year</a>. It would use a browser feature developed for Chrome called 'Web Packaging,' which allows sites to display content on behalf of other sites <span class="ILfuVd">&mdash;</span> while using TLS to ensure the content hasn't been changed along the way. Web Packaging was <a href="https://www.chromestatus.com/feature/5745285984681984" class="external" rel="nofollow" target="_blank">enabled by default in Chrome 73</a>, but <a href="https://github.com/mozilla/standards-positions/issues/29" class="external" rel="nofollow" target="_blank">Mozilla hasn't yet decided</a> if it will add Web Packing support to Firefox.</p><div class="ains ains-3" data-ai="WzMsMCwiYXAyX2luX3Bvc3RfYm9keV8xIiwiIl0=" style="margin: 8px auto; text-align: center; clear: both;">
<style type="text/css">
.adslot_ap2_in_post_body_1 {  }
@media (min-width: 599px) { .adslot_ap2_in_post_body_1 {  } }
@media (min-width: 768px) { .adslot_ap2_in_post_body_1 {  } }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_in_post_body_1" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4273329030" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">AMP pages are beautiful, but links to AMP pages? Not so much ... </p>
<p>Until today! Signed exchanges are here: now you can get instant loading for AMP on your own domain! &#128588; <a href="https://twitter.com/hashtag/AMPConf?src=hash&amp;ref_src=twsrc%5Etfw" class="external" rel="nofollow" target="_blank">#AMPConf</a> <a href="https://t.co/OSEcKDc3A5" class="external" rel="nofollow" target="_blank">pic.twitter.com/OSEcKDc3A5</a></p>
<p>&mdash; AMP Project (@AMPhtml) <a href="https://twitter.com/AMPhtml/status/1118318585678577664?ref_src=twsrc%5Etfw" class="external" rel="nofollow" target="_blank">April 17, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>The company announced today at AMP Conf that sites can now use Web Packaging with AMP. Now when users tap on an AMP page from Google Search, it will look like they were taken to the proper page (complete with the green lock icon), but they're actually getting the AMP version served from Google's servers. What's more, with the information bar gone, it's not clear how users can actually visit the original version of a page.</p>
<p>It's extremely difficult for me to look at this any other way than a user-hostile 'feature' that fundamentally changes how the web works. One of the basic principles of the internet is that a URL tells you exactly where you are, but if you're using Chrome, that's no longer true.</p>
<p style="text-align: center;"><a href="https://www.androidpolice.com/wp-content/uploads/2019/04/image-5.png" class=" no-style"><img class="alignnone size-hero-size wp-image-558079" src="https://www.androidpolice.com/wp-content/uploads/2019/04/image-5-728x426.png" alt="" width="668" height="391" srcset="https://www.androidpolice.com/wp-content/uploads/2019/04/image-5-728x426.png 728w, https://www.androidpolice.com/wp-content/uploads/2019/04/image-5-329x193.png 329w, https://www.androidpolice.com/wp-content/uploads/2019/04/image-5-768x450.png 768w, https://www.androidpolice.com/wp-content/uploads/2019/04/image-5-668x391.png 668w, https://www.androidpolice.com/wp-content/uploads/2019/04/image-5-161x94.png 161w, https://www.androidpolice.com/wp-content/uploads/2019/04/image-5-217x127.png 217w, https://www.androidpolice.com/wp-content/uploads/2019/04/image-5.png 1600w" sizes="(max-width: 668px) 100vw, 668px"></a></p>
<p>The AMP versions of most pages are limited in functionality, so now users will be unknowingly stuck on an alternate version of the page they wanted to visit, with seemingly no way to see the real page. Want to use the comments section, but the site you're visiting hasn't added comments to the AMP version? Well, sucks to be you, I guess.</p>
<p>CloudFlare is rolling out support for AMP Real URL, so expect to see some of your favorite sites start to use it over the coming weeks. Now might be a good opportunity to check out <a href="https://duckduckgo.com/" class="external" rel="nofollow" target="_blank">DuckDuckGo</a> and/or Firefox.</p>
<div class="clear pre-horizontal-boxes"></div><ul class="list-unstyled list-inline list-emphasis"><li class="title"><strong>Source: </strong></li><li><a href="https://webmasters.googleblog.com/2019/04/instant-loading-amp-pages-from-your-own.html" class="external" rel="nofollow" target="_blank">Google Webmasters Blog</a>, </li><li> <a href="https://blog.cloudflare.com/announcing-amp-real-url/" class="external" rel="nofollow" target="_blank">CloudFlare</a></li></ul>
</div>
<div class="post-footer-meta">
<ul class="horizontal-boxes list-unstyled horizontal-boxes-tags"><li class="title green-border header-bg green-bg">Tags</li><li><a href="https://www.androidpolice.com/tags/accelerated-mobile-pages/" rel="tag">accelerated mobile pages</a></li><li><a href="https://www.androidpolice.com/tags/amp/" rel="tag">amp</a></li><li><a href="https://www.androidpolice.com/tags/amp-real-url/" rel="tag">amp real url</a></li><li><a href="https://www.androidpolice.com/tags/google/" rel="tag">Google</a></li></ul>
<a href="#" class="btn btn-small btn-pb btn-subscribe" data-trigger="reveal" data-target="card-pb" data-function="apLoadPushbullet"><i class="icon-pushbullet"></i>subscribe</a>
<div class="clear"></div>
<div id="card-pb" class="card card-popup card-pb depth3">
<div class="card-inner"></div>
</div>
</div>
<div class='ains ains-9' data-ai='WzksMCwiYXAyX2JlbG93X3Bvc3RfYm9keSIsIiJd' style=''>
<style type="text/css">
.adslot_ap2_below_post_body { margin: 10px -10px 0; }
@media (min-width: 540px) { .adslot_ap2_below_post_body { margin: 10px -20px 0; } }
@media (min-width: 599px) { .adslot_ap2_below_post_body { margin: 20px -20px 0; } }
@media (min-width: 768px) { .adslot_ap2_below_post_body { margin: 20px -15px 0; } }
@media (min-width: 960px) { .adslot_ap2_below_post_body { margin: 30px -20px 0; } }
@media (min-width: 1160px) { .adslot_ap2_below_post_body { margin: 30px -30px 0; } }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_below_post_body" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="7266108282" data-ad-format="auto" data-full-width-responsive="false"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="OUTBRAIN" data-src="https://www.androidpolice.com/2019/04/16/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works/" data-widget-id="AR_1" data-ob-template="IllogicalRobot"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
</div>
<div class="post-footer">
<div class="article-nav">
<div class="article-nav-box ">
<a href="https://www.androidpolice.com/2019/04/16/amp-stories-will-roll-out-to-mobile-google-search-soon/#disqus_thread" class="comment-btn">...</a>
<a href="https://www.androidpolice.com/2019/04/16/amp-stories-will-roll-out-to-mobile-google-search-soon/">
<div class="article-nav-box-content">
<h4 class="first-heading"><span>Previous</span> Story</h4>
<div class="article-nav-box-title">
<div class="ellipsize">
<h5>AMP Stories will roll out to mobile Google Search soon</h5>
</div>
</div>
</div>
<div class="frame">
<div class="frame-image-wrapper">
<img class="centered animate" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fvlcsnap-2019-04-17-00h04m31s973.jpg&h=129&zc=3" alt="">
</div>
<img class="bg animate" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fvlcsnap-2019-04-17-00h04m31s973.jpg&w=150&h=85&zc=1&f=8|8|8|8|8|8|8|8|8|8|8|8|8" alt="">
</div>
</a>
</div>
<div class="article-nav-box article-nav-box-right article-nav-box-disabled">
<h5>This Is The Most Recent Story</h5>
</div>
</div>
<div class="post-footer-inner">
<div class="single-post-widget">
<li id="appopularposts-7" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><header class="section-header"><h4 class="header-bg">Trending</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/03/27/inbox-is-about-to-die-and-google-still-hasnt-brought-its-best-feature-to-gmail/#comments">277</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999563615161%;"></div></div>
<a class="cell-link" href="/2019/03/27/inbox-is-about-to-die-and-google-still-hasnt-brought-its-best-feature-to-gmail/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F03%2FInbox-Gmail-gif-Google-hero.gif&w=60&h=60">
<div class="cell-content">
<h4>Inbox is about to die, and Google still hasn't brought its best feature to Gmail</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/03/27 12:00pm PDT</time><time class="timeago" datetime="2019-03-27T12:00:08-07:00">Mar 27, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/04/google-messages-v4-2-now-supports-attachments-of-any-type-adds-verified-sms-details-apk-teardown/#comments">75</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.99924084713%;"></div></div>
<a class="cell-link" href="/2019/04/04/google-messages-v4-2-now-supports-attachments-of-any-type-adds-verified-sms-details-apk-teardown/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fmsg.png&w=60&h=60">
<div class="cell-content">
<h4>Google Messages v4.2 now supports attachments of any type, adds Verified SMS details [APK Teardown]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/04 1:24pm PDT</time><time class="timeago" datetime="2019-04-04T13:24:00-07:00">Apr 4, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/11/samsung-is-screwing-up-many-galaxy-s10-trade-ins-leaving-customers-frustrated/#comments">132</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998480868326%;"></div></div>
<a class="cell-link" href="/2019/04/11/samsung-is-screwing-up-many-galaxy-s10-trade-ins-leaving-customers-frustrated/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2FGalaxy-S10-Plus-on-a-pile-of-other-phones.jpg&w=60&h=60">
<div class="cell-content">
<h4>Samsung is screwing up many Galaxy S10 trade-ins, leaving customers frustrated</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/11 3:54pm PDT</time><time class="timeago" datetime="2019-04-11T15:54:01-07:00">Apr 11, 2019</time></div></div>
</div>
</a>
</li></ul></section><div class='ains ains-11' data-ai='WzExLDAsImFwMl90cmVuZGluZ19wb3N0c193cmFwcGVyIiwiIl0=' style=''>
<style type="text/css">
.adslot_ap2_trending_posts_wrapper { }
@media (min-width: 960px) { .adslot_ap2_trending_posts_wrapper { float: left; width: 320px; height: 270px} }
</style>
<div class='adslot_ap2_trending_posts_wrapper'>
<style type="text/css">
    .adslot_ap2_trending_posts { margin: 10px auto; width: 336px; height: 280px}
    @media (min-width: 960px) { .adslot_ap2_trending_posts { width: 300px; height: 250px; } }
    </style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot adslot_ap2_trending_posts" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="3021676711" data-full-width-responsive="false"></ins>
<script>
    (adsbygoogle = window.adsbygoogle || []).push({});
    </script>
</div></div>
</div>
<div id="comments">
<header class="section-header ">
<h4 class="header-bg blue-bg">Comments</h4>
</header>
<a name="comments"></a>
<section>
<div id="disqus_thread"></div>
</section>
</div>
</div>
</div>
<center>
<div class='ains ains-13' data-ai='WzEzLDAsImFwMl9mb290ZXIgc21hbGwiLCIiXQ==' style=''>
<style type="text/css">
.adslot_ap2_footer_little { margin-bottom: 10px; }
@media (min-width: 599px) { .adslot_ap2_footer_little { margin-bottom: 20px; } }
@media (min-width: 768px) { .adslot_ap2_footer_little { display: none !important; } }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_footer_little" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="9594790476" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</center>
</div>
<div id="sbar" class="secondary column">
<ul id="sbar-content" class="list-unstyled">
<li id="ai_widget-2" class="widget-odd widget-first widget-1  none widget ai_widget"><div class='ains ains-14' data-ai='WzE0LDFd' style=''>
<style type="text/css">
.adslot_ap2_sidebar_1 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_1 { display:inline-block; width: 300px; height: 250px;} }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_sidebar_1" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="6545105860"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</li>
<li id="apfollowwidget-2" class="widget-even widget-2 red widget ap-follow-widget"><header class="section-header"><h4 class="header-bg">Follow Android Police</h4></header>
<section class="card">
<div class="card-inner">
<div class="multi-column"> <div class="one-third">
<a class="ap-follow-btn" title="Follow Android Police on Twitter" class="" href="https://twitter.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon twitter-color"><i class="icon-twitter"></i></div>
<span class="ap-sidebar-title">497k</span>
</a>
</div>
<div class="one-third">
<a class="ap-follow-btn" title="Like Android Police on Facebook" class="" href="https://facebook.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon facebook-color"><i class="icon-facebook"></i></div>
<span class="ap-sidebar-title">156k</span>
</a>
</div>
<div class="one-third">
<a class="ap-follow-btn" title="Subscribe on YouTube" class="" href="https://youtube.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon youtube-color"><i class="icon-youtube"></i></div>
<span class="ap-sidebar-title">285k</span>
</a>
</div>
</div><div class="multi-column"> <div class="one-third">
<a class="ap-follow-btn" title="Follow on Twitch" class="" href="https://twitch.tv/androidpolice" target="_blank">
<div class="ap-follow-icon twitch-color"><i class="icon-twitch"></i></div>
<span class="ap-sidebar-title">7.16k</span>
</a>
</div>
</div>
</div>
<div class="card-action">
<a class="currents ap-follow-btn" title="Subscribe to the RSS feed" href="/feed" target="_blank">
<div class="ap-follow-icon rss-color"><i class="icon-feed"></i></div>
</a>
<a class="currents ap-follow-btn" title="Read on Feedly" href="https://feedly.com/i/subscription/feed%2Fhttps://www.androidpolice.com/feed" target="_blank">
<div class="ap-follow-icon ap-follow-icon-feedly"></div>
</a>
<a class="currents ap-follow-btn" title="Read on Google Play Newsstand" href="https://news.google.com/publications/CAAqBggKMLuYFDDSzAI" target="_blank">
<div class="ap-follow-icon newsstand-color"><i class="icon-newsstand"></i></div>
</a>
<a class="pushbullet-subscribe-widget fl-right" data-channel="androidpolicefeed" data-widget="button" data-size="small"></a>
</div>
</section>
</li>
<li id="ai_widget-3" class="widget-odd widget-3  none widget ai_widget"><div class='ains ains-15' data-ai='WzE1LDJd' style=''>
<div class="adslot_ap2_sidebar_2">
<script type="text/javascript">
if (window.matchMedia("(min-width: 768px)").matches) {
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - 300x600_sidebar_2 */
google_ad_slot = "2879686538";
google_ad_width = 300;
google_ad_height = 600;
//-->

document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}
</script>
</div></div>
</li>
<li id="aprecentpostswidget-2" class="widget-even widget-4 green widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Latest Deals</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/hp-2-in-1-chromebook-x14-400-best-buy/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:46.639134141517%;"></div></div>
<a class="cell-link" href="/2019/04/16/hp-2-in-1-chromebook-x14-400-best-buy/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2F6301869cv1d.png&w=60&h=60">
<div class="cell-content">
<h4>HP 2-in-1 Chromebook x360 is $400 ($200 off) at Best Buy</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 11:56am PDT</time><time class="timeago" datetime="2019-04-16T11:56:52-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/ankers-19000mah-battery-is-just-85-45-off-on-amazon/#comments">11</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:38.756613401382%;"></div></div>
<a class="cell-link" href="/2019/04/16/ankers-19000mah-battery-is-just-85-45-off-on-amazon/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fanker-battery-hero.jpg&w=60&h=60">
<div class="cell-content">
<h4>Anker's 19,000mAh battery is just $85 ($45 off) on Amazon</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 10:53am PDT</time><time class="timeago" datetime="2019-04-16T10:53:31-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/amazon-fire-hd-10-is-100-50-off-today-only-at-best-buy/#comments">5</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:39.604329686156%;"></div></div>
<a class="cell-link" href="/2019/04/16/amazon-fire-hd-10-is-100-50-off-today-only-at-best-buy/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F09%2Fnexus2cee_Fire-HD-10-Colors.jpg&w=60&h=60">
<div class="cell-content">
<h4>Amazon Fire HD 10 is $100 ($50 off) today only at Best Buy</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 10:21am PDT</time><time class="timeago" datetime="2019-04-16T10:21:49-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/sonys-wh-1000xm3-bluetooth-anc-headphones-are-276-74-off-on-rakuten-with-code/#comments">8</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:38.467362878317%;"></div></div>
<a class="cell-link" href="/2019/04/16/sonys-wh-1000xm3-bluetooth-anc-headphones-are-276-74-off-on-rakuten-with-code/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F01%2F1000xm3-hero.png&w=60&h=60">
<div class="cell-content">
<h4>Sony's WH-1000XM3 Bluetooth ANC headphones are $276 ($74 off) on Rakuten with code</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 10:11am PDT</time><time class="timeago" datetime="2019-04-16T10:11:44-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/best-buy-has-a-hue-white-ambiance-bulb-and-dimmer-switch-bundle-for-30-20-off/#comments">0</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:36.69107493194%;"></div></div>
<a class="cell-link" href="/2019/04/16/best-buy-has-a-hue-white-ambiance-bulb-and-dimmer-switch-bundle-for-30-20-off/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2FHue-BulbDimmer.png&w=60&h=60">
<div class="cell-content">
<h4>Best Buy has a Hue White Ambiance bulb and dimmer switch bundle for $30 ($20 off)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 9:26am PDT</time><time class="timeago" datetime="2019-04-16T09:26:39-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="ai_widget-4" class="widget-odd widget-5  none widget ai_widget"><div class='ains ains-16' data-ai='WzE2LDFd' style=''>
<style type="text/css">
.adslot_ap2_sidebar_3 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_3 { display:inline-block; width: 300px; height: 250px;} }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_sidebar_3" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="2745870776"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</li>
<li id="wpb_widget-3" class="widget-even widget-6 blue widget widget_wpb_widget"><header class="section-header"><h4 class="header-bg">Latest Poll</h4></header><section class="ap-sbar-widget-wrapper"><div id="polls-449" class="wp-polls">
<form id="polls_form_449" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_449_nonce" name="wp-polls-nonce" value="badb4eb628" /></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="449" /></p>
<p style="text-align: center;"><strong>Has the YouTube TV price bump pushed you to unsubscribe?</strong></p><div id="polls-449-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li><input type="radio" id="poll-answer-2276" name="poll_449" value="2276" /> <label for="poll-answer-2276">Nope, I'm keeping my subscription.</label></li>
<li><input type="radio" id="poll-answer-2277" name="poll_449" value="2277" /> <label for="poll-answer-2277">Yep, too much for me.</label></li>
<li><input type="radio" id="poll-answer-2278" name="poll_449" value="2278" /> <label for="poll-answer-2278">Unsubbed before the announcement.</label></li>
<li><input type="radio" id="poll-answer-2279" name="poll_449" value="2279" /> <label for="poll-answer-2279">I haven't decided yet.</label></li>
<li><input type="radio" id="poll-answer-2280" name="poll_449" value="2280" /> <label for="poll-answer-2280">Never had it to begin with.</label></li>
<li><input type="radio" id="poll-answer-2281" name="poll_449" value="2281" /> <label for="poll-answer-2281">I subscribed because of the increase.</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(449);" /></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(449); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-449-loading" class="wp-polls-loading"><img src="https://www.androidpolice.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image" />&nbsp;Loading ...</div>
<div class="center"><p><a href="https://www.androidpolice.com/2019/04/14/weekend-poll-has-the-youtube-tv-price-bump-pushed-you-to-unsubscribe/" class="primary-btn btn-widget"> Discuss This Poll</a></p></div></section></li>
<li id="ai_widget-5" class="widget-odd widget-7  none widget ai_widget"><div class='ains ains-17' data-ai='WzE3LDFd' style=''>
<style type="text/css">
.adslot_ap2_sidebar_4 { display: none; text-align: center;}
@media (min-width: 768px) { .adslot_ap2_sidebar_4 { display:inline-block; width: 300px; height: 600px;} }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_sidebar_4" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="4881079520"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</li>
<li id="aprecentpostswidget-3" class="widget-even widget-8 teal widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Recent Reviews</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/the-soundcore-liberty-neo-finally-bring-decent-audio-to-cheap-true-wireless-earbuds/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:38.635443322542%;"></div></div>
<a class="cell-link" href="/2019/04/16/the-soundcore-liberty-neo-finally-bring-decent-audio-to-cheap-true-wireless-earbuds/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2FSoundcore-liberty-neo-hero.png&w=60&h=60">
<div class="cell-content">
<h4>The Soundcore Liberty Neo finally bring decent audio to cheap true wireless earbuds</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 8:20am PDT</time><time class="timeago" datetime="2019-04-16T08:20:12-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/14/the-lg-g8-is-a-good-phone-that-cant-escape-some-of-the-bad-ideas-behind-it/#comments">94</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-20" style="width:15.865525393146%;"></div></div>
<a class="cell-link" href="/2019/04/14/the-lg-g8-is-a-good-phone-that-cant-escape-some-of-the-bad-ideas-behind-it/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Flg-g8-hero.png&w=60&h=60">
<div class="cell-content">
<h4>The LG G8 is a good phone that can't escape some of the bad ideas behind it</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/14 7:57am PDT</time><time class="timeago" datetime="2019-04-14T07:57:21-07:00">Apr 14, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/14/zendures-supertank-may-be-ugly-but-its-the-best-and-most-powerful-type-c-battery-you-can-buy/#comments">37</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:29.984603116714%;"></div></div>
<a class="cell-link" href="/2019/04/14/zendures-supertank-may-be-ugly-but-its-the-best-and-most-powerful-type-c-battery-you-can-buy/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2FKGC23503.jpg&w=60&h=60">
<div class="cell-content">
<h4>Zendure's SuperTank may be ugly, but it's the best and most powerful Type-C battery you can buy</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/14 6:00am PDT</time><time class="timeago" datetime="2019-04-14T06:00:33-07:00">Apr 14, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/13/belkins-boost-up-wireless-chargers-make-the-pixel-stand-look-like-a-good-deal/#comments">9</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:25.793130243417%;"></div></div>
<a class="cell-link" href="/2019/04/13/belkins-boost-up-wireless-chargers-make-the-pixel-stand-look-like-a-good-deal/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2FBelkin-1-1.jpg&w=60&h=60">
<div class="cell-content">
<h4>Belkin's Boost Up wireless chargers make the Pixel Stand look like a good deal</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/13 8:00am PDT</time><time class="timeago" datetime="2019-04-13T08:00:49-07:00">Apr 13, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/12/quick-rapid-turbo-and-fast-charging-explained-what-you-need-to-know-about-charging-your-smartphone/#comments">289</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:98.955755172327%;"></div></div>
<a class="cell-link" href="/2019/04/12/quick-rapid-turbo-and-fast-charging-explained-what-you-need-to-know-about-charging-your-smartphone/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2015%2F06%2Fap_resize.png&w=60&h=60">
<div class="cell-content">
<h4>Quick, Rapid, Fast, and Power Delivery charging explained: What you need to know about charging your smartphone (2019 edition)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/12 4:44pm PDT</time><time class="timeago" datetime="2019-04-12T16:44:00-07:00">Apr 12, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="aprecentpostswidget-5" class="widget-odd widget-9 red widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Latest Roundups</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/14/29-best-new-and-1-wtf-android-games-released-this-week-including-construction-simulator-3-photographs-and-distraint-2/#comments">3</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:27.80947311944%;"></div></div>
<a class="cell-link" href="/2019/04/14/29-best-new-and-1-wtf-android-games-released-this-week-including-construction-simulator-3-photographs-and-distraint-2/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60">
<div class="cell-content">
<h4>29 best new (and 1 WTF) Android games released this week including Construction Simulator 3, Photographs, and Distraint 2</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/14 7:21am PDT</time><time class="timeago" datetime="2019-04-14T07:21:19-07:00">Apr 14, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/13/22-new-and-notable-and-1-wtf-android-apps-from-the-last-two-weeks-including-spark-holey-light-and-nytimes-daydream-3-30-19-4-13-19/#comments">4</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:37.547093988271%;"></div></div>
<a class="cell-link" href="/2019/04/13/22-new-and-notable-and-1-wtf-android-apps-from-the-last-two-weeks-including-spark-holey-light-and-nytimes-daydream-3-30-19-4-13-19/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_apps-01.png&w=60&h=60">
<div class="cell-content">
<h4>22 new and notable (and 1 WTF) Android apps from the last two weeks including Spark, Holey Light, and NYTimes - Daydream (3/30/19 - 4/13/19)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/13 6:31am PDT</time><time class="timeago" datetime="2019-04-13T06:31:25-07:00">Apr 13, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/11/bonus-round-photographs-tiny-klepto-eat-it-up-legfish-oco-and-true-surf/#comments">1</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:27.461249872132%;"></div></div>
<a class="cell-link" href="/2019/04/11/bonus-round-photographs-tiny-klepto-eat-it-up-legfish-oco-and-true-surf/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fcdn.androidpolice.com%2Fwp-content%2Fuploads%2F2013%2F05%2Fnexusae0_bonusround_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>[Bonus Round] Photographs, Tiny Klepto, Eat it Up, LegFish, OCO, and True Surf</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/11 10:24am PDT</time><time class="timeago" datetime="2019-04-11T10:24:39-07:00">Apr 11, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/07/18-best-new-android-games-from-this-week-including-cultist-simulator-after-burner-climax-and-scorcher/#comments">5</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:26.722957514927%;"></div></div>
<a class="cell-link" href="/2019/04/07/18-best-new-android-games-from-this-week-including-cultist-simulator-after-burner-climax-and-scorcher/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60">
<div class="cell-content">
<h4>18 best new Android games released this week including Cultist Simulator, After Burner Climax, and Scorcher</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/07 7:14am PDT</time><time class="timeago" datetime="2019-04-07T07:14:51-07:00">Apr 7, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/04/bonus-round-dungeon-warfare-2-ground-up-construction-spin-up-nitro-nation-experiment-john-on-fire-a-mans-cat-taken-and-tower-breaker/#comments">2</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:12.979924059627%;"></div></div>
<a class="cell-link" href="/2019/04/04/bonus-round-dungeon-warfare-2-ground-up-construction-spin-up-nitro-nation-experiment-john-on-fire-a-mans-cat-taken-and-tower-breaker/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fcdn.androidpolice.com%2Fwp-content%2Fuploads%2F2013%2F05%2Fnexusae0_bonusround_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>[Bonus Round] Dungeon Warfare 2, Ground Up Construction, Spin Up!, Nitro Nation Experiment, John on Fire A Mans Cat Taken, and Tower Breaker</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/04 11:03am PDT</time><time class="timeago" datetime="2019-04-04T11:03:29-07:00">Apr 4, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="aprecentpostswidget-4" class="widget-even widget-10 blue widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Recent Apps and Games</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/dont-panic-emails-about-samsung-email-accessing-your-gmail-are-legit-samsung-is-working-on-a-fix/#comments">17</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-60" style="width:63.819998926631%;"></div></div>
<a class="cell-link" href="/2019/04/16/dont-panic-emails-about-samsung-email-accessing-your-gmail-are-legit-samsung-is-working-on-a-fix/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fsamsung-email-google-alert-hero.png&w=60&h=60">
<div class="cell-content">
<h4>Don't panic: Emails about Samsung Email accessing your Gmail are legit, Samsung is working on a fix</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 4:54pm PDT</time><time class="timeago" datetime="2019-04-16T16:54:31-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/waymo-app-comes-to-the-play-store-but-you-probably-still-cant-use-it/#comments">11</a>
 <div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:36.985946979743%;"></div></div>
<a class="cell-link" href="/2019/04/16/waymo-app-comes-to-the-play-store-but-you-probably-still-cant-use-it/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fwaymo-app.jpg&w=60&h=60">
<div class="cell-content">
<h4>Waymo app comes to the Play Store, but you probably still can't use it</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 12:37pm PDT</time><time class="timeago" datetime="2019-04-16T12:37:49-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/pubg-mobile-0-12-0-update-brings-darkest-night-a-new-zombie-filled-survival-mode/#comments">7</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:42.774283226665%;"></div></div>
<a class="cell-link" href="/2019/04/16/pubg-mobile-0-12-0-update-brings-darkest-night-a-new-zombie-filled-survival-mode/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2F57433593_1230922273735582_2249038699469733888_n.jpg&w=60&h=60">
<div class="cell-content">
<h4>PUBG Mobile 0.12.0 update brings Darkest Night, a new zombie-filled survival mode</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 11:35am PDT</time><time class="timeago" datetime="2019-04-16T11:35:13-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/google-addresses-developer-concerns-with-promises-to-improve-play-store-appeal-processes/#comments">6</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:37.189485594652%;"></div></div>
<a class="cell-link" href="/2019/04/16/google-addresses-developer-concerns-with-promises-to-improve-play-store-appeal-processes/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F01%2FCerberus-Phone-Keyboard-Hero.jpg&w=60&h=60">
<div class="cell-content">
<h4>Google addresses developer concerns with promises to improve Play Store appeal processes</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 9:42am PDT</time><time class="timeago" datetime="2019-04-16T09:42:55-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2019/04/16/google-maps-is-asking-commuters-how-crowded-their-trains-are/#comments">19</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:40.184356568932%;"></div></div>
<a class="cell-link" href="/2019/04/16/google-maps-is-asking-commuters-how-crowded-their-trains-are/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fgoogle-maps-train-crowded-1.png&w=60&h=60">
<div class="cell-content">
<h4>Google Maps is asking commuters how crowded their trains are</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 9:20am PDT</time><time class="timeago" datetime="2019-04-16T09:20:03-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="apblastfromthepast-2" class="widget-odd widget-last widget-11 red widget ap-blast-from-past"><header class="section-header"><h4 class="header-bg">Blast from the Past</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="/2018/04/16/app-sales-apr-16-2018/#comments">9</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.981145907324%;"></div></div>
<a class="cell-link" href="/2018/04/16/app-sales-apr-16-2018/">
<h3 class="ap-sidebar-title"><span>1 Year Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F05%2Fnexus2cee_monday.png&w=60&h=60">
<div class="cell-content">
<h4>26 temporarily free and 49 on-sale apps to begin the week</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2018/04/16 2:23pm PDT</time><time class="timeago" datetime="2018-04-16T14:23:59-07:00">Apr 16, 2018</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2017/04/16/people-folders-google-photos-disappearing-google-case/#comments">48</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-60" style="width:61.44032003897%;"></div></div>
<a class="cell-link" href="/2017/04/16/people-folders-google-photos-disappearing-google-case/">
<h3 class="ap-sidebar-title"><span>2 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_googlephotoshero_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>People folders in Google Photos are disappearing for some, Google is on the case</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/16 3:11pm PDT</time><time class="timeago" datetime="2017-04-16T15:11:25-07:00">Apr 16, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2016/04/16/shrug-facepalm-for-the-first-time-ever-android-supports-more-emoji-than-ios-does/#comments">158</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:98.237941155203%;"></div></div>
<a class="cell-link" href="/2016/04/16/shrug-facepalm-for-the-first-time-ever-android-supports-more-emoji-than-ios-does/">
<h3 class="ap-sidebar-title"><span>3 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F04%2Fnexus2cee_emoji.png&w=60&h=60">
<div class="cell-content">
<h4>[Shrug, Facepalm] For The First Time Ever, Android Supports More Emoji Than iOS Does</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2016/04/16 3:26pm PDT</time><time class="timeago" datetime="2016-04-16T15:26:20-07:00">Apr 16, 2016</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2015/04/16/google-play-services-causing-severe-wakelock-issues-on-cyanogen-os-12-and-cm12-patch-coming-next-week/#comments">106</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-90" style="width:89.399244480819%;"></div></div>
<a class="cell-link" href="/2015/04/16/google-play-services-causing-severe-wakelock-issues-on-cyanogen-os-12-and-cm12-patch-coming-next-week/">
<h3 class="ap-sidebar-title"><span>4 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2015%2F04%2Fnexus2cee_OnePlusOne.jpg&w=60&h=60">
<div class="cell-content">
<h4>Google Play Services Causing Severe Wakelock Issues On Cyanogen OS 12 And CM12, Patch Coming Next Week</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2015/04/16 1:51pm PDT</time><time class="timeago" datetime="2015-04-16T13:51:42-07:00">Apr 16, 2015</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2014/04/16/google-calendar-for-android-finally-suggests-locations-of-nearby-places-and-lets-you-join-video-calls-in-hangouts-apk-download/#comments">32</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2014/04/16/google-calendar-for-android-finally-suggests-locations-of-nearby-places-and-lets-you-join-video-calls-in-hangouts-apk-download/">
<h3 class="ap-sidebar-title"><span>5 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2014%2F04%2Fnexusae0_Calendar-Thumb_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>Updated Google Calendar For Android Finally Suggests Locations Of Nearby Places And Lets You Join Video Calls In Hangouts [APK Download]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2014/04/16 11:03pm PDT</time><time class="timeago" datetime="2014-04-16T23:03:07-07:00">Apr 16, 2014</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2013/04/16/att-one-x-updated-to-v1-19-502-1-with-bug-fixes-galore-full-rom-download-available/#comments">13</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2013/04/16/att-one-x-updated-to-v1-19-502-1-with-bug-fixes-galore-full-rom-download-available/">
<h3 class="ap-sidebar-title"><span>6 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2013%2F04%2Fnexusae0_HTC-One-X-Plus.jpg&w=60&h=60">
<div class="cell-content">
<h4>AT&amp;T HTC One X+ Updated To v1.19.502.1 With Bug Fixes Galore, Full ROM Download Available</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2013/04/16 6:29pm PDT</time><time class="timeago" datetime="2013-04-16T18:29:23-07:00">Apr 16, 2013</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2012/04/16/music-is-math-now-snapnplay-lets-you-play-back-sheet-music-by-taking-a-picture-of-the-notes/#comments">15</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2012/04/16/music-is-math-now-snapnplay-lets-you-play-back-sheet-music-by-taking-a-picture-of-the-notes/">
<h3 class="ap-sidebar-title"><span>7 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2012%2F04%2Fsnapnplay.png&w=60&h=60">
<div class="cell-content">
<h4>[New App] Music Is Math Now: SnapNPlay Lets You Play Back Sheet Music By Taking A Picture Of The Notes</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2012/04/16 10:39pm PDT</time><time class="timeago" datetime="2012-04-16T22:39:50-07:00">Apr 16, 2012</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2011/04/16/motorola-rolls-out-froyo-for-bravo-users-applaud/#comments">1</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2011/04/16/motorola-rolls-out-froyo-for-bravo-users-applaud/">
<h3 class="ap-sidebar-title"><span>8 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2011%2F04%2Fimage_thumb330.png&w=60&h=60">
<div class="cell-content">
<h4>Motorola Rolls Out Froyo For Bravo - Users Applaud</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2011/04/16 3:00pm PDT</time><time class="timeago" datetime="2011-04-16T15:00:16-07:00">Apr 16, 2011</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="/2010/04/16/htc-hero-and-samsung-moment-android-2-1-updates-delayed-again-this-time-till-early-may/#comments">9</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div></div>
<a class="cell-link" href="/2010/04/16/htc-hero-and-samsung-moment-android-2-1-updates-delayed-again-this-time-till-early-may/">
<h3 class="ap-sidebar-title"><span>9 Years Ago</span> Today</h3>
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fandroidpolice.com%2Fwp-content%2Fuploads%2FHTC.1UpdatesDelayedAgainThisTimeTillEarl_B485%2Fimage.png&w=60&h=60">
<div class="cell-content">
<h4>HTC Hero And Samsung Moment Android 2.1 Updates Coming In Early May</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2010/04/16 12:55pm PDT</time><time class="timeago" datetime="2010-04-16T12:55:22-07:00">Apr 16, 2010</time></div></div>
</div>
</a>
</li></ul></section></li>
</ul>
</div> </div>
</div>
<script type="text/javascript">
    var ajaxurl = 'https://www.androidpolice.com/wordpress/wp-admin/admin-ajax.php';
    var postid = 558076</script>
<center>
<div class='ains ains-12' data-ai='WzEyLDAsImFwMl9mb290ZXIgbGFyZ2UiLCIiXQ==' style=''>
<style type="text/css">
.adslot_ap2_footer_large { display: none; }
@media (min-width: 768px) { .adslot_ap2_footer_large { display:inline-block; width: 728px; height: 90px; margin-bottom: 10px} }
@media (min-width: 970px) { .adslot_ap2_footer_large { display:inline-block; width: 970px; height: 250px; margin-bottom: 20px} }
</style>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle adslot_ap2_footer_large" style="display:block" data-ad-client="ca-pub-8776668743582988" data-ad-slot="9594790476"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</center>
<div class="band footer">
<div class="container">
<div class="ap-hottest-content-wrapper">
<header class="section-header"><h4>What's Hot</h4></header>
<div class="one-third column alpha">
<li id="appopularposts-5" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 24 Hours</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/16/sprint-galaxy-s10-reception-issues-may-have-a-fix-while-galaxy-s8-problems-surface/#comments">87</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-80" style="width:77.621214254383%;"></div></div>
<a class="cell-link" href="/2019/04/16/sprint-galaxy-s10-reception-issues-may-have-a-fix-while-galaxy-s8-problems-surface/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fsprint-samsung-galaxy.jpg&w=60&h=60">
<div class="cell-content">
<h4>[Update: S10 updated, still no fix] Sprint Galaxy S10 reception issues may have a fix while Galaxy S8, Note8 problems surface</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 9:00am PDT</time><time class="timeago" datetime="2019-04-16T09:00:20-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/16/dont-panic-emails-about-samsung-email-accessing-your-gmail-are-legit-samsung-is-working-on-a-fix/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-60" style="width:63.819998926631%;"></div></div>
<a class="cell-link" href="/2019/04/16/dont-panic-emails-about-samsung-email-accessing-your-gmail-are-legit-samsung-is-working-on-a-fix/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fsamsung-email-google-alert-hero.png&w=60&h=60">
<div class="cell-content">
<h4>Don't panic: Emails about Samsung Email accessing your Gmail are legit, Samsung is working on a fix</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 4:54pm PDT</time><time class="timeago" datetime="2019-04-16T16:54:31-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/16/play-store-tests-simultaneous-downloads-internal-app-sharing-more/#comments">44</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-60" style="width:56.498908159411%;"></div></div>
<a class="cell-link" href="/2019/04/16/play-store-tests-simultaneous-downloads-internal-app-sharing-more/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fplay-store-simultaneous-downloads-3.png&w=60&h=60">
<div class="cell-content">
<h4>Play Store tests simultaneous downloads, internal app sharing, more</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 8:00am PDT</time><time class="timeago" datetime="2019-04-16T08:00:25-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/16/hp-2-in-1-chromebook-x14-400-best-buy/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:46.639134141517%;"></div></div>
<a class="cell-link" href="/2019/04/16/hp-2-in-1-chromebook-x14-400-best-buy/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2F6301869cv1d.png&w=60&h=60">
<div class="cell-content">
<h4>HP 2-in-1 Chromebook x360 is $400 ($200 off) at Best Buy</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 11:56am PDT</time><time class="timeago" datetime="2019-04-16T11:56:52-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/16/new-oneplus-7-renders-reveal-version-with-waterdrop-notch-and-no-pop-up-camera/#comments">51</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:44.451741228634%;"></div></div>
<a class="cell-link" href="/2019/04/16/new-oneplus-7-renders-reveal-version-with-waterdrop-notch-and-no-pop-up-camera/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2FOnePlus-7-CAD-1.jpg&w=60&h=60">
<div class="cell-content">
<h4>New OnePlus 7 renders reveal version with waterdrop notch and no pop-up camera</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/16 6:20am PDT</time><time class="timeago" datetime="2019-04-16T06:20:23-07:00">Apr 16, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
</div>
<div class="one-third column">
<li id="appopularposts-6" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 7 Days</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/11/samsung-is-screwing-up-many-galaxy-s10-trade-ins-leaving-customers-frustrated/#comments">132</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998480868326%;"></div></div>
<a class="cell-link" href="/2019/04/11/samsung-is-screwing-up-many-galaxy-s10-trade-ins-leaving-customers-frustrated/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2FGalaxy-S10-Plus-on-a-pile-of-other-phones.jpg&w=60&h=60">
<div class="cell-content">
<h4>Samsung is screwing up many Galaxy S10 trade-ins, leaving customers frustrated</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/11 3:54pm PDT</time><time class="timeago" datetime="2019-04-11T15:54:01-07:00">Apr 11, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/15/update-facebook-confirms-how-to-manually-enable-facebook-messenger-dark-mode/#comments">115</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.983830743141%;"></div></div>
<a class="cell-link" href="/2019/04/15/update-facebook-confirms-how-to-manually-enable-facebook-messenger-dark-mode/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F03%2FMessengerDarkMode_Hero_.png&w=60&h=60">
<div class="cell-content">
<h4>[Update: Dark mode goes global, no mooning necessary] How to manually enable Facebook Messenger dark mode</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/15 11:52am PDT</time><time class="timeago" datetime="2019-04-15T11:52:34-07:00">Apr 15, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/13/the-5-best-and-worst-things-about-the-samsung-galaxy-s10/#comments">112</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.967640398714%;"></div></div>
 <a class="cell-link" href="/2019/04/13/the-5-best-and-worst-things-about-the-samsung-galaxy-s10/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F03%2FDSC01386.jpg&w=60&h=60">
<div class="cell-content">
<h4>The 5 best and worst things about the Samsung Galaxy S10</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/13 9:14am PDT</time><time class="timeago" datetime="2019-04-13T09:14:10-07:00">Apr 13, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/11/how-to-disable-androids-annoying-direct-share-pop-up-on-the-share-menu-samsung-lg-and-google/#comments">89</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.942399426261%;"></div></div>
<a class="cell-link" href="/2019/04/11/how-to-disable-androids-annoying-direct-share-pop-up-on-the-share-menu-samsung-lg-and-google/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fnexus2cee_allo-direct-share.png&w=60&h=60">
<div class="cell-content">
<h4>How to disable Android's annoying "direct share" pop-up on the share menu (Samsung, LG, and Google)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/11 12:27pm PDT</time><time class="timeago" datetime="2019-04-11T12:27:45-07:00">Apr 11, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/11/silence-your-phone-via-google-home-with-new-assistant-command/#comments">50</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.938250525071%;"></div></div>
<a class="cell-link" href="/2019/04/11/silence-your-phone-via-google-home-with-new-assistant-command/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F03%2Fnexus2cee_Android-P-Do-Not-Disturb-Icon-Toggle-Hero.jpg&w=60&h=60">
<div class="cell-content">
<h4>Silence your phone via Google Home with new Assistant command</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/11 4:47am PDT</time><time class="timeago" datetime="2019-04-11T04:47:58-07:00">Apr 11, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
</div>
<div class="one-third column omega">
<li id="appopularposts-9" class="widget-odd widget-last widget-first widget-1 red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 30 Days</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/03/27/inbox-is-about-to-die-and-google-still-hasnt-brought-its-best-feature-to-gmail/#comments">277</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999563615161%;"></div></div>
<a class="cell-link" href="/2019/03/27/inbox-is-about-to-die-and-google-still-hasnt-brought-its-best-feature-to-gmail/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F03%2FInbox-Gmail-gif-Google-hero.gif&w=60&h=60">
<div class="cell-content">
<h4>Inbox is about to die, and Google still hasn't brought its best feature to Gmail</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/03/27 12:00pm PDT</time><time class="timeago" datetime="2019-03-27T12:00:08-07:00">Mar 27, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/04/google-messages-v4-2-now-supports-attachments-of-any-type-adds-verified-sms-details-apk-teardown/#comments">75</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.99924084713%;"></div></div>
<a class="cell-link" href="/2019/04/04/google-messages-v4-2-now-supports-attachments-of-any-type-adds-verified-sms-details-apk-teardown/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2Fmsg.png&w=60&h=60">
<div class="cell-content">
<h4>Google Messages v4.2 now supports attachments of any type, adds Verified SMS details [APK Teardown]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/04 1:24pm PDT</time><time class="timeago" datetime="2019-04-04T13:24:00-07:00">Apr 4, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/04/11/samsung-is-screwing-up-many-galaxy-s10-trade-ins-leaving-customers-frustrated/#comments">132</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.998480868326%;"></div></div>
<a class="cell-link" href="/2019/04/11/samsung-is-screwing-up-many-galaxy-s10-trade-ins-leaving-customers-frustrated/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F04%2FGalaxy-S10-Plus-on-a-pile-of-other-phones.jpg&w=60&h=60">
<div class="cell-content">
<h4>Samsung is screwing up many Galaxy S10 trade-ins, leaving customers frustrated</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/04/11 3:54pm PDT</time><time class="timeago" datetime="2019-04-11T15:54:01-07:00">Apr 11, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/03/25/long-awaited-robust-call-blocking-features-may-soon-come-to-google-phone-app/#comments">127</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.997026581701%;"></div></div>
<a class="cell-link" href="/2019/03/25/long-awaited-robust-call-blocking-features-may-soon-come-to-google-phone-app/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2019%2F03%2Fgoogle-phone-beta-v30-call-blocking-hero-alt.jpg&w=60&h=60">
<div class="cell-content">
<h4>Long-awaited robust call blocking features may soon come to Google Phone app</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/03/25 2:58pm PDT</time><time class="timeago" datetime="2019-03-25T14:58:34-07:00">Mar 25, 2019</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="/2019/03/19/google-drops-pixel-3-prices-even-further-both-models-now-200-off/#comments">379</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.994557909435%;"></div></div>
<a class="cell-link" href="/2019/03/19/google-drops-pixel-3-prices-even-further-both-models-now-200-off/">
<img class="cell-thumb" src="/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2018%2F11%2Fpixel-3-6.jpg&w=60&h=60">
<div class="cell-content">
<h4>[Update x2: Also on Fi] Google drops Pixel 3 prices even further, both models now $200 off</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2019/03/19 12:03pm PDT</time><time class="timeago" datetime="2019-03-19T12:03:40-07:00">Mar 19, 2019</time></div></div>
</div>
</a>
</li></ul></section></li>
</div>
</div>
<div class="sixteen columns">
</div>
<div class="sixteen columns ">
<div class="footer-notes">
<div id='footer_signature'>
Notice a bug? <a target="_blank" href="https://github.com/android-police/androidpolice-public/issues">Let us know here.</a><br />
Link monetization by <a target="_blank" href="http://skimlinks.com">Skimlinks</a>
<span class="footer-break">
<a href="https://www.androidpolice.com/androidpolice-com-privacy-policy/">Privacy Policy</a>
| <a href="https://www.androidpolice.com/dmca-copyright-infringement-notification/">DMCA Disclaimer</a>
| <a href="https://www.androidpolice.com/about/">About</a>
| <a href="https://www.androidpolice.com/advertise/">Advertise</a>
| <a href="https://www.androidpolice.com/contact/">Contact</a><br /></span>
<a title="Original page cache stats:&#013;175 queries | 0.407s | citadel&#013;This request stats:&#013;28 queries | 0.145s | citadel">
175 queries | 0.407s | citadel </a>
<span class="footer-break">
Android is a trademark of Google Inc. | &copy; Illogical Robot LLC, 2009-2019 </span>
</div>
</div>
</div>
</div>
</div>

<script>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</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/ap-hotness/assets/js/aph-pvc.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"androidpolice"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"558076 https:\/\/www.androidpolice.com\/?p=558076","disqusShortname":"androidpolice","disqusTitle":"AMP pages will now show original URL in Chrome's address bar, fundamentally changing how the web works","disqusUrl":"http:\/\/androidpolice.com\/2019\/04\/16\/amp-pages-will-now-show-original-url-in-chromes-address-bar-fundamentally-changing-how-the-web-works\/","postId":"558076"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201916'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/quantcast-choice/public/js/script.min.js?ver=1.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var qc_choice_init = "{\"Publisher Purpose IDs\":[1,2,3,4,5],\"No Option\":false,\"Display UI\":\"inEU\",\"Min Days Between UI Displays\":90,\"Non-Consent Display Frequency\":90,\"Publisher Name\":\"Illogical Robot LLC\",\"Publisher Logo\":\"https:\\\/\\\/www.androidpolice.com\\\/wp-content\\\/themes\\\/ap2\\\/images\\\/android-police-logo-599.png\",\"Initial Screen Title Text\":\"We value your privacy\",\"Initial Screen Body Text\":\"The quality content and information we provide to you depends on the revenue we generate from advertising. We and our partners use your personal data in order to serve personalised advertising, measure activity on the site and deliver personalised features and content to you. Click below to consent to the use of your data. You can revisit your choices at any time.\",\"Initial Screen Reject Button Text\":\"I do not accept\",\"Initial Screen Accept Button Text\":\"I accept\",\"Initial Screen Purpose Link Text\":\"Show Purposes\",\"Purpose Screen Header Title Text\":\"Privacy Settings\",\"Purpose Screen Title Text\":\"We value your privacy\",\"Purpose Screen Body Text\":\"You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.\",\"Purpose Screen Enable All Button Text\":\"Enable all purposes\",\"Purpose Screen Vendor Link Text\":\"See full vendor list\",\"Purpose Screen Cancel Button Text\":\"Cancel\",\"Purpose Screen Save and Exit Button Text\":\"Save & Exit\",\"Vendor Screen Title Text\":\"We value your privacy\",\"Vendor Screen Body Text\":\"You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.\",\"Vendor Screen Reject All Button Text\":\"Reject All\",\"Vendor Screen Accept All Button Text\":\"Accept all\",\"Vendor Screen Purposes Link Text\":\"Back to purposes\",\"Vendor Screen Cancel Button Text\":\"Cancel\",\"Vendor Screen Save and Exit Button Text\":\"Save & Exit\",\"Language\":\"EN\",\"Initial Screen Body Text Option\":1,\"UI Layout\":\"banner\",\"Custom Links Displayed on Initial Screen\":[\"[Find out more by reading our privacy and cookie policies](https:\\\/\\\/www.androidpolice.com\\\/androidpolice-com-privacy-policy\\\/)\",\"[How Google uses information from sites](https:\\\/\\\/policies.google.com\\\/technologies\\\/partner-sites)\"]}";
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/quantcast-choice/public/js/script.async.min.js?ver=1.2.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tocplus = {"smooth_scroll":"1","smooth_scroll_offset":"10"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=1509'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.androidpolice.com\/wordpress\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.easing.1.4.1.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/socialite.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/nivo-lightbox.js?ver=1522743797'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jRespond.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/mousetrap/mousetrap.min.js?ver=1.4.6'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.timeago.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.flexslider.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/androidpolice.js?ver=1548695700'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/jquery.countTo.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/ap.single.js?ver=1496874322'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wp-content/themes/ap2/js/waypoints-combined.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.androidpolice.com/wordpress/wp-includes/js/wp-embed.min.js?ver=5.1.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201916.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'12245754',post:'558076',tz:'-7',srv:'www.androidpolice.com'} ]);
	_stq.push([ 'clickTrackerInit', '12245754', '558076' ]);
</script>
<script type="text/javascript">
	var templateDir = "https://www.androidpolice.com/wp-content/themes/ap2";
  var ajaxurl = "https://www.androidpolice.com/wordpress/wp-admin/admin-ajax.php";
  var blogurl = "https://www.androidpolice.com";
</script>

<script src="//instant.page/1.2.2" type="module" integrity="sha384-2xV8M5griQmzyiY3CDqh1dn4z3llDVqZDqzjzcY+jCBCk/a5fXJmuZ/40JJAPeoU"></script>


<script type="text/javascript">(function(){var a=document.createElement('script');a.type='text/javascript';a.async=true;a.src='https://widget.pushbullet.com/dynamic.js';var b=document.getElementsByTagName('script')[0];b.parentNode.insertBefore(a,b);})();</script>

<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
<script type="text/javascript" src="https://www.androidpolice.com/wp-content/themes/ap2/js/tablepress.search-fix.js"></script>

<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=651&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>


<script type="text/javascript" src="//ado.pro-market.net/ads/scripts/site-130167.js"></script>


<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-95hmrIiT9zWMo"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-95hmrIiT9zWMo.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>


<img src="https://sb.scorecardresearch.com/p?c1=2&c2=15235859&cv=2.0&cj=1" />

<script src="https://apis.google.com/js/platform.js" async defer></script>

<script type="text/javascript" src="//s.skimresources.com/js/85009X1537243.skimlinks.js"></script>

</body>
</html>
