Most owners of OG Pixels can attest that Bluetooth on those devices is not the best. We've written a fair few articles about the various issues over the past year, but with the launch of the new Pixels we were hopeful that Google might have improved things somewhat. While Bluetooth performance so far does seem to be more consistent, we've just learned about one particularly annoying bug that Pixel 2 owners have uncovered.

According to the many posters on this Pixel User Community thread, when you connect Bluetooth headphones to a Pixel 2 or 2 XL and activate the Google Assistant, it makes a sound to indicate that it's listening but doesn't detect your voice. Users have tested and confirmed the issue with several different headphone brands and models that have the power to summon the Assistant with a button-press, including those from Plantronics, Anker, Beats, and LG. The problem seems to be ubiquitous, regardless of the audio hardware.

I've tested this out myself and found the same behavior. I could replicate the issue with both the Libratone Q Adapt On-ear headphones and the Jabra Elite Sport earbuds when paired with my Pixel 2 XL (8.0). I ran the same tests connecting both to my OG Pixel XL (8.1), and everything worked as it should. I don't have the smaller Pixel 2 to try out, but it would appear from the forum that it suffers from the same bug. Others have stated that updating to the 8.1 developer preview does not solve the issue.

This would be a catastrophic issue for Google's Pixel Buds.

The initial forum post is from a Community Manager, so we know Google is aware of the bug and is investigating. There's been no further comment regarding a fix yet. I've not yet received the Pixel Buds to test those out, but Google would really not want this to affect them given that Assistant synergy is kind of their raison d'être.

I must admit that I'm surprised by the size of the response to this. I didn't realize quite so many people used the assistant via headphones. I need to try that out some more, although I'll have to do it with my OG Pixel for the time being. If any of you are experiencing this problem, do let us know in the comments. We'll update you if we hear anything more about it.

  • Thanks:
  • James and Joanna