<!DOCTYPE html>
<!--[if lt IE 7 ]><html class="ie ie6" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7 ]><html class="ie ie7" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8 ]><html class="ie ie8" lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" itemscope itemtype="http://schema.org/Article"> <!--<![endif]-->
<head>
 
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<link rel="pingback" href="http://www.androidpolice.com/wordpress/xmlrpc.php"/>
<meta property="og:site_name" content="Android Police"/>
<meta name="theme-color" content="#0041C8">
<link rel="publisher" href="https://plus.google.com/103876278794381402383"/>
 
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=3">
 
<link href='//fonts.googleapis.com/css?family=Oswald|Roboto:700,500,400|Roboto+Slab' rel='stylesheet' type='text/css'>
<!--[if lt IE 9]>
		<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
   <![endif]-->
 
<link rel="shortcut icon" type="image/gif" href="http://www.androidpolice.com/wp-content/themes/ap2/images/favicon.gif">
<link rel="apple-touch-icon" href="http://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon.png">
<link rel="apple-touch-icon" sizes="72x72" href="http://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="114x114" href="http://www.androidpolice.com/wp-content/themes/ap2/images/apple-touch-icon-114x114.png">
<script src="//tags-cdn.deployads.com/a/androidpolice.com.js" async></script>
<script>
  var ap_naag_timeset = parseFloat(localStorage['naag-timeset']),
                  ap_naag_expiry  = ap_naag_timeset + 600000,
                  ap_naag_article_count = parseFloat(localStorage['naag-article-count']),
                  naag_d = new Date(),
                  naag_time = naag_d.getTime();

              console.log('APDEBUG ARTICLE COUNT: ' + ap_naag_article_count );</script>
 
<script>
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

    ga('create', 'UA-6275685-2', 'auto');
    ga('require', 'linkid', 'linkid.js');
    ga('send', 'pageview');

  </script>
<script type="text/javascript">var postid = 421365;</script><script type="text/javascript">var aphDir = "http://www.androidpolice.com/wp-content/plugins/ap-hotness"</script>
 
<title>Google is looking into longstanding issues with Smart Lock&#039;s Trusted Places feature</title>
<meta name="description" content="This particular issue seems to have been plaguing users for quite a while now. Trusted Places, a method of unlocking your Android device more easily in cer... by Ryne Hager in Bug Watch, Google, News"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/"/>
<link rel="publisher" href="https://plus.google.com/+AndroidPolice"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Google is looking into longstanding issues with Smart Lock&#039;s Trusted Places feature"/>
<meta property="og:description" content="This particular issue seems to have been plaguing users for quite a while now. Trusted Places, a method of unlocking your Android device more easily in cer... by Ryne Hager in Bug Watch, Google, News"/>
<meta property="og:url" content="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/"/>
<meta property="og:site_name" content="Android Police - Android News, Apps, Games, Phones, Tablets"/>
<meta property="article:publisher" content="https://www.facebook.com/AndroidPolice"/>
<meta property="article:tag" content="bug"/>
<meta property="article:tag" content="Google"/>
<meta property="article:tag" content="not working"/>
<meta property="article:tag" content="trusted places"/>
<meta property="article:section" content="Bug Watch"/>
<meta property="article:published_time" content="2017-04-27T09:06:23-07:00"/>
<meta property="fb:admins" content="3207613"/>
<meta property="og:image" content="https://www.androidpolice.com/wp-content/uploads/2017/04/nexus2cee_original_images-Android_thumb.png"/>
<meta property="og:image" content="https://www.androidpolice.com/wp-content/uploads/2017/04/nexus2cee_2017-04-27_12-03-33_thumb.png"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="This particular issue seems to have been plaguing users for quite a while now. Trusted Places, a method of unlocking your Android device more easily in cer... by Ryne Hager in Bug Watch, Google, News"/>
<meta name="twitter:title" content="Google is looking into longstanding issues with Smart Lock&#039;s Trusted Places feature"/>
<meta name="twitter:site" content="@AndroidPolice"/>
<meta name="twitter:image" content="https://www.androidpolice.com/wp-content/uploads/2017/04/nexus2cee_original_images-Android_thumb.png"/>
<meta name="twitter:creator" content="@rynehager"/>
 
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="Android Police - Android News, Apps, Games, Phones, Tablets &raquo; Feed" href="http://www.androidpolice.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Android Police - Android News, Apps, Games, Phones, Tablets &raquo; Comments Feed" href="http://www.androidpolice.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="Android Police - Android News, Apps, Games, Phones, Tablets &raquo; Google is looking into longstanding issues with Smart Lock&#039;s Trusted Places feature Comments Feed" href="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.androidpolice.com\/wordpress\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var e,f,g,h,i=b.createElement("canvas"),j=i.getContext&&i.getContext("2d");for(h=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},g=0;g<h.length;g++)c.supports[h[g]]=function(a){var b,c,d,e,f=String.fromCharCode;if(!j||!j.fillText)return!1;switch(j.clearRect(0,0,i.width,i.height),j.textBaseline="top",j.font="600 32px Arial",a){case"flag":return j.fillText(f(55356,56826,55356,56819),0,0),i.toDataURL().length<3e3?!1:(j.clearRect(0,0,i.width,i.height),j.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=i.toDataURL(),j.clearRect(0,0,i.width,i.height),j.fillText(f(55356,57331,55356,57096),0,0),c=i.toDataURL(),b!==c);case"emoji4":return j.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=i.toDataURL(),j.clearRect(0,0,i.width,i.height),j.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=i.toDataURL(),d!==e}return!1}(h[g]),c.supports.everything=c.supports.everything&&c.supports[h[g]],"flag"!==h[g]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[h[g]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(f=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",f,!1),a.addEventListener("load",f,!1)):(a.attachEvent("onload",f),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),e=c.source||{},e.concatemoji?d(e.concatemoji):e.wpemoji&&e.twemoji&&(d(e.twemoji),d(e.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='wpappbox-css' href='http://www.androidpolice.com/wp-content/plugins/wp-appbox/css/styles.min.css?ver=4.0.10' type='text/css' media='screen'/>
<link rel='stylesheet' id='wp-polls-css' href='http://www.androidpolice.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.73.2' type='text/css' media='all'/>
<style id='wp-polls-inline-css' type='text/css'>.wp-polls .pollbar{margin:1px;font-size:6px;line-height:8px;height:8px;background-image:url('http://www.androidpolice.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');border:1px solid #c8c8c8;}</style>
<link rel='stylesheet' id='layout-css' href='http://www.androidpolice.com/wp-content/themes/ap2/stylesheets/layout.css?ver=1492623672' type='text/css' media='all'/>
<link rel='stylesheet' id='tablepress-default-css' href='http://www.androidpolice.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.8' type='text/css' media='all'/>
<link rel='stylesheet' id='jetpack_css-css' href='http://www.androidpolice.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.8.2' type='text/css' media='all'/>
<script type='text/javascript' src='http://www.androidpolice.com/wordpress/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wordpress/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/androidpolice.js?ver=1492990875'></script>
<link rel='https://api.w.org/' href='http://www.androidpolice.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.androidpolice.com/wordpress/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.androidpolice.com/wordpress/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.7.4"/>
<link rel='shortlink' href='http://www.androidpolice.com/?p=421365'/>
<link rel="alternate" type="application/json+oembed" href="http://www.androidpolice.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.androidpolice.com%2F2017%2F04%2F27%2Fgoogle-looking-longstanding-issues-smart-locks-trusted-places-feature%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.androidpolice.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.androidpolice.com%2F2017%2F04%2F27%2Fgoogle-looking-longstanding-issues-smart-locks-trusted-places-feature%2F&#038;format=xml"/>
<style type='text/css'>img#wpstats{display:none}</style>
 
<script type="text/javascript">
      (function() {
          function async_load(script_url){
              var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
              var s = document.createElement('script'); s.src = protocol + script_url;
              var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
          }
          bm_website_code = 'ADCF24FB71BE47D4';
          jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
          jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
      })();
  </script>
 
</head>
<body class="post-template-default single single-post postid-421365 single-format-image">
 
<div id="tip-us">
<div id="tip-us-container" class="container">
<div class="sixteen columns">
<div class="tip-us-wrapper">
<div class="tip-us-header">
<a href="#" class="btn-close" title="Close"><i class="icon-exit"></i></a>
<h2 class="modal-heading">Tip Us</h2>
</div>
<div class="tip-us-body">
<div class="ap-loader"></div>
</div>
</div>
</div>
</div>
</div>
<div class="band header hidden-phone">
<div class="container">
<div class="sixteen columns">
<a href="http://www.androidpolice.com"><h1 class="logo">Android Police</h1></a>
<div id="header-ad-wrapper">
<div id="ap2_header_1" class="adslot" data-mapping="header" data-dfp="ap2_header_1" data-cids="7956726685" data-sizes="0,0,0,728,728,728"></div>
<script>(deployads = window.deployads || []).push({});</script> </div>
</div>
</div>
</div> 
<div class="band nav">
<div class="ap-nav-wrapper">
<div class="container">
<ul class="mobile-nav list-unstyled">
<li class="depth-priority">
<a id="ap-menu-button" href="#" class="menu">
<span class="ap-bar"></span>
<span class="ap-bar"></span>
<span class="ap-bar"></span>
</a>
<a class="search-box-close visible-handheld hidden">
<i class="icon-backarrow"></i>
</a>
</li>
<li>
<a href="http://www.androidpolice.com" id="ap-logo-small">
<i class="icon-ap"></i>
</a>
</li>
<li>
<a id="search-btn-a" class="search-btn depth-priority" onclick="firstIconClick(event)"><i class="icon-search"></i></a>
<div class="search-box" id="search-box">
<form role="search" method="get" id="searchform" action="http://www.androidpolice.com/" autocomplete="off">
<input class="textfield" type="search" name="s" id="s" placeholder="Search" value="" autocomplete="off"/>
<div class="cat-select">
<ul class="cat-ul list-unstyled">
</ul>
</div>
</form>
</div>
</li>
<li class="ap-new-articles">
<a class="ap-new-articles-btn ap-btn-red" href="#">
<span id="ap-new-articles-num" class="ap-new-articles-num"></span>
<script>
              apNewArticlesNum = document.getElementById("ap-new-articles-num");
              console.log('APDEBUG EL: ' + apNewArticlesNum);
              console.log('APDEBUG ARTICLE COUNT: naag_time = ' + naag_time + ', ap_naag_expiry = ' + ap_naag_expiry);
              if ( !isNaN(ap_naag_article_count) && naag_time < ap_naag_expiry ) {
                apNewArticlesNum.innerHTML = ap_naag_article_count;
                console.log('APDEBUG ARTICLE COUNT: updating content with ' + ap_naag_article_count);
              }
              else {
                console.log('APDEBUG ARTICLE COUNT: DID NOT UPDATE');
              }
            </script>
<span class="ap-new-articles-lable">New<br>Articles</span>
<i class="icon-sort-down"></i>
</a>
</li>
</ul>
<ul id="menu-primary-nav" class="primary-nav ap-panel" role="navigation">
<li id="nav-menu-item-294419" rel="news"><a class='ap-nav-primary' href="http://www.androidpolice.com/topics/news/">News<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294419'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294423" rel="news"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/news/">Latest news</a></li>
<li id="nav-menu-item-414169" rel="android-o"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/android-os/android-o/">Android O</a></li>
<li id="nav-menu-item-367349" rel="nougat-70"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/android-os/nougat-70/">Nougat 7.0/7.1</a></li>
<li id="nav-menu-item-294428" rel="android-os"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/android-os/">Android OS</a></li>
<li id="nav-menu-item-294429" rel="wearables"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/wearables/">Wearables</a></li>
<li id="nav-menu-item-294598" rel="android-tv-android-os"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/android-os/android-tv-android-os/">Android TV</a></li>
<li id="nav-menu-item-294597" rel="android-auto"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/android-os/android-auto/">Android Auto</a></li>
<li id="nav-menu-item-294426" rel="dev-development"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/dev-development/">Development</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='http://www.androidpolice.com/topics/news/'>More News...</a></div></div>
</li>
<li id="nav-menu-item-294420" rel="applications-games"><a class='ap-nav-primary' href="http://www.androidpolice.com/topics/applications-games/">Apps/Games<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294420'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294425" rel="games"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/applications-games/games/">Games</a></li>
<li id="nav-menu-item-294424" rel="applications"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/applications-games/applications/">Applications</a></li>
<li id="nav-menu-item-294430" rel="roundups"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/roundups/">Roundups</a></li>
<li id="nav-menu-item-294431" rel="app-reviews"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/reviews/app-reviews/">App Reviews</a></li>
<li id="nav-menu-item-294432" rel="game-reviews"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/reviews/game-reviews/">Game Reviews</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='http://www.androidpolice.com/topics/applications-games/'>More Apps/Games...</a></div></div>
</li>
<li id="nav-menu-item-294421" rel="reviews"><a class='ap-nav-primary' href="http://www.androidpolice.com/topics/reviews/">Reviews<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294421'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-294435" rel="reviews"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/reviews/">All reviews</a></li>
<li id="nav-menu-item-294434" rel="phone-reviews"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/reviews/phone-reviews/">Phone Reviews</a></li>
<li id="nav-menu-item-294436" rel="tablet-reviews"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/reviews/tablet-reviews/">Tablet Reviews</a></li>
<li id="nav-menu-item-294437" rel="wearable-reviews"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/reviews/wearable-reviews/">Wearable Reviews</a></li>
<li id="nav-menu-item-294433" rel="other-reviews"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/reviews/other-reviews/">Other Reviews</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='http://www.androidpolice.com/topics/reviews/'>More Reviews...</a></div></div>
</li>
<li id="nav-menu-item-294422" rel="phones-devices"><a class='ap-nav-primary' href="http://www.androidpolice.com/topics/phones-devices/">Devices<i class="icon-caret-right"></i></a>
<div class='drop-down light' data-parent-id='nav-menu-item-294422'><div class='container'><ul class='sub-cat list-unstyled'>
<li id="nav-menu-item-297470" rel="nexus-google-phones-devices"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/phones-devices/google-phones-devices/nexus-google-phones-devices/">Nexus Devices</a></li>
<li id="nav-menu-item-294438" rel="samsung"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/phones-devices/samsung/">Samsung</a></li>
<li id="nav-menu-item-294439" rel="htc"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/phones-devices/htc/">HTC</a></li>
<li id="nav-menu-item-294440" rel="motorola"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/phones-devices/motorola/">Motorola</a></li>
<li id="nav-menu-item-294441" rel="sony"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/phones-devices/sony/">Sony</a></li>
<li id="nav-menu-item-294594" rel="lg"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/phones-devices/lg/">LG</a></li>
<li id="nav-menu-item-294442" rel="nvidia-phones-devices"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/phones-devices/nvidia-phones-devices/">NVIDIA</a></li>
<li id="nav-menu-item-294595" rel="huawei"><a class='ap-nav-sub' href="http://www.androidpolice.com/topics/phones-devices/huawei/">Huawei</a></li>
</ul><div id='article-list'></div><a class='more-btn' href='http://www.androidpolice.com/topics/phones-devices/'>More Devices...</a></div></div>
</li>
<li id="menu-item-294411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294411"><a href="http://www.androidpolice.com/topics/news/leak/">Leaks</a></li>
<li id="menu-item-294412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294412"><a href="http://www.androidpolice.com/topics/news/exclusive/">Exclusives</a></li>
<li id="menu-item-294413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294413"><a href="http://www.androidpolice.com/topics/downloads/">Downloads</a></li>
<li id="menu-item-294414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294414"><a href="http://www.androidpolice.com/topics/deals/">Deals</a></li>
<li id="menu-item-294415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294415"><a href="http://www.androidpolice.com/topics/contests/">Giveaways</a></li>
<li id="menu-item-294416" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-294416"><a href="http://www.androidpolice.com/topics/features/">Features</a></li>
<li id="menu-item-294417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294417"><a href="http://www.androidpolice.com/topics/editorials/">Editorials</a></li>
<li id="menu-item-294418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294418"><a href="http://www.androidpolice.com/topics/podcast/">Podcast</a></li>
<li><a class="tip-us" href="http://www.androidpolice.com/contact">Tip Us</a></li> </ul>
</div>
<div class="ap-panel ap-panel-news">
<div class="container">
<div id="news-slider"></div>
<div class="fs-navigation">
<a href="" class="fs-control fs-control-prev"><i class='icon-caret-left'></i> Prev</a>
<div class="fs-control fs-control-filters disabled">
<span>Posts in the last </span>
<div class="ap-dropdown ap-filter-time">
<a class="ap-dropdown-trigger active" href=""><span>24 Hours</span><i class="icon-sort-down"></i></a>
<ul class="list-unstyled ap-dropdown-content ap-dropdown-content-bottom depth3">
<li><a class="active" href="" data-function="ap_news_updater" data-time="24">24 Hours</a></li>
<li><a href="" data-function="ap_news_updater" data-time="48">48 Hours</a></li>
<li><a href="" data-function="ap_news_updater" data-time="72">72 Hours</a></li>
</ul>
</div>
<span>sorted by </span>
<div class="ap-dropdown ap-filter-criteria">
<a class="ap-dropdown-trigger active" href="#"><span>Hottest</span><i class="icon-sort-down"></i></a>
<ul class="list-unstyled ap-dropdown-content ap-dropdown-content-bottom depth3">
<li><a class="active" href="" data-function="ap_news_updater" data-criteria="hottest">Hottest</a></li>
<li><a href="" data-function="ap_news_updater" data-criteria="latest">Latest</a></li>
<li><a href="" data-function="ap_news_updater" data-criteria="comments">Comments</a></li>
</ul>
</div>
</div>
<a href="" class="fs-control fs-control-next">Next <i class='icon-caret-right'></i></a>
</div> 
</div>
</div>
</div>
 
</div> 
<div class="band sub-nav main">
<div class="container">
<div class="sixteen columns">
<nav>
<ul id="menu-quick-menu-1" class="sub-nav"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294411"><a href="http://www.androidpolice.com/topics/news/leak/">Leaks</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294412"><a href="http://www.androidpolice.com/topics/news/exclusive/">Exclusives</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294413"><a href="http://www.androidpolice.com/topics/downloads/">Downloads</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294414"><a href="http://www.androidpolice.com/topics/deals/">Deals</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294415"><a href="http://www.androidpolice.com/topics/contests/">Giveaways</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-294416"><a href="http://www.androidpolice.com/topics/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294417"><a href="http://www.androidpolice.com/topics/editorials/">Editorials</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-294418"><a href="http://www.androidpolice.com/topics/podcast/">Podcast</a></li>
<li class="fl-right"><a class="tip-us ap-btn-red" href="http://www.androidpolice.com/contact" data-lightbox-type="ajax">Tip Us</a></li></ul>
</nav>
</div>
</div>
</div> 
<div class="band content main single">
<div class="container" id="ap-body">
<div id="ap-mobile-1" class="lv-wrapper lv-wrapper-above-post visible-phone">
<div id="ap2_header_2" class="adslot" data-mapping="smallWide" data-dfp="ap2_header_2" data-sizes="300,336,468,0,0,0"></div>
<script>(deployads = window.deployads || []).push({});</script> </div>
<div class="primary column">
<div class="large-post single post-421365 post type-post status-publish format-image hentry category-bug-watch-features category-google-phones-devices category-news tag-bug tag-google tag-not-working tag-trusted-places post_format-post-format-image" id="post-421365">
<header class="post-header">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/#disqus_thread">...</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:49.595556534966%;"></div>
</div>
<h2 itemprop="name"><a href="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/">Google is looking into longstanding issues with Smart Lock's Trusted Places feature</a></h2><div class="post-meta">
<a class="author-pic hidden-phone" href="http://www.androidpolice.com/author/ryne-hager/"><img src="https://lh5.googleusercontent.com/-b0J8xyd8Sfs/AAAAAAAAAAI/AAAAAAAAmbU/pXiCTDHq3gY/photo.jpg?sz=50"/></a>
<span class="post-author"><a class="author-name" href="http://www.androidpolice.com/author/ryne-hager/ ">Ryne Hager</a></span><div class="card card-small card-popup card-author depth3">
<div class="card-inner">
</div>
<div class="card-action"><div class="fl-left"><div class="g-follow" data-annotation="none" data-height="20" data-href="https://plus.google.com/+RyneHager" data-rel="author"></div></div><a href="https://twitter.com/rynehager" class="twitter-follow-button fl-left" data-show-count="false" data-size="medium" data-show-screen-name="false">Follow</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script><a href="http://www.androidpolice.com/author/ryne-hager/" class="card-action-btn fl-right">View All Posts</a>
</div>
</div><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/27 9:06am PDT</time><time class="timeago" datetime="2017-04-27T09:06:23-07:00">Apr 27, 2017</time></div> </div><div class="share-box">
<ul class="share-btns list-unstyled">
<li>
<a class="share-btn-gplus"><i class="icon-google-plus"></i><span>15</span></a>
<div class="share-btn gplus-widget">
<a href="https://plus.google.com/share?url=http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/" class="socialite googleplus-one" data-text="Google is looking into longstanding issues with Smart Lock's Trusted Places feature" data-href="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/" data-size="medium" data-align="right" rel="nofollow" target="_blank">
Plus 1 on G+
</a>
</div>
</li>
<li>
<a><i class="icon-facebook"></i><span>15</span></a>
<div class="share-btn">
<a class="socialite facebook-like" data-layout="button_count" data-show-faces="false" href="http://www.facebook.com/sharer.php?u=http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/&amp;t=Google is looking into longstanding issues with Smart Lock's Trusted Places feature" data-href="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/" target="_blank">
Share on Facebook
</a>
</div>
</li>
<li>
<a><i class="icon-twitter"></i><span>11</span></a>
<div class="share-btn">
<a href="http://twitter.com/share" class="socialite twitter-share" data-text="Google is looking into longstanding issues with Smart Lock's Trusted Places feature" data-url="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/" data-align="right" rel="nofollow" target="_blank">
Share on Twitter
</a>
</div>
</li>
</ul>
<div class="shares">
<span>Total Shares</span><span class="count">41</span>
</div>
</div></header><div class="categories"><ul class="post-categories list-unstyled"><li><a class="cat cat-bug-watch-features" href="http://www.androidpolice.com/topics/features/bug-watch-features/" title="View all posts in Bug Watch"><i class="icon-bug-watch"></i>Bug Watch</a></li><li><a class="cat cat-google-phones-devices" href="http://www.androidpolice.com/topics/phones-devices/google-phones-devices/" title="View all posts in Google">Google</a></li><li><a class="cat cat-news" href="http://www.androidpolice.com/topics/news/" title="View all posts in News"><i class="icon-news"></i>News</a></li></ul></div><a class="post-hero post-hero-single" href="https://www.androidpolice.com/wp-content/uploads/2017/04/nexus2cee_original_images-Android_thumb.png"><img class="img-hero" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_original_images-Android_thumb.png&w=728"></a>
<div class="post-content">
<div id="ap-in-post-1" class="ip-wrapper">
<div id="ap2_in_post_1" class="adslot" data-mapping="allWide320" data-dfp="ap2_in_post_1" data-sizes="320,320,468,320,468,728"></div>
<script>(deployads = window.deployads || []).push({});</script> </div>
<p><a href="https://www.androidpolice.com/wp-content/uploads/2017/04/nexus2cee_original_images-Android.png" class=" no-style"></a></p>
<p>This particular issue seems to have been plaguing users for quite a while now. Trusted Places, a method of unlocking your Android device more easily in certain locations, has been either working intermittently, inaccurately, or not at all for some folks. As of yesterday it looks like Google is reaching out to affected users for bug reports. Hopefully those with the issue can see it fixed soon.</p>
<p><span id="more-421365"></span></p>
<p>I'm not a big fan of Trusted Places, since I can go pretty far from my place in the city and still be close enough that Google considers it secure. Part of that is the lack of location accuracy that comes from having a lot of tall buildings nearby.&nbsp; Another part is the sheer density of the city. I don't have to go much further than a few miles by foot for months at a time, outside of really long-distance travel. For those that do use the service and have experienced the problem, some have reported that they were able to fix it for short periods of time by toggling the security option for Trusted Places, re-adding the home location, disabling other smart lock features, rebooting, or changing the device location method between device only and battery saving.</p>
<p><a href="https://www.androidpolice.com/wp-content/uploads/2017/04/nexus2cee_2017-04-27_12-03-33.png" class=" no-style"><img style="display: inline;" title="2017-04-27_12-03-33" src="https://www.androidpolice.com/wp-content/uploads/2017/04/nexus2cee_2017-04-27_12-03-33_thumb.png" alt="2017-04-27_12-03-33" width="688" height="155"></a></p>
<p>So far the most recent statement to those affected has been a request for additional logs from those running 7.1.2. It might be frustrating that an issue reported six months ago is yet to see a solution, but at least it seems this bug is finally getting some attention. Hopefully it won't be too long until it's fixed.</p>
<div class="clear pre-horizontal-boxes"></div><ul class="list-unstyled list-inline list-emphasis"><li class="title"><strong>Source: </strong></li><li><a href="https://productforums.google.com/forum/#!msg/phone-by-google/KNrSoHOhb_Q/XXGHCpgQAgAJ" class="external" rel="nofollow" target="_blank">Google</a></li></ul>
</div>
<div class="post-footer-meta">
<ul class="horizontal-boxes list-unstyled horizontal-boxes-tags"><li class="title green-border header-bg green-bg">Tags</li><li><a href="http://www.androidpolice.com/tags/bug/" rel="tag">bug</a></li><li><a href="http://www.androidpolice.com/tags/google/" rel="tag">Google</a></li><li><a href="http://www.androidpolice.com/tags/not-working/" rel="tag">not working</a></li><li><a href="http://www.androidpolice.com/tags/trusted-places/" rel="tag">trusted places</a></li></ul>
<a href="#" class="btn btn-small btn-pb btn-subscribe" data-trigger="reveal" data-target="card-pb" data-function="apLoadPushbullet"><i class="icon-pushbullet"></i>subscribe</a>
<div class="clear"></div>
<div id="card-pb" class="card card-popup card-pb depth3">
<div class="card-inner">
</div>
</div>
</div>
<div id="ap-in-post-4" class="ip-wrapper ip-wrapper-bottom">
<div id="ap2_in_post_4" class="adslot" data-mapping="allBoxWideVariant_2" data-dfp="ap2_in_post_2" data-sizes="300,320,468,336,468,728"></div>
<script>(deployads = window.deployads || []).push({});</script> </div>
<div class="OUTBRAIN" data-src="http://www.androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/" data-widget-id="AR_1" data-ob-template="IllogicalRobot"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
</div> 
<div class="post-footer">
<div class="article-nav">
<div class="article-nav-box ">
<a href="http://www.androidpolice.com/2017/04/27/samsung-pay-launches-sweden-uae-enters-early-access-hong-kong-switzerland/#disqus_thread" class="comment-btn">...</a>
<a href="http://www.androidpolice.com/2017/04/27/samsung-pay-launches-sweden-uae-enters-early-access-hong-kong-switzerland/">
<div class="article-nav-box-content">
<h4 class="first-heading"><span>Previous</span> Story</h4>
<div class="article-nav-box-title">
<div class="ellipsize">
<h5>Samsung Pay launches in Sweden and UAE, enters early access in Hong Kong and Switzerland</h5>
</div>
</div>
</div>
<div class="frame">
<div class="frame-image-wrapper">
<img class="centered animate" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F05%2Fnexus2cee_samsung-pay-728x485.jpg&h=129&zc=3" alt="">
</div>
<img class="bg animate" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F05%2Fnexus2cee_samsung-pay-728x485.jpg&w=150&h=85&zc=1&f=8|8|8|8|8|8|8|8|8|8|8|8|8" alt="">
</div>
</a>
</div>
<div class="article-nav-box ">
<a href="http://www.androidpolice.com/2017/04/27/replying-messages-android-auto-broken-hangouts-isnt-installed-google-case/#disqus_thread" class="comment-btn">...</a>
<a href="http://www.androidpolice.com/2017/04/27/replying-messages-android-auto-broken-hangouts-isnt-installed-google-case/">
<div class="article-nav-box-content">
<h4 class="first-heading"><span>Next</span> Story</h4>
<div class="article-nav-box-title">
<div class="ellipsize">
<h5>Replying to messages in Android Auto is broken if Hangouts isn't installed, Google is on the case</h5>
</div>
</div>
</div>
<div class="frame">
<div class="frame-image-wrapper">
<img class="centered animate" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F11%2Fnexus2cee_facebook-android-auto-728x387.png&h=129&zc=3" alt="">
</div>
<img class="bg animate" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F11%2Fnexus2cee_facebook-android-auto-728x387.png&w=150&h=85&zc=1&f=8|8|8|8|8|8|8|8|8|8|8|8|8" alt="">
</div>
</a>
</div>
</div>
<div class="post-footer-inner">
<div class="single-post-widget">
<li id="appopularposts-7" class="widget-1 widget-first widget-last widget-odd red widget ap-popular-posts"><header class="section-header"><h4 class="header-bg">Trending</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/19/apps-services-will-work-google-home-continuously-updated/#comments">259</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999895294459%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/19/apps-services-will-work-google-home-continuously-updated/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F10%2Fnexus2cee_ap_resize-2-728x410.png&w=60&h=60">
<div class="cell-content">
<h4>These are all the apps and services that will work with Google Home [Continuously Updated]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/19 10:15am PDT</time><time class="timeago" datetime="2017-04-19T10:15:41-07:00">Apr 19, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/12/google-photos-v2-13-adds-video-stabilization-hints-at-possible-google-integration-apk-download-teardown/#comments">97</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.99895457024%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/12/google-photos-v2-13-adds-video-stabilization-hints-at-possible-google-integration-apk-download-teardown/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_photos_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>Google Photos v2.13 adds video stabilization, hints at possible Google+ integration [APK Download + Teardown]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/12 4:09am PDT</time><time class="timeago" datetime="2017-04-12T04:09:55-07:00">Apr 12, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/25/google-posts-truly-incredible-night-images-captured-pixel-nexus-6p/#comments">103</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.976134303682%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/25/google-posts-truly-incredible-night-images-captured-pixel-nexus-6p/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_image10-728x546.jpg&w=60&h=60">
<div class="cell-content">
<h4>Google posts truly incredible night images captured by the Pixel and Nexus 6P</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/25 11:28am PDT</time><time class="timeago" datetime="2017-04-25T11:28:11-07:00">Apr 25, 2017</time></div></div>
</div>
</a>
</li></ul></section><div id="ap-mobile-trending" class="pop-ad-wrapper">
<div class="adslot" id="ap2_popular_posts_1" data-mapping="popular" data-dfp="ap2_popular_posts_1" data-sizes="300,336,336,336,300,300"></div>
<script>(deployads = window.deployads || []).push({});</script>
</div></li> </div>
<div id="comments">
<header class="section-header ">
<h4 class="header-bg blue-bg">Comments</h4>
</header>
<a name="comments"></a>
<section>
<div id="disqus_thread">
<div id="dsq-content">
<ul id="dsq-comments">
<li class="comment even thread-even depth-1" id="dsq-comment-1560094">
<div id="dsq-comment-header-1560094" class="dsq-comment-header">
<cite id="dsq-cite-1560094">
<span id="dsq-author-user-1560094">Matthew Rebmann</span>
</cite>
</div>
<div id="dsq-comment-body-1560094" class="dsq-comment-body">
<div id="dsq-comment-message-1560094" class="dsq-comment-message"><p>Thank you baby jesus. I've been waiting ages for them to fix this.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-2" id="dsq-comment-1560096">
<div id="dsq-comment-header-1560096" class="dsq-comment-header">
<cite id="dsq-cite-1560096">
<span id="dsq-author-user-1560096">Mix</span>
</cite>
</div>
<div id="dsq-comment-body-1560096" class="dsq-comment-body">
<div id="dsq-comment-message-1560096" class="dsq-comment-message"><p><b>You are welcome my child.</b><br/>
<a href="http://www.medjugorje.ws/data/olm/images/pictures/jesus-christ-images/little-baby-jesus/little-jesus.jpg" rel="nofollow" class="external" target="_blank">http://www.medjugorje.ws/data/olm/images/pictures/jesus-christ-images/little-baby-jesus/little-jesus.jpg</a></p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-1560128">
<div id="dsq-comment-header-1560128" class="dsq-comment-header">
<cite id="dsq-cite-1560128">
<span id="dsq-author-user-1560128">Suicide_Note</span>
</cite>
</div>
<div id="dsq-comment-body-1560128" class="dsq-comment-body">
<div id="dsq-comment-message-1560128" class="dsq-comment-message"><p>What an ugly baby.</p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1560098">
<div id="dsq-comment-header-1560098" class="dsq-comment-header">
<cite id="dsq-cite-1560098">
<span id="dsq-author-user-1560098">Andrew Palmer</span>
</cite>
</div>
<div id="dsq-comment-body-1560098" class="dsq-comment-body">
<div id="dsq-comment-message-1560098" class="dsq-comment-message"><p>It's one feature I guess I use a lot less now that I only really ever use my fingerprint to unlock my phone. It was a great help on the Nexus 5 though. </p>
<p>I thought this was fixed ages ago. </p>
</div>
</div>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-1560100">
<div id="dsq-comment-header-1560100" class="dsq-comment-header">
<cite id="dsq-cite-1560100">
<span id="dsq-author-user-1560100">Jordan L</span>
</cite>
</div>
<div id="dsq-comment-body-1560100" class="dsq-comment-body">
<div id="dsq-comment-message-1560100" class="dsq-comment-message"><p>YES! this feature tends to not work for me.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1560102">
<div id="dsq-comment-header-1560102" class="dsq-comment-header">
<cite id="dsq-cite-1560102">
<span id="dsq-author-user-1560102">Anunnaki</span>
</cite>
</div>
<div id="dsq-comment-body-1560102" class="dsq-comment-body">
<div id="dsq-comment-message-1560102" class="dsq-comment-message"><p>This is a standard templated reply. Does not at all mean they're really looking into it.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-1560104">
<div id="dsq-comment-header-1560104" class="dsq-comment-header">
<cite id="dsq-cite-1560104">
<span id="dsq-author-user-1560104">Ryne Hager</span>
</cite>
</div>
<div id="dsq-comment-body-1560104" class="dsq-comment-body">
<div id="dsq-comment-message-1560104" class="dsq-comment-message"><p>It could be, but from what I've seen with posts on the Google Forums, if they say they are reaching out to users over email, they usually are. But yeah, who knows how much attention it may actually be getting.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-1560116">
<div id="dsq-comment-header-1560116" class="dsq-comment-header">
<cite id="dsq-cite-1560116">
<span id="dsq-author-user-1560116">Jason Bell</span>
</cite>
</div>
<div id="dsq-comment-body-1560116" class="dsq-comment-body">
<div id="dsq-comment-message-1560116" class="dsq-comment-message"><p>I'm the OP on that thread. Way back in November, they replied with something similar and they DID reach out to people for bug reports. Fortunately it's been working for me lately so they have not reached out to me this time. So based on past experience, I'd say it's legit.</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-1560106">
<div id="dsq-comment-header-1560106" class="dsq-comment-header">
<cite id="dsq-cite-1560106">
<span id="dsq-author-user-1560106">boop</span>
</cite>
</div>
<div id="dsq-comment-body-1560106" class="dsq-comment-body">
<div id="dsq-comment-message-1560106" class="dsq-comment-message"><p>Funny, it just started working perfectly fine recently.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1560107">
<div id="dsq-comment-header-1560107" class="dsq-comment-header">
<cite id="dsq-cite-1560107">
<a id="dsq-author-user-1560107" href="http://www.blogger.com/profile/09558823023162268203" target="_blank" rel="nofollow">givitumibeybi</a>
</cite>
</div>
<div id="dsq-comment-body-1560107" class="dsq-comment-body">
<div id="dsq-comment-message-1560107" class="dsq-comment-message"><p>David Foster left his chair on Google. Are you gonna write an article about it?</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-1560120">
<div id="dsq-comment-header-1560120" class="dsq-comment-header">
<cite id="dsq-cite-1560120">
<span id="dsq-author-user-1560120">Ryne Hager</span>
</cite>
</div>
<div id="dsq-comment-body-1560120" class="dsq-comment-body">
<div id="dsq-comment-message-1560120" class="dsq-comment-message"><p>Unfortunately other than reporting he's gone, there isn't much more we could really add to the story. We don't know why, and since he joined after the Pixel was already announced we don't really even know what exactly he did. So we could do something, but it wouldn't really be useful news. </p>
<p>Now if David Foster <em>Wallace</em> had left a physical chair somewhere on the Google campus, I'd be all over that.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-1560130">
<div id="dsq-comment-header-1560130" class="dsq-comment-header">
<cite id="dsq-cite-1560130">
<span id="dsq-author-user-1560130">Suicide_Note</span>
</cite>
</div>
<div id="dsq-comment-body-1560130" class="dsq-comment-body">
<div id="dsq-comment-message-1560130" class="dsq-comment-message"><p>David who??</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-1560111">
<div id="dsq-comment-header-1560111" class="dsq-comment-header">
<cite id="dsq-cite-1560111">
<span id="dsq-author-user-1560111">4Ui812</span>
</cite>
</div>
<div id="dsq-comment-body-1560111" class="dsq-comment-body">
<div id="dsq-comment-message-1560111" class="dsq-comment-message"><p>We need a complete list of all the problems currently plaguing Google. Then maybe we can identify and rectify the issues 😉.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1560113">
<div id="dsq-comment-header-1560113" class="dsq-comment-header">
<cite id="dsq-cite-1560113">
<span id="dsq-author-user-1560113">George</span>
</cite>
</div>
<div id="dsq-comment-body-1560113" class="dsq-comment-body">
<div id="dsq-comment-message-1560113" class="dsq-comment-message"><p>How come it seems like Google can't get their shit together lately...</p>
</div>
</div>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-1560114">
<div id="dsq-comment-header-1560114" class="dsq-comment-header">
<cite id="dsq-cite-1560114">
<span id="dsq-author-user-1560114">dcdttu</span>
</cite>
</div>
<div id="dsq-comment-body-1560114" class="dsq-comment-body">
<div id="dsq-comment-message-1560114" class="dsq-comment-message"><p>This hasn't worked on my phone since my Nexus 5. I've submitted numerous bug reports on it. About time!</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1560119">
<div id="dsq-comment-header-1560119" class="dsq-comment-header">
<cite id="dsq-cite-1560119">
<span id="dsq-author-user-1560119">Trooper311</span>
</cite>
</div>
<div id="dsq-comment-body-1560119" class="dsq-comment-body">
<div id="dsq-comment-message-1560119" class="dsq-comment-message"><p>This is great news. I have not had any problems with it of late but have had it stop working in the past. Glad to see it is going to be addressed!</p>
</div>
</div>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-1560121">
<div id="dsq-comment-header-1560121" class="dsq-comment-header">
<cite id="dsq-cite-1560121">
<span id="dsq-author-user-1560121">JSo</span>
</cite>
</div>
<div id="dsq-comment-body-1560121" class="dsq-comment-body">
<div id="dsq-comment-message-1560121" class="dsq-comment-message"><p>Haven't had any real issues with this. The only bug I have noticed is that my work location doesn't show up in the list anymore even though I have both my work and home set in Google Maps. I just add a custom one for work. Not a huge deal</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-1560125">
<div id="dsq-comment-header-1560125" class="dsq-comment-header">
<cite id="dsq-cite-1560125">
<a id="dsq-author-user-1560125" href="http://www.simplefilmreviews.com/" target="_blank" rel="nofollow">Borgman</a>
</cite>
</div>
<div id="dsq-comment-body-1560125" class="dsq-comment-body">
<div id="dsq-comment-message-1560125" class="dsq-comment-message"><p>I wish it would read my home wifi as a trusted place</p>
</div>
</div>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-1560126">
<div id="dsq-comment-header-1560126" class="dsq-comment-header">
<cite id="dsq-cite-1560126">
<a id="dsq-author-user-1560126" href="http://kennected.blogspot.com/" target="_blank" rel="nofollow">KENNECTED</a>
</cite>
</div>
<div id="dsq-comment-body-1560126" class="dsq-comment-body">
<div id="dsq-comment-message-1560126" class="dsq-comment-message"><p>I've been having issues. Glad they are being addressed as inside my apartment I don't want to enter a code to open my phone.</p>
</div>
</div>
</li> 
</ul>
</div>
</div>
<script type="text/javascript">
var disqus_url = 'http://androidpolice.com/2017/04/27/google-looking-longstanding-issues-smart-locks-trusted-places-feature/';
var disqus_identifier = '421365 https://www.androidpolice.com/?p=421365';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'androidpolice';
var disqus_title = "Google is looking into longstanding issues with Smart Lock's Trusted Places feature";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=421365';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
</section>
</div>
</div>
</div>
<style>@media only screen and (max-width: 767px) {.ad-footer{//margin-bottom: 20px;margin-left:-20px;margin-right:-20px;}}</style>
<center>
<div class="ad-footer">
<script type="text/javascript">
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - responsive_1 */
google_ad_slot = "9424709618";
//-->
if (window.matchMedia("(max-width: 767px)").matches) {
  if (window.matchMedia("(min-width: 728px)").matches) {
    <!--
    google_ad_width = 728;
    google_ad_height = 90;
    //-->
    } else if (window.matchMedia("(min-width: 336px)").matches) {
    <!--
    google_ad_width = 336;
    google_ad_height = 280;
    //-->
    } else if (window.matchMedia("(min-width: 300px)").matches) {
    <!--
    google_ad_width = 300;
    google_ad_height = 250;
    //-->
  }

  document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}

</script>
</div>
</center>
</div> 
<div id="sbar" class="secondary column">
<ul id="sbar-content" class="list-unstyled">
<li id="execphp-6" class="widget-1 widget-first widget-odd  none widget widget_execphp"> <div class="execphpwidget"><style>#execphp-6>.execphpwidget{padding:0;text-align:center;}</style>
<script type="text/javascript">
if (window.matchMedia("(min-width: 768px)").matches) {
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - 300x250_sidebar_1 */
google_ad_slot = "1402978658";
google_ad_width = 300;
google_ad_height = 250;
//-->

document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}
</script></div>
</li>
<li id="apfollowwidget-2" class="widget-2 widget-even red widget ap-follow-widget"><header class="section-header"><h4 class="header-bg">Follow Android Police</h4></header>
<section class="card">
<div class="card-inner">
<div class="multi-column"> <div class="one-third">
<a class="ap-follow-btn" title="+1 Android Police on Google+" class="" href="https://plus.google.com/+AndroidPolice/" target="_blank">
<div class="ap-follow-icon google-plus-color"><i class="icon-google-plus"></i></div>
<span class="ap-sidebar-title">1.5M</span>
</a>
</div>
<div class="one-third">
<a class="ap-follow-btn" title="Follow Android Police on Twitter" class="" href="https://twitter.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon twitter-color"><i class="icon-twitter"></i></div>
<span class="ap-sidebar-title">466k</span>
</a>
</div>
<div class="one-third">
<a class="ap-follow-btn" title="Like Android Police on Facebook" class="" href="https://facebook.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon facebook-color"><i class="icon-facebook"></i></div>
<span class="ap-sidebar-title">142k</span>
</a>
</div>
</div><div class="multi-column"> <div class="one-third">
<a class="ap-follow-btn" title="Subscribe on YouTube" class="" href="https://youtube.com/AndroidPolice" target="_blank">
<div class="ap-follow-icon youtube-color"><i class="icon-youtube"></i></div>
<span class="ap-sidebar-title">111k</span>
</a>
</div>
</div>
</div>
<div class="card-action">
<a class="currents ap-follow-btn" title="Subscribe to the RSS feed" class="" href="/feed" target="_blank">
<div class="ap-follow-icon rss-color"><i class="icon-feed"></i></div>
</a>
<a class="currents ap-follow-btn" title="Read on Google Play Newsstand" href="https://www.google.com/producer/editions/CAowu5gU/androidpolice" target="_blank">
<div class="ap-follow-icon newsstand-color"><i class="icon-newsstand"></i></div>
</a>
<a class="pushbullet-subscribe-widget fl-right" data-channel="androidpolicefeed" data-widget="button" data-size="large"></a>
</div>
</section>
</li>
<li id="execphp-7" class="widget-3 widget-odd  none widget widget_execphp"> <div class="execphpwidget"><style>#execphp-7>.execphpwidget{padding:0;text-align:center;}</style>
<script type="text/javascript">
if (window.matchMedia("(min-width: 768px)").matches) {
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - 300x250_sidebar_2 */
google_ad_slot = "2879686538";
google_ad_width = 300;
google_ad_height = 600;
//-->

document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}
</script></div>
</li>
<li id="aprecentpostswidget-2" class="widget-4 widget-even green widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Latest Deals</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/27/deal-alert-bose-quietcomfort-25-25-225-amazon-ebay/#comments">14</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-20" style="width:21.866860123813%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/27/deal-alert-bose-quietcomfort-25-25-225-amazon-ebay/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_deal-bose-qc25-ebay-728x281.png&w=60&h=60">
<div class="cell-content">
<h4>[Deal Alert] Bose QuietComfort 25 down 25% to $225 on Amazon and eBay</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/27 5:19am PDT</time><time class="timeago" datetime="2017-04-27T05:19:08-07:00">Apr 27, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/deal-alert-get-verizonunlocked-galaxy-s8-warranty-just-699-99-56-off-reputable-ebay-seller/#comments">14</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:32.190543703583%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/deal-alert-get-verizonunlocked-galaxy-s8-warranty-just-699-99-56-off-reputable-ebay-seller/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_Screen-Shot-2017-04-26-at-6.10.59-PM-728x295.png&w=60&h=60">
<div class="cell-content">
<h4>[Deal Alert] Get a Verizon/unlocked Galaxy S8 with warranty for just $699.99 ($56 off) from a reputable eBay seller</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 3:46pm PDT</time><time class="timeago" datetime="2017-04-26T15:46:10-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/deal-alert-23-temporarily-free-2-cheap-18-sale-apps-wednesday/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:52.770112063801%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/deal-alert-23-temporarily-free-2-cheap-18-sale-apps-wednesday/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F01%2Fnexus2cee_apps-01-1-728x400.png&w=60&h=60">
<div class="cell-content">
<h4>[Deal Alert] Here are 23 temporarily free, 2 cheap, and 18 on-sale apps for your Wednesday</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 3:44pm PDT</time><time class="timeago" datetime="2017-04-26T15:44:35-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/deal-alert-best-buy-16gb-moto-g4-plus-160-deal-day-90-off/#comments">25</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.846928430917%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/deal-alert-best-buy-16gb-moto-g4-plus-160-deal-day-90-off/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_DA-G4-BB-hero-728x552.png&w=60&h=60">
<div class="cell-content">
<h4>[Update: eBay too] Deal Alert: Best Buy has the 16GB Moto G4 Plus for $160 in its Deal of the Day ($90 off)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 1:18pm PDT</time><time class="timeago" datetime="2017-04-26T13:18:28-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/24/deal-alert-get-75-sony-led-uhd-android-tv-best-buy-2150-today-650-off/#comments">38</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-90" style="width:94.006437429194%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/24/deal-alert-get-75-sony-led-uhd-android-tv-best-buy-2150-today-650-off/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_DA-BB-TV-hero-728x285.png&w=60&h=60">
<div class="cell-content">
<h4>[Update: Now it's cheaper] Deal Alert: Get a 75" Sony LED UHD Android TV from Best Buy for $2150 today ($650 off)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/24 7:35pm PDT</time><time class="timeago" datetime="2017-04-24T19:35:35-07:00">Apr 24, 2017</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="execphp-5" class="widget-5 widget-odd  none widget widget_execphp"> <div class="execphpwidget"><style>#execphp-5>.execphpwidget{padding:0;text-align:center;}</style>
<script type="text/javascript">
if (window.matchMedia("(min-width: 768px)").matches) {
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - 300x250_sidebar_3 */
google_ad_slot = "3019439258";
google_ad_width = 300;
google_ad_height = 250;
//-->

document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}
</script></div>
</li>
<li id="wpb_widget-3" class="widget-6 widget-even blue widget widget_wpb_widget"><header class="section-header"><h4 class="header-bg">Latest Poll</h4></header><section class="ap-sbar-widget-wrapper"><div id="polls-354" class="wp-polls">
<form id="polls_form_354" class="wp-polls-form" action="/index.php" method="post">
<p style="display: none;"><input type="hidden" id="poll_354_nonce" name="wp-polls-nonce" value="0e182b1083"/></p>
<p style="display: none;"><input type="hidden" name="poll_id" value="354"/></p>
<p style="text-align: center;"><strong>Inbox or Gmail?</strong></p><div id="polls-354-ans" class="wp-polls-ans"><ul class="wp-polls-ul">
<li><input type="radio" id="poll-answer-1797" name="poll_354" value="1797"/> <label for="poll-answer-1797">Gmail</label></li>
<li><input type="radio" id="poll-answer-1798" name="poll_354" value="1798"/> <label for="poll-answer-1798">Inbox</label></li>
<li><input type="radio" id="poll-answer-1799" name="poll_354" value="1799"/> <label for="poll-answer-1799">Both</label></li>
<li><input type="radio" id="poll-answer-1800" name="poll_354" value="1800"/> <label for="poll-answer-1800">Neither</label></li>
</ul><p style="text-align: center;"><input type="button" name="vote" value="   Vote   " class="Buttons" onclick="poll_vote(354);"/></p><p style="text-align: center;"><a href="#ViewPollResults" onclick="poll_result(354); return false;" title="View Results Of This Poll">View Results</a></p></div>
</form>
</div>
<div id="polls-354-loading" class="wp-polls-loading"><img src="http://www.androidpolice.com/wp-content/plugins/wp-polls/images/loading.gif" width="16" height="16" alt="Loading ..." title="Loading ..." class="wp-polls-image"/>&nbsp;Loading ...</div>
<div class="center"><p><a href="http://www.androidpolice.com/2017/04/16/weekend-poll-inbox-or-gmail/" class="primary-btn btn-widget"> Discuss This Poll</a></p></div></section></li>
<li id="execphp-4" class="widget-7 widget-odd  none widget widget_execphp"> <div class="execphpwidget"><style>#execphp-4>.execphpwidget{padding:0;text-align:center;}</style>
<script type="text/javascript">
if (window.matchMedia("(min-width: 768px)").matches) {
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - 300x250_sidebar_4 */
google_ad_slot = "7729068338";
google_ad_width = 300;
google_ad_height = 600;
//-->

document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}
</script></div>
</li>
<li id="aprecentpostswidget-3" class="widget-8 widget-even teal widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Recent Reviews</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/22/sonos-playbase-review/#comments">50</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-70" style="width:68.634336057541%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/22/sonos-playbase-review/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_DSC_0134-728x485.jpg&w=60&h=60">
<div class="cell-content">
<h4>Sonos Playbase review: The speaker to rule the living room</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/22 8:00am PDT</time><time class="timeago" datetime="2017-04-22T08:00:43-07:00">Apr 22, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/22/synology-diskstation-ds416play-review-cloud-personal-servers-can-cool-feature-filled/#comments">29</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:53.326375101521%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/22/synology-diskstation-ds416play-review-cloud-personal-servers-can-cool-feature-filled/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_synology-ds416play-728x432.png&w=60&h=60">
<div class="cell-content">
<h4>Synology DiskStation DS416play review: Cloud who? Personal servers can be cool and feature-filled too</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/22 6:30am PDT</time><time class="timeago" datetime="2017-04-22T06:30:28-07:00">Apr 22, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/19/synology-rt2600ac-review/#comments">28</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:47.515572298046%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/19/synology-rt2600ac-review/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_DSC_0115-728x485.jpg&w=60&h=60">
<div class="cell-content">
<h4>Synology RT2600AC review: A beast disguised as a router</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/19 10:55am PDT</time><time class="timeago" datetime="2017-04-19T10:55:03-07:00">Apr 19, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/18/galaxy-s8-and-s8-review-another-pair-of-excellent-mainstream-smartphones-from-samsung/#comments">443</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:98.365650579094%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/18/galaxy-s8-and-s8-review-another-pair-of-excellent-mainstream-smartphones-from-samsung/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_DSC07267-01-01-01_thumb-1.jpg&w=60&h=60">
<div class="cell-content">
<h4>Galaxy S8 and S8+ review: Another pair of excellent mainstream smartphones from Samsung</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/18 7:59am PDT</time><time class="timeago" datetime="2017-04-18T07:59:53-07:00">Apr 18, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/15/fitbit-alta-hr-review-compromising-features-slim-profile-7-day-battery-life/#comments">23</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:30.753368010978%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/15/fitbit-alta-hr-review-compromising-features-slim-profile-7-day-battery-life/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_fitbit-altahr-1-728x461.png&w=60&h=60">
<div class="cell-content">
<h4>Fitbit Alta HR review: Compromising features for a slim profile and 7-day battery life</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/15 4:00am PDT</time><time class="timeago" datetime="2017-04-15T04:00:13-07:00">Apr 15, 2017</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="aprecentpostswidget-5" class="widget-9 widget-odd red widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Latest Roundups</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/25/22-new-notable-android-games-last-week-41917-42517/#comments">7</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-50" style="width:46.290346273958%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/25/22-new-notable-android-games-last-week-41917-42517/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60">
<div class="cell-content">
<h4>22 new and notable Android games from the last week (4/19/17 - 4/25/17)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/25 6:29pm PDT</time><time class="timeago" datetime="2017-04-25T18:29:32-07:00">Apr 25, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/24/11-new-notable-android-apps-last-week-41817-42417/#comments">0</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-60" style="width:64.379388170792%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/24/11-new-notable-android-apps-last-week-41817-42417/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_apps-01.png&w=60&h=60">
<div class="cell-content">
<h4>11 new and notable Android apps from the last week (4/18/17 - 4/24/17)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/24 1:15pm PDT</time><time class="timeago" datetime="2017-04-24T13:15:09-07:00">Apr 24, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/18/17-new-notable-1-wtf-android-games-last-week-41217-41817/#comments">11</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:28.742887547154%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/18/17-new-notable-1-wtf-android-games-last-week-41217-41817/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60">
<div class="cell-content">
<h4>17 new and notable (and 1 WTF) Android games from the last week (4/12/17 - 4/18/17)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/18 5:29pm PDT</time><time class="timeago" datetime="2017-04-18T17:29:44-07:00">Apr 18, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/17/11-new-notable-android-apps-last-week-41117-41717/#comments">19</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-70" style="width:69.789107898081%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/17/11-new-notable-android-apps-last-week-41117-41717/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_apps-01.png&w=60&h=60">
<div class="cell-content">
<h4>11 new and notable Android apps from the last week (4/11/17 - 4/17/17)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/17 7:02pm PDT</time><time class="timeago" datetime="2017-04-17T19:02:00-07:00">Apr 17, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/11/19-new-notable-android-games-last-week-4417-41117/#comments">5</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-40" style="width:36.308391782836%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/11/19-new-notable-android-games-last-week-4417-41117/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F02%2Fnexus2cee_games-02_thumb-2.png&w=60&h=60">
<div class="cell-content">
<h4>19 new and notable Android games from the last week (4/4/17 - 4/11/17)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/11 3:45pm PDT</time><time class="timeago" datetime="2017-04-11T15:45:40-07:00">Apr 11, 2017</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="aprecentpostswidget-4" class="widget-10 widget-even blue widget apRecentPostsWidget"><header class="section-header"><h4 class="header-bg">Recent Apps and Games</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/27/replying-messages-android-auto-broken-hangouts-isnt-installed-google-case/#comments">0</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/27/replying-messages-android-auto-broken-hangouts-isnt-installed-google-case/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F11%2Fnexus2cee_facebook-android-auto-728x387.png&w=60&h=60">
<div class="cell-content">
<h4>Replying to messages in Android Auto is broken for some if Hangouts isn't installed, Google is on the case</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/27 9:28am PDT</time><time class="timeago" datetime="2017-04-27T09:28:20-07:00">Apr 27, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/27/now-anyone-can-create-google-classroom/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-70" style="width:66.175596847389%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/27/now-anyone-can-create-google-classroom/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_google-classroom-creat-728x363.png&w=60&h=60">
<div class="cell-content">
<h4>Now anyone can create a Google Classroom</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/27 6:45am PDT</time><time class="timeago" datetime="2017-04-27T06:45:18-07:00">Apr 27, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/27/facebook-testing-floating-button-suggested-videos/#comments">10</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-20" style="width:21.974527792128%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/27/facebook-testing-floating-button-suggested-videos/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_facbeook-fab-suggested-videos-728x295.png&w=60&h=60">
<div class="cell-content">
<h4>Facebook is testing a floating button for suggested videos</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/27 5:45am PDT</time><time class="timeago" datetime="2017-04-27T05:45:38-07:00">Apr 27, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/google-talkback-5-2-beta-speech-verbosity-settings-select-speak/#comments">5</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-30" style="width:30.937408945201%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/google-talkback-5-2-beta-speech-verbosity-settings-select-speak/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_hero_thumb-14.png&w=60&h=60">
<div class="cell-content">
<h4>Google TalkBack 5.2 is out of beta with speech verbosity settings, Select to Speak, and more</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 6:28pm PDT</time><time class="timeago" datetime="2017-04-26T18:28:07-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/google-photos-v2-14-is-preparing-personalized-experiences-and-sharing-suggestions-based-around-facial-recognition-apk-teardown/#comments">43</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-80" style="width:78.603752319804%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/google-photos-v2-14-is-preparing-personalized-experiences-and-sharing-suggestions-based-around-facial-recognition-apk-teardown/">
<img class="cell-thumb" src="https://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_photos_thumb-1.png&w=60&h=60">
<div class="cell-content">
<h4>Google Photos v2.14 is preparing personalized experiences and sharing suggestions based around facial recognition [APK Teardown]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 5:08pm PDT</time><time class="timeago" datetime="2017-04-26T17:08:57-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li></ul></section></li>
<li id="apblastfromthepast-2" class="widget-11 widget-last widget-odd widget ap-blast-from-past"><header class="section-header"><h4 class="header-bg">Blast from the Past</h4></header><section><ul class="post-list list-unstyled">
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2016/04/27/evleaks-says-htc-is-building-two-nexuses-m1-and-s1-and-we-think-theyre-codenamed-marlin-and-sailfish/#comments">296</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999395787662%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2016/04/27/evleaks-says-htc-is-building-two-nexuses-m1-and-s1-and-we-think-theyre-codenamed-marlin-and-sailfish/">
<h3 class="ap-sidebar-title"><span>1 Year Ago</span> Today</h3>
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F04%2Fnexus2cee_Pacific-sailfish_thumb.jpg&w=60&h=60">
<div class="cell-content">
<h4>Evleaks Says HTC Is Building Two Nexuses - M1 And S1 - And We Think They're Codenamed Marlin And Sailfish</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2016/04/27 11:45am PDT</time><time class="timeago" datetime="2016-04-27T11:45:08-07:00">Apr 27, 2016</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2015/04/27/googles-desktop-search-also-lets-you-set-an-alarm-or-send-a-note-to-your-phone/#comments">83</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-90" style="width:92.132269733899%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2015/04/27/googles-desktop-search-also-lets-you-set-an-alarm-or-send-a-note-to-your-phone/">
<h3 class="ap-sidebar-title"><span>2 Years Ago</span> Today</h3>
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2015%2F04%2Fnexus2cee_google-logo-stock-150x150.png&w=60&h=60">
<div class="cell-content">
<h4>[Update: Set A Reminder As Well] Google's Desktop Search Also Lets You Set An Alarm Or Send A Note To Your Phone</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2015/04/27 1:00am PDT</time><time class="timeago" datetime="2015-04-27T01:00:24-07:00">Apr 27, 2015</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2014/04/27/solid-explorer-updated-with-limited-work-around-for-kitkat-sd-card-restrictions-on-samsung-devices/#comments">51</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2014/04/27/solid-explorer-updated-with-limited-work-around-for-kitkat-sd-card-restrictions-on-samsung-devices/">
<h3 class="ap-sidebar-title"><span>3 Years Ago</span> Today</h3>
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2014%2F04%2Fnexusae0_unnamed_thumb18.png&w=60&h=60">
<div class="cell-content">
<h4>Solid Explorer Updated With Limited Work-Around For KitKat SD Card Restrictions On Samsung Devices</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2014/04/27 3:30pm PDT</time><time class="timeago" datetime="2014-04-27T15:30:00-07:00">Apr 27, 2014</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2013/04/27/asus-transformer-pad-300-3g-tf300tg-currently-getting-its-android-4-2-1-update-full-rom-download-already-available/#comments">6</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2013/04/27/asus-transformer-pad-300-3g-tf300tg-currently-getting-its-android-4-2-1-update-full-rom-download-already-available/">
<h3 class="ap-sidebar-title"><span>4 Years Ago</span> Today</h3>
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2013%2F04%2Fnexusae0_perfection-tf300_thumb1.png&w=60&h=60">
<div class="cell-content">
<h4>ASUS Transformer Pad 300 3G (TF300TG) Currently Getting Its Android 4.2.1 Update, Full ROM Download Already Available</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2013/04/27 3:43pm PDT</time><time class="timeago" datetime="2013-04-27T15:43:00-07:00">Apr 27, 2013</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2012/04/27/the-android-police-podcast-episode-7-squirting-tidbits/#comments">4</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2012/04/27/the-android-police-podcast-episode-7-squirting-tidbits/">
<h3 class="ap-sidebar-title"><span>5 Years Ago</span> Today</h3>
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2012%2F04%2FAndroidPolice-logo-with-bg-242x242_thumb4.png&w=60&h=60">
<div class="cell-content">
<h4>[The Android Police Podcast] Episode 7: Squirting Tidbits</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2012/04/27 7:12pm PDT</time><time class="timeago" datetime="2012-04-27T19:12:56-07:00">Apr 27, 2012</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2011/04/27/psa-take-it-easy-att-isnt-targeting-unauthorized-android-tethering-and-may-never/#comments">31</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2011/04/27/psa-take-it-easy-att-isnt-targeting-unauthorized-android-tethering-and-may-never/">
<h3 class="ap-sidebar-title"><span>6 Years Ago</span> Today</h3>
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2011%2F04%2Fdeath-star-att_thumb.jpg&w=60&h=60">
<div class="cell-content">
<h4>PSA: Take It Easy, AT&amp;T Isn't Targeting Unauthorized Android Tethering (And May Never)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2011/04/27 10:49pm PDT</time><time class="timeago" datetime="2011-04-27T22:49:19-07:00">Apr 27, 2011</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper">
<a class="comment-btn" href="http://www.androidpolice.com/2010/04/27/htc-desire-legend-and-possibly-incredible-rooted-by-modaco-com-founder-paulobrien/#comments">0</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-10" style="width:10%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2010/04/27/htc-desire-legend-and-possibly-incredible-rooted-by-modaco-com-founder-paulobrien/">
<h3 class="ap-sidebar-title"><span>7 Years Ago</span> Today</h3>
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2010%2F04%2Fimage_thumb206.png&w=60&h=60">
<div class="cell-content">
<h4>HTC Desire, Legend, And Possibly Incredible Rooted By MoDaCo.com Founder PaulOBrien</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2010/04/27 11:31pm PDT</time><time class="timeago" datetime="2010-04-27T23:31:13-07:00">Apr 27, 2010</time></div></div>
</div>
</a>
</li></ul></section></li>
</ul>
</div> </div>
</div> 
<script type="text/javascript">
var ajaxurl = 'https://www.androidpolice.com/wordpress/wp-admin/admin-ajax.php';
var postid = 421365</script>
<style>@media only screen and (min-width: 768px) {.ad-footer-large{//margin-bottom: 20px;}}</style>
<center>
<div class="ad-footer-large">
<script type="text/javascript">
<!--
google_ad_client = "ca-pub-5262833430322012";
/* AP - responsive_1 */
google_ad_slot = "9424709618";
//-->
if (window.matchMedia("(min-width: 768px)").matches) {
  if (window.matchMedia("(min-width: 970px)").matches) {
    <!--
    google_ad_width = 970;
    google_ad_height = 250;
    //-->
    } else {
    <!--
    google_ad_width = 728;
    google_ad_height = 90;
    //-->
  }

  document.write('\x3Cscript type="text/javascript" src="//pagead2.googlesyndication.com/pagead/show_ads.js">\x3C/script>');
}

</script>
</div>
</center>
<div class="band footer">
<div class="container">
<div class="ap-hottest-content-wrapper">
<header class="section-header"><h4>What's Hot</h4></header>
<div class="one-third column alpha">
<li id="appopularposts-5" class="widget-1 widget-first widget-last widget-odd red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 24 Hours</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/deal-alert-best-buy-16gb-moto-g4-plus-160-deal-day-90-off/#comments">25</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.874528798488%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/deal-alert-best-buy-16gb-moto-g4-plus-160-deal-day-90-off/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_DA-G4-BB-hero-728x552.png&w=60&h=60">
<div class="cell-content">
<h4>[Update: eBay too] Deal Alert: Best Buy has the 16GB Moto G4 Plus for $160 in its Deal of the Day ($90 off)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 1:18pm PDT</time><time class="timeago" datetime="2017-04-26T13:18:28-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/opinion-google-fix-erratic-reminder-system/#comments">112</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:98.99345115744%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/opinion-google-fix-erratic-reminder-system/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_Featured-image-reminders-728x553.png&w=60&h=60">
<div class="cell-content">
<h4>Opinion: Google should fix its erratic reminder system</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 2:15pm PDT</time><time class="timeago" datetime="2017-04-26T14:15:08-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/google-photos-v2-14-is-preparing-personalized-experiences-and-sharing-suggestions-based-around-facial-recognition-apk-teardown/#comments">43</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-80" style="width:78.603752319804%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/google-photos-v2-14-is-preparing-personalized-experiences-and-sharing-suggestions-based-around-facial-recognition-apk-teardown/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_photos_thumb-1.png&w=60&h=60">
<div class="cell-content">
<h4>Google Photos v2.14 is preparing personalized experiences and sharing suggestions based around facial recognition [APK Teardown]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 5:08pm PDT</time><time class="timeago" datetime="2017-04-26T17:08:57-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/27/now-anyone-can-create-google-classroom/#comments">16</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-70" style="width:70.228281673181%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/27/now-anyone-can-create-google-classroom/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_google-classroom-creat-728x363.png&w=60&h=60">
<div class="cell-content">
<h4>Now anyone can create a Google Classroom</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/27 6:45am PDT</time><time class="timeago" datetime="2017-04-27T06:45:18-07:00">Apr 27, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/google-branded-wireless-headphones-show-fcc/#comments">112</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-70" style="width:68.837096808094%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/google-branded-wireless-headphones-show-fcc/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_google-headphones-hero.png&w=60&h=60">
<div class="cell-content">
<h4>[Update: Just headphones for employees] Google-branded wireless headphones show up at the FCC</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 10:28am PDT</time><time class="timeago" datetime="2017-04-26T10:28:04-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li></ul></section></li>
</div>
<div class="one-third column">
<li id="appopularposts-6" class="widget-1 widget-first widget-last widget-odd red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 7 Days</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/25/google-posts-truly-incredible-night-images-captured-pixel-nexus-6p/#comments">103</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.976134303682%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/25/google-posts-truly-incredible-night-images-captured-pixel-nexus-6p/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_image10-728x546.jpg&w=60&h=60">
<div class="cell-content">
<h4>Google posts truly incredible night images captured by the Pixel and Nexus 6P</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/25 11:28am PDT</time><time class="timeago" datetime="2017-04-25T11:28:11-07:00">Apr 25, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/21/googles-messaging-mess-money-not-making-life-easier-opinion/#comments">314</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.975112812486%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/21/googles-messaging-mess-money-not-making-life-easier-opinion/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_Screenshot_20170421-104538_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>Google's messaging mess is about money, not making your life easier (opinion)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/21 10:51am PDT</time><time class="timeago" datetime="2017-04-21T10:51:28-07:00">Apr 21, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/25/att-is-the-first-carrier-to-say-it-has-a-5g-network-which-is-complete-bullshit/#comments">138</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.927635409034%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/25/att-is-the-first-carrier-to-say-it-has-a-5g-network-which-is-complete-bullshit/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_bs_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>AT&amp;T is the first carrier to say it has a &quot;5G&quot; network, which is complete bullshit</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/25 8:54am PDT</time><time class="timeago" datetime="2017-04-25T08:54:46-07:00">Apr 25, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/google-app-7-1-beta-is-testing-a-search-bar-in-the-notification-panel-and-may-begin-showing-pollen-counts-apk-teardown/#comments">51</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.882508270867%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/google-app-7-1-beta-is-testing-a-search-bar-in-the-notification-panel-and-may-begin-showing-pollen-counts-apk-teardown/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_google_thumb-1.png&w=60&h=60">
<div class="cell-content">
<h4>Google App 7.1 beta is testing a search bar in the notification panel and may begin showing pollen counts [APK Teardown]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 5:12am PDT</time><time class="timeago" datetime="2017-04-26T05:12:19-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/26/deal-alert-best-buy-16gb-moto-g4-plus-160-deal-day-90-off/#comments">25</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.874528798488%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/26/deal-alert-best-buy-16gb-moto-g4-plus-160-deal-day-90-off/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_DA-G4-BB-hero-728x552.png&w=60&h=60">
<div class="cell-content">
<h4>[Update: eBay too] Deal Alert: Best Buy has the 16GB Moto G4 Plus for $160 in its Deal of the Day ($90 off)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/26 1:18pm PDT</time><time class="timeago" datetime="2017-04-26T13:18:28-07:00">Apr 26, 2017</time></div></div>
</div>
</a>
</li></ul></section></li>
</div>
<div class="one-third column omega">
<li id="appopularposts-9" class="widget-1 widget-first widget-last widget-odd red widget ap-popular-posts"><h3 class="ap-pp-heading">Last 30 Days</h3><section><ul class="post-list list-unstyled">
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/19/apps-services-will-work-google-home-continuously-updated/#comments">259</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.999895294459%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/19/apps-services-will-work-google-home-continuously-updated/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2016%2F10%2Fnexus2cee_ap_resize-2-728x410.png&w=60&h=60">
<div class="cell-content">
<h4>These are all the apps and services that will work with Google Home [Continuously Updated]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/19 10:15am PDT</time><time class="timeago" datetime="2017-04-19T10:15:41-07:00">Apr 19, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/12/google-photos-v2-13-adds-video-stabilization-hints-at-possible-google-integration-apk-download-teardown/#comments">97</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.99895457024%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/12/google-photos-v2-13-adds-video-stabilization-hints-at-possible-google-integration-apk-download-teardown/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_photos_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>Google Photos v2.13 adds video stabilization, hints at possible Google+ integration [APK Download + Teardown]</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/12 4:09am PDT</time><time class="timeago" datetime="2017-04-12T04:09:55-07:00">Apr 12, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/25/google-posts-truly-incredible-night-images-captured-pixel-nexus-6p/#comments">103</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.976134303682%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/25/google-posts-truly-incredible-night-images-captured-pixel-nexus-6p/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_image10-728x546.jpg&w=60&h=60">
<div class="cell-content">
<h4>Google posts truly incredible night images captured by the Pixel and Nexus 6P</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/25 11:28am PDT</time><time class="timeago" datetime="2017-04-25T11:28:11-07:00">Apr 25, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/21/googles-messaging-mess-money-not-making-life-easier-opinion/#comments">314</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.975112812486%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/21/googles-messaging-mess-money-not-making-life-easier-opinion/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=https%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_Screenshot_20170421-104538_thumb.png&w=60&h=60">
<div class="cell-content">
<h4>Google's messaging mess is about money, not making your life easier (opinion)</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/21 10:51am PDT</time><time class="timeago" datetime="2017-04-21T10:51:28-07:00">Apr 21, 2017</time></div></div>
</div>
</a>
</li>
<li class="cell-wrapper cell-small list-item">
<a class="comment-btn" href="http://www.androidpolice.com/2017/04/14/google-assistant-screen-search-button/#comments">79</a>
<div class="post-hotness-meter">
<div class="hotness ap-hotness-100" style="width:99.965185713209%;"></div>
</div>
<a class="cell-link" href="http://www.androidpolice.com/2017/04/14/google-assistant-screen-search-button/">
<img class="cell-thumb" src="http://www.androidpolice.com/wp-content/themes/ap2/ap_resize/ap_resize.php?src=http%3A%2F%2Fwww.androidpolice.com%2Fwp-content%2Fuploads%2F2017%2F04%2Fnexus2cee_new-assistant-ui.png&w=60&h=60">
<div class="cell-content">
<h4>Google Assistant's screen search has been moved to a button</h4>
<div class="post-meta"><div class="post-date-time"><i class="icon-calendar"></i><time class="timeago-hover">2017/04/14 9:02am PDT</time><time class="timeago" datetime="2017-04-14T09:02:10-07:00">Apr 14, 2017</time></div></div>
</div>
</a>
</li></ul></section></li>
</div>
</div>
<div class="sixteen columns">
</div>
<div class="sixteen columns ">
<div class="footer-notes">
<div id='footer_signature'>
Notice a bug? <a target="_blank" href="https://github.com/archon810/androidpolice-public/issues">Let us know here.</a><br/>
Link monetization by <a target="_blank" href="http://skimlinks.com">Skimlinks</a>
<span class="footer-break">
<a href="http://www.androidpolice.com/androidpolice-com-privacy-policy/">Privacy Policy</a>
| <a href="http://www.androidpolice.com/dmca-copyright-infringement-notification/">DMCA Disclaimer</a>
| <a href="http://www.androidpolice.com/about/">About</a>
| <a href="http://www.androidpolice.com/advertise/">Advertise</a>
| <a href="http://www.androidpolice.com/contact/">Contact</a><br/></span>
116 queries | 0.580s | hive <span class="footer-break">
Android is a trademark of Google Inc. | &copy; Illogical Robot LLC, 2009-2017 </span>
</div> 
</div>
</div>
</div>
</div>
 
<script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'androidpolice';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/plugins/ap-hotness/assets/js/aph-pvc.js?ver=1.0'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201717'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tocplus = {"smooth_scroll":"1","smooth_scroll_offset":"10"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=1509'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.androidpolice.com\/wordpress\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.73.2'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/plugins/wp-gfycat/js/gfycat_test_.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/jquery.easing.1.3.js?ver=1.7'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/socialite.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/nivo-lightbox.js?ver=1460096262'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/jRespond.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/mousetrap/mousetrap.min.js?ver=1.4.6'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/jquery.timeago.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/jquery.flexslider.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/jquery.countTo.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/ap.single.js?ver=1488350966'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wp-content/themes/ap2/js/waypoints-combined.min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.androidpolice.com/wordpress/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201717.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.8.2',blog:'12245754',post:'421365',tz:'-7',srv:'www.androidpolice.com'} ]);
	_stq.push([ 'clickTrackerInit', '12245754', '421365' ]);
</script>
<script type="text/javascript">
	var templateDir = "http://www.androidpolice.com/wp-content/themes/ap2";
  var ajaxurl = "https://www.androidpolice.com/wordpress/wp-admin/admin-ajax.php";
  var blogurl = "http://www.androidpolice.com";
</script>
 
<script type="text/javascript">(function(){var a=document.createElement('script');a.type='text/javascript';a.async=true;a.src='https://widget.pushbullet.com/dynamic.js';var b=document.getElementsByTagName('script')[0];b.parentNode.insertBefore(a,b);})();</script>
 
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
<script type="text/javascript" src="http://www.androidpolice.com/wp-content/themes/ap2/js/tablepress.search-fix.js"></script>
 
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=651&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>
 
 
<script type="text/javascript" src="//ado.pro-market.net/ads/scripts/site-130167.js"></script>
 
 
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-95hmrIiT9zWMo"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-95hmrIiT9zWMo.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
 
 
<img src="http://b.scorecardresearch.com/p?c1=2&c2=15235859&cv=2.0&cj=1"/>
 
<script src="https://apis.google.com/js/platform.js" async defer></script>
 
<script type="text/javascript" src="//s.skimresources.com/js/85009X1537243.skimlinks.js"></script>
 
</body>
</html>
 