11
Nov
mic

Have you noticed that sometimes your Nexus 5 reverts to the old Ice Cream Sandwich-style pop-up for voice dictation in some apps, as opposed to the less disruptive "endless dictation" on-the-keyboard style? You're not alone. Our fearless leader Artem found that his N5's microphone icon was missing from the default keyboard, and using contextual mic icons (in search boxes and other places) caused the aforesaid behavior. It was also affecting third-party keyboards like SwiftKey.

As it turns out, at least some Nexus devices and updates are being sent out with the "Google voice typing" option disabled in the Language and Input menu. This doesn't actually disable voice typing, at least within those apps that use a microphone icon to allow users to speak search queries and other text fields, but it does cause some of the inconsistent behavior noted above. Observe:

Google voice typing disabled (default). No microphone on Google keyboard, Ice Cream Sandwich-style pop-up, also seen in SwiftKey on the Nexus 5.

Screenshot_2013-11-11-01-46-49 Screenshot_2013-11-11-01-47-25 Screenshot_2013-11-11-01-47-44 Screenshot_2013-11-11-01-48-39

Google voice typing enabled. Microphone button returns to Google keyboard, dictation appears on the keyboard area, SwiftKey works correctly.

Screenshot_2013-11-11-01-52-31 Screenshot_2013-11-11-01-50-14 Screenshot_2013-11-11-01-49-17 Screenshot_2013-11-11-01-49-57

We have no idea why Google voice typing is disabled on some phones, or exactly which devices have it turned off by default - my stock Nexus 7 2013, for example, seems to have had it enabled since I bought it, but at least one stock Nexus 4 has it disabled by default. This isn't a bug, per se, just a strange design decision. If you're not fond of the floating dictation button or inconsistent UI touches, just dive into the Settings menu and enable the voice typing option.

Jeremiah Rice
Jeremiah is a US-based blogger who bought a Nexus One the day it came out and never looked back. In his spare time he watches Star Trek, cooks eggs, and completely fails to write novels.
  • anmolm97

    I want my Nexus 5 :'(

  • http://ashutoshmishra.org/ Ashutosh Mishra

    this is not the Jeremiah Rice you looking for

    this is not the Jeremiah Rice you're looking for

    this is not the Jeremiah Rice you were looking for

    this is not the Jeremiah Rice your looking for

    this is not the Jeremiah Rice you are looking for

  • awesome

    Hmm..

  • Kenny O

    Funny, I actually stumbled on this when I was enabling Swiftkey.

  • Brad Durandetta

    I'm pretty sure this is a bug, just because the microphone button was initially on the keyboard and then it disappeared. This seemed to happen to me after viewing input settings for the first time (I reset my device a few times to try to find out the cause). On my Nexus 4, voice typing is disabled by default, as the article states, but this doesn't seem to affect the microphone button.

    • http://www.androidpolice.com/ Artem Russakovskii

      There are multiple microphone buttons we may be talking about. The one on the keyboard and the one apps put up in or next to search bars.

  • jonathan3579

    Thank you. I was trying to figure out why voice to text sucked ass while I was driving the other day and this explains it.

  • scuttlefield

    THANK YOU, THANKS YOU, THANK YOU! For the last 24 hours of so, I've be trying to figure out what happend to my microphone icon. I couldn't, for the life of me, figure it out. I'm so glad that Android Police has got my back. (A good side effect of this problem, though, is that it finally pushed me into using SwiftKey.)

    • http://www.androidpolice.com/ Artem Russakovskii

      Hey, not a bad way to live.

  • Jef Cashless

    Thank you!!! This was bugging the living )*@& outta me!!!

  • http://www.androidpolice.com/author/pamela-hill/ Pamela Hill

    Huh, mine is unchecked in both N4 & N7, but I have no trouble with voice dictation in Google Now. I didn't notice the icon missing in the keyboard, because I use Swype and it uses Dragon, which works great. I'm not sure if I need to check the box or not. It says "automatic" under it, and I'm puzzled by what that means.

    • http://www.androidpolice.com/ Artem Russakovskii

      Yeah, apps that put up their own mics have voice input work just fine. Doesn't make much sense, does it?

    • Lookatthemonkeys

      Mine was unchecked, but google now works fine, it was just when I tried to voice dictate using the microphone button on the keyboard it wouldnt work correctly. It was driving me crazy!

  • MLBaylor

    TIL people dont actually explore the options on their own phones

  • Cesar

    This actually helped me in the reverse. I prefer to have the comma key on the keyboard instead of hidden behind the period key, and I never use voice typing outside of Google Now, so having Google voice typing turned off is the preferred setup for me. I just didn't know that turning voice typing off would change the microphone icon to a comma. Thanks AP!

    • Whyzor

      I don't use voice typing very often, but would like it for the rare occasion (without having to go into settings to enable it). But I also like the comma key. I remember it used to be a long-hold of the comma key, but this doesn't seem available in KitKat Nexus 5, it's either comma key or voice key.

      • n5user

        You can always hold down on the "." (period) key and you'll get a comma within less than a second. It's convenient. Having the voice enabled and the comma just behind the period is working great for me.

  • Walkop

    Now my microphone is back and I can be happy again.

    Sent using Google Voice typing.

  • HC

    Awesome thanks ive been trying to figure this out

  • http://blog.tonysarju.com/ Tony Sarju

    Thank you very much for this tip. I had noticed it disabled once before and re-enabled it on my Nexus 5. Then I tried to use voice typing the other day and was faced with that popup asking me to select from a series of suggested dictations which I've never seen before. Just checked and it was disabled again, I think it disabled after SwiftKey updated again on my device. I enabled it again and now all is well.

  • Roh_Mish

    Mine never got disabled.

  • Lookatthemonkeys

    Thank you Thank you Thank you! I thought this was a problem with Swiftkey and it was driving me crazy!

  • Michael Benesch

    4.4 on the optimus g also had it disabled for me, but I had gone through the settings right after I installed the ROM and changed it so didn't see the issue.

  • http://www.modminecraft.com/ Nick Coad

    Nexus 5 here, mine was never disabled.

  • Chris

    Sigh... two more weeks

  • bL4Ck

    Disabled by default on my Nexus 5, probably depends on your region? Mine is the italian version.

  • Eric Jones

    I came across this "feature" mentioned on Google+, and checked my keyboard in the same app they had screenshot, hangouts. I had the button, and no issues with voice typing. A couple of days later, I went to use voice typing, and the mic button was gone from the stock keyboard. Mine was on, and then was disabled, so I think something else is going on.

    • sdcoiner76

      This happened to me also. There have been lots of little things like this happen. I had to clear all of my permissions because Google+ became a default program to share with and I could not figure out which app to clear the permissions for.

  • Kamal

    Thanks. My Nexus 5 had this disabled by default. Google voice recognition is very good now. I am from India and my accent is not american, but it did a good job of voice to text conversion. I have been using "OK Google" a lot with my N5.

  • Bouffard

    I had this issue, I dont use swifkey, when I set it to default I still dont have it as default icon its still the , I have to long hold on the , and it gives me the microphone, is there a way to change this to move the , to a second page or something?

  • BRCeDDie

    I've been looking for 30 minutes and you solved my question! Thanks Jeremiah for posting this.