Hordes of excited Google+ users trying to get the new v4.0 update of their favorite Android app were puzzled this morning when their devices running Ice Cream Sandwich and Jelly Bean were suddenly listed as incompatible. Numerous "WAT?!"s were exclaimed and heart attacks had, but don't worry, Google isn't canning Google+.

image

As you can see, the reason your devices are incompatible is simple - the Google+ team set the app compatibility to just Froyo and Gingerbread. As we suspected, it's just a temporary glitch - a Google+ engineer and Vic Gundotra already confirmed that the company is aware of the problem caused by a faulty manifest and is working on a fix:

image image

So sit tight, folks. You'll have your 4.0 update soon.

Update 12:50pm PT: Looks like it's fixed. Go grab your v4.0 update now:

image

More: +AndroidPolice