02
Nov
1
Last Updated: November 3rd, 2012

Earlier this week, we posted the slightly unfinished Android 4.2 keyboard with Swype-like gesture typing and pretty blue glow (which we since took down at Google's request). Thanks to the recent Android 4.2 system dump from the Nexus 4, some new goodies are now available for pre-4.2 versions of Android. Namely the release version of the keyboard and the new Clock app that Ron is already in love with.

4.2kb1 Screenshot_2012-11-02-13-21-08 Screenshot_2012-11-02-13-21-23

Recognized XDA developer Gnufabio snagged each of the aforementioned apps, porting the keyboard to Android 4.0+ devices and the clock to 4.1. At this point, the only known to the developer issue is with the layout of the clock, where the stopwatch notification isn't displaying correctly. The dev noted on his site that this problem can't be corrected until apktool is updated to support Android 4.2.

Screenshot_2012-11-02-09-24-32 Screenshot_2012-11-02-09-25-52 Screenshot_2012-11-02-09-26-01 Screenshot_2012-11-02-09-26-17

Artem took both the keyboard and the clock out for a spin on an EVO LTE running CM10. Both of them installed in addition to the existing keyboard and clock, so getting rid of them is a matter of a simple uninstall via TitaniumBackup. The keyboard worked flawlessly, though at first it made the existing 4.1 keyboard crash. The dev reportedly fixed the crash and updated the download link, but if it still happens to you, just freeze it with TitaniumBackup and use the new keyboard.

The clock did work for the most part, but it did crash upon clicking the Alarms button and then proceeded to crash randomly while in the background. When Artem reported the issue to the developer, he learned that the crashes were not observed on a Galaxy Nexus, so your mileage may vary. Either way, you can experience the new clock in all its gorgeous glory and uninstall if it doesn't satisfy you 100%.

Update: We got the clock to stop crashing randomly by freezing/uninstalling the old clock. However, the Alarms functionality still didn't work. To fix that, uninstall (but make sure to back it up first) the old clock and then rename the new one in /system/DeskClockGoogle.apk to /system/DeskClock.apk. Reboot for good measure and enjoy the now 100% working clock with alarms. We also reported it to the developer, so it's possible he will update the flashable zip accordingly and make this process unnecessary:

Screenshot_2012-11-03-14-08-27

Disclaimer: Android Police isn't responsible for any harm to your device - proceed at your own risk.

For more info, see the source link below.

Source: Gnufabio

Cameron Summerson
Cameron is a self-made geek, Android enthusiast, horror movie fanatic, musician, and cyclist. When he's not pounding keys here at AP, you can find him spending time with his wife and kids, plucking away on the 6-string, spinning on the streets, or watching The Texas Chainsaw Massacre on repeat.

  • Marc

    Can't wait to go to 4.2 on my Galaxy Nexus! I just don't want to root! :(

    • Tito

      rooting is the best thing you could ever do...

    • John

      You on Verizon? If so, you'll be waiting quite a hwhile.

      • Marc

        I've a unlocked phone the GSM version which recieves updates as fast as possible, but I had problems with rooting on my old HTC Desire and I think the phone is just great as it it already. I'll wait untill the 4.2 comes out and I can enjoy everything at once! :)

        • Andrew Ruffolo

          Then you don't have to wait. You can do this all with an unlocked bootloader and not messing with the stock recovery (which means you will still get updates from google when they happen). If you didn't unlock your bootloader, you will lose your info. If you already unlocked your bootloader, you can download adb, fastboot and clockworkmod recovery, place them all in a folder and boot into a custom recovery without flashing it to your phone (fastboot boot recovery.img).

    • Aleksey_US

      If you have a non GSM version you'll have to wait a while... ROOT FTW! loving my new camera app by the way ;)

      • http://www.facebook.com/profile.php?id=1745689461 Hal Motley

        With Photo Sphere, apparently panoramas are really insane now.

    • http://www.facebook.com/profile.php?id=1745689461 Hal Motley

      If you already have a Nexus device and you are on AP, wouldn't that suggest that you aren't afraid to get your feet wet in the world of Android hacking and development?

    • http://twitter.com/redbullcat Phil Oakley

      Why not? Rooting opens you up to so many possibilities :)

  • Petunia

    I just looooooooove Android Police :)

    • Petunia

      I am sorry, Polish friends, but it only works in US English... Still fabulous.

  • whargharbl

    Is this keyboard APK a newer version of the one posted before? From the screenshots, both the world following your finger and the gesture trial look slightly different.

    • http://www.androidpolice.com/ Artem Russakovskii

      Yeah, it's newer, which is why we posted it :P

      Clarified it just in case.

  • Isidhu

    Cant wait for 4.2 on the GNex but till then batter make use of root permissions. Already running new gmail and camera app(which btw is awesomeeee)

  • Matthew King

    Wow, the clock app is gorgeous!

  • ozzy

    So much MIUI goodies coming to AOSP... ironic.

    • Bariman43

      That's not what irony means, but yeah. The benefits of an open-source system is you can implement features that aren't in stock AOSP. Eventually, if they're good enough ideas, they go official.

  • http://cassidyjames.com Cassidy James

    Woo! My Nexus S is getting more Nexus 4-like every day! :P I now have the new camera, gallery, keyboard, clock, Google Now, and wallpapers.

    • Alex Fiorani

      hahaha I can say the same about mine, all 4.2 stuff is already on it. By the way, the photo sphere (although a little slow) makes some damn pretty panoramas.

  • Łukasz Zając

    Love the clock!

  • Plerisei

    'm going to start calling my phone, "Hybrid" cause, you know, she like a disciple of the kingdom, able to bring out treasures both old and new
    LOL

  • Danny Holyoake

    Could someone get a video up of the new clock app?

  • Genetic_Bloom

    It force closes for me when going into the alarms menu on the new clock. :/

    • http://www.facebook.com/profile.php?id=759910421 Luiz Mattos

      Mine was force closing when i tapped the alarm menu until I disabled the old clock app. Now I can get to the alarm menu but it force closes when I try to tap the + to create an alarm. Oh well, hope that gets ironed out soon.

      • Chuck Testa

        Clear data of the Alarm App in App settings. Worked for me twice.

      • http://www.androidpolice.com/ Artem Russakovskii

        It was doing that until I renamed it from DeskClockGoogle.apk to DeskClock.apk. Then Alarms started to work.

    • Invision

      rename the new app with the old app name and everything works!

      • tylerbrainerd

        I can second this. Use a root file manager, rename, and clear data and reboot.

  • GazaIan

    Keep following AndroidPolice and we'll have Android 4.2's source code before it's even released

  • Saurav

    Can I have the keyboard as apk? The new one?

  • schmaltzy

    Have you guys seen the new "alarms" part of the clock? It is damn sexy! Swipe to delete an alarm, tap to extend alarm settings! I have a semi over this! LOL

    • Ian Santopietro

      TMI

      • KreeTerry

        Too many informations?

    • http://www.androidpolice.com/ Artem Russakovskii

      It crashes on my EVO LTE, so I didn't see it. :(

      • redsmith

        Have you tried uninstalling the old Clock app? I did just that and voila, no more crashes when opening Alarms.

        HTC Desire on JB 4.1.1 ROM

        • Antonio

          Thank you.

        • http://www.androidpolice.com/ Artem Russakovskii

          That fixed the random crashes, but alarms still didn't work. See the update in the post for the full fix.

    • Jelmer Borst

      Yeah, sexy as hell!

  • coversnails

    Why is the first number in the clock and stopwath so much bigger and bolder than the others? It disagrees with me a bit, symetrical ocd I guess :p

    • http://www.facebook.com/profile.php?id=1745689461 Hal Motley

      I guess on the stopwatch the minutes section is the most important part because it gives you best idea how long it has been running. Is the hour section bold too?

      • coversnails

        It kind of makes sense for the stopwatch to have the most important number in bold, no idea why they do the same for the regular clock though, makes no sense to me

  • Alex

    Just flashed the keyboard and its perfect, now I will uninstall Swype since I don't need it anymore.
    All languages are available. I haven't uninstalled or freezed the stock keyboard and I'm not getting any FCs. I'm on latest CM10 nightly, and my device is a Nexus S

  • Guest

    flashed the clock---but there's no Digital one in the Widgets section; missing something?

  • Tony

    Do you guys know you can also find the new Gallery/Camera app apk online already too? It's cool but not able to get the 3D mode working.

  • Nathan S.

    Anyone try this on a ICS rom on the Tmo GS2?

    • WatSon9000

      The keyboard and clock widget should work, but clock app probably needs Jelly Bean.

  • http://www.facebook.com/horriblekitten Anthony Luis Gonzalez

    Need the keyboard apk please not gonna root. I have the one you guys posted before works great but this new one would be good too.

    • http://www.facebook.com/profile.php?id=1745689461 Hal Motley

      Wouldn't you need root to replace it anyway? Why the phobia of root anyway? As long as you have SuperUser/SuperSU and you are careful about who gets the root permissions you are fine.

      • http://www.facebook.com/horriblekitten Anthony Luis Gonzalez

        I just don't like the idea can't I uninstall the first one I side loaded the side load this new one?

        • http://www.facebook.com/profile.php?id=1745689461 Hal Motley

          You could probably install 2 clock apps, one is the system app that came with the OS and the other is the app you installed as a standard app. No root, no fuss...

          But 2 clock apps! XD

  • Liam Cobb

    Wow, the new clock is damn sexy.

  • Ben Baranovsky

    They both work great along with the camera update. So amazing! Thanks so much.

    EDIT: You may need to delete the old .apk files from /system/app before flashing the .zip files. It didn't work for me a few times after they originally worked. Curious. Very curious.

    Galaxy Nexus GSM, Rooted, CWM Recovery.

  • http://blog.ravrahn.net/ Owen Cassidy

    It looks like they've just taken the app Timer, and implemented it as part of the clock app, which is awesome because it's a brilliant app!

  • Sanjay

    I have flashed it and the keyboard installed fine. But whenever I try to swype on the keyboard, it force closes. It works fine for non-swype input. I'm using Hauwei G300 running Infusion ROM.

  • http://www.facebook.com/profile.php?id=1745689461 Hal Motley

    I think I'll wait until I get Android 4.2, either via CM10/11 or a by convincing someone to buy me a Nexus 4 (preferably 32GB). Thanks for providing us with a link to the APK though.

    I am glad that Google finally got the clock app pretty much how I wanted it, though iOS have had this for years and we are still missing a World Clock function. Something to look forward to in CM perhaps...

    Does that mean the Clock app here as lost the famous Android nightstand mode for good now though>?

    • niv

      actully, the new clock app does have a world clock option. notice the little "location" pin below the clock in the clock section? and as i saw, both in the screenshot above and another website that there is an android nightstand mode. i also saw you can change the daydream action (screensaver) to have photos, clock, colors (dont know what that means) and most importantly- flying jelly beans :-)

  • tjennhw

    Any Mirrors?

    • tjennhw

      nvrmnd. It's working.

  • Ryde2004

    I was so looking forward to this, but for some reason when I tried to flash through CWM, nothing seems to happen. :(. I'm on a stock 4.0.3 on a Galaxy S2, but with Dorimanx Kernel (and hence also CWM) I had the previous APK installed. I since uninstalled it...but when I flash, there is no "android keyboard" that appears.

    Any help?

  • bikerbill12

    Can't get it to display digital on my home screen on my gnex . Only analog but when I press it it shows it in digital . Any trick or help or is it natural fir that ?

  • http://twitter.com/AHHSom Im Real

    getting random crashing on keyboard when i try to delete words or single type word

  • MAINEVENT23

    I'm using this and some of the buttons don't match their action. Pressing the Mic is a backspace... etc. Anyone else experiencing this on the keyboard?

  • PaulMaddux

    Clock works. Sorta. It'll let me into the app but alarm settings fc me. However, the keyboard is super smooth and so far fairly accurate.

    • http://www.androidpolice.com/ Artem Russakovskii

      See the update about the alarm.

  • Jeffery yuan

    Anyone has idea how to install it? - it is a zip file :)

    • http://www.androidpolice.com/ Artem Russakovskii

      It's flashable in recovery.

  • Zak Taccardi

    running a sprint gnex with cm10, the clock crashes but the gesture typing works great!

    I still prefer swype though, the gesture typing keyboard doesn't let you swype apostrophes - so "we'll" and "well" have the same trace - a dealbreaker for me

  • raashid

    i tried this on my Nexus S(i9023) both the keyboard and the clock work perfectly fine...thanks a lot...time to make my friends jealous..:D

  • http://www.androidpolice.com/ Artem Russakovskii

    Update: We got the clock to stop crashing randomly by freezing/uninstalling the old clock. However, the Alarms functionality still didn't work. To fix that, uninstall (but make sure to back it up first) the old clock and then rename the new one in /system/DeskClockGoogle.apk to /system/DeskClock.apk. Reboot for good measure and enjoy the now 100% working clock with alarms. We also reported it to the developer, so it's possible he will update the flashable zip accordingly and make this process unnecessary.

    See the updated post for the Alarms screenshot.

  • arthur

    You can just disable old clock if you're getting force close message

  • Brian(aka brianzion) Carr

    love the disclaimer android icon

  • http://twitter.com/GnuFabio Fabio

    Just updated the packages, now they should work for everyone.

  • Gav456

    I had the same alarm clock issues, but uninstalling the original fixed it, been running smooth since (didn't have to rename it)

    • Jelmer Borst

      Yeah that works too but many prefer to keep the old one as a backup

  • Jelmer Borst

    I was wondering though, would it be possible to use gestured based typing on the new keyboard in languages other than English? BTW it works very well and makes sure that typing is so much faster whilst doing this only with one thumb

  • xliquidaznx

    Did you mean to say /system/app?

  • http://www.facebook.com/profile.php?id=100000338649747 Omario Amriky

    AFTER INSTALLATION CLEAR CACHE AND DALVIK IN RECOVERY AND CACHE AND DATA IN APP SETTINGS.

  • http://ramonnavarro.tumblr.com Ramon Navarro

    Any Android 4.2 keyboard love, for non-rooted Samsung Galaxy S3 owners?

  • Anonymous

    It may also help to clear data of the DeskClock app before rebooting.

  • matiasmorris

    I installed the new clock apk on cyanogenmod 10 on my S2. At first, the app crashed when trying to access Alarms. I couldn't use the "uninstall-rename" solution because I only had one clock apk (the new one) at the system folder. The solution was using the "wipe data" function on Titanium Backup. Now it works like charm. Thanks AP!

    • http://www.facebook.com/profile.php?id=100000003999549 Mike Harris

      Thank you for sharing that solution. I had the same problem and that fixed it.

    • ondra

      It wipe data only for the clock or all data from phone?sorry,but I dont use Titanium so dont know about this feature...

    • mattdonders

      Thank you SO much - I didn't even think of this. All fixed for me now.

  • Samuels
  • Samm

    The fix worked perfect for me, thanks!

    Verizon GNex

  • rider8

    Hey guys, even the updated keyboard I still cant flash through CWM. Its weird though, the loading bar is all sorts of colors..

    Rooted on an S2 with stock ROM..
    When I flash nothing seems to happen, though it shows in system/apps.

    Thanks for any help!

  • jolek78

    why path suggested is system/ and not /system/app/ ?

  • Sony miro

    Why clock doesn't work on 4.0.4 just 4.1+ ?

  • http://www.facebook.com/MorrisSEX Javier Cárdenas

    Not working on Xperia Neo V, Xperia Ultimate HD ROM.

  • Daniel Serke

    Am I correct in assuming that the 4.2 clock only includes an analog clock widget?

  • http://www.facebook.com/frankzermeno Frank Zermeño

    It's system/app/... not just system/... - at least this is true for the Galaxy Nexus. Just in case some weren't aware.

  • LewisSD

    This is why I check AP daily! Thanks for the fix on the alarms!

  • ondra

    Flashed the v2 version on my Blade with CM10-everything is working,but when I want change alarm get FC´s :(

  • Guest

    If alarm crashes, "force stop" the clock and clear data.. Alarm works fine.. tried on galaxy nexus.

    • khaled

      thank u so much, been driving me crazy since I downloaded it.

  • Piyush

    Had some issues with the older version of keyboard (unfinished product). Now we see the updated release version by Gnufabio, but it's not an easily installable apk file anymore for non-stock android platforms. Could someone make an apk out of this without the need of flashing?

  • xenothaulus

    4.2's clock and lock screens are the ugliest things I have seen in a UI in a long, long time. Thanks, Google.

  • H.d.modi

    hey guys please help me i am not able to download this file.
    the server returns reporting an error
    i request you guys that anyone who has this zip file with you then please email me this file at hitsunmodi@gmail.com
    it would be greatful if anyone can email me this file.
    Please email.

  • Luke H

    I don't see a download link anywhere? I tried the source link, but it was dead. Nothing is there. I may be an idiot, but can someone point me to the download link for the keyboard?

Quantcast