Here's a bit of good news for anyone with an unrooted Motorola device - the root method released earlier today by Dan Rosenberg for the Xyboard/Xoom 2 should actually work on any Moto device that's running Gingerbread or Honeycomb. The direct quote, from Dan himself:

The Droid 4 root ("Motofail") should work on all Gingerbread Motorola devices that I know of. The just-released XYBoard root ("XYZ") should root all Gingerbread and Honeycomb Motorola devices. Both Motofail and XYZ rely on the same vulnerability, but the XYBoard had an additional hurdle in place that required me to exploit a second bug in order to trigger the first one.

The newest exploit only adds one step to its predecessor, essentially making the first one superfluous. Thus, anyone looking to gain root on a modern Motorola device should go straight for XYZ to make it happen.

Here's a list of the most popular devices that this method should work on:

  • Droid 4
  • Droid RAZR/MAXX
  • RAZR (International)
  • Droid Bionic
  • Droid 3
  • Droid 2/Global
  • Droid Pro
  • Droid X2
  • Droid X
  • Milestone X
  • Atrix
  • Atrix 2
  • Defy
  • Defy+
  • Admiral
  • Photon 4G
  • Electrify
  • Xyboard
  • Xoom
  • Xoom 2
  • ...etc

If your device isn't on the list but is running Gingerbread, then go ahead and give it a shot - this method should cover the gamut of Moto devices.

To grab the download, head over to Dan's site, Vulfactory.org.

Cameron Summerson
Cameron is a self-made geek, Android enthusiast, horror movie fanatic, musician, and cyclist. When he's not pounding keys here at AP, you can find him spending time with his wife and kids, plucking away on the 6-string, spinning on the streets, or watching The Texas Chainsaw Massacre on repeat.


    Awesome!!! I donated to the bounty last week for the Motofail exploit and love the quick method to root my Bionic running the latest OTA. Wish so many people hadn't taken exception to the reverse bounty last weekend -- this dev is doing a great service and deserves thanks and praise!!

    • rockstar323

      Yeah, it's sad that some people complained about the reverse bounty and just expect devs to give stuff away for free. I donated and I own a Nexus.

  • http://www.facebook.com/civility614 Mike H

    Did not work on the motorola Xoom Family Edition. Sadly. Willl this thing ever see a crack?

    • http://www.AndroidPolice.com Artem Russakovskii

      You're running Honeycomb on that, right? I wonder why it didn't work. Pinged Dan about this.

  • Dark

    I tried it on my Atrix running 2.3.6, but unfortunately it failed. Ended up using the fastboot method to regain root.

    • Dark

      I didn't realize that the method was updated from the original motofail to xyz because it needed to exploit another vulnerability. So I unrooted and tried the exploit and it still failed.

      • http://www.AndroidPolice.com Artem Russakovskii

        Dark, I will put you in touch with Dan to take a look. Thanks for flagging this.

        • iHAP_zone

          Any luck on the Atrix rooting -- "fs is Read-only" when copying to

  • Herach

    Did not work on my Bionic running 2.3.4 5.9.902. It keeps buzzing and the screen is stock on (This may take a few minutes, don't mind the buzzing) and doesn't go any further. How long does it take to do this?

    • Troy

      Did it ever finally work? Mine's been looping through the vibration cycle and sitting at the "This may take a few minutes" screen for about 1 minutes now. Bionic with 2.3.4 5.9.902 as well.

      • Troy

        Er that should have said 10 minutes....

        • Herach

          Nope. It did not. same situation. over 15min on buzzing screen.

        • Herach

          Go to XDA-developers and look for (R3L3AS3DRoot and 43V3R root for the BIONIC v2.1) forum and go to the last page. There is a link for motofail root. It worked for me.

  • NateTheDuck

    I would love an exploit root for my LTE Xoom (3.2.6) to avoid wiping data. However, this doesn't seem to work at all for me. The script just waits at the phase 1 "don't mind the buzzing" step indefinitely... and I don't hear a buzzing noise. Perhaps I'm doing something wrong.

  • yaron

    Won't work for my UK 3g XOOM (MZ601). just hangs on during phase1 for ever.

    Any idea?


  • CrazyAndro

    Downloaded the xyboard utility from Dan's blog and unzipped it. I know i need to run the. bat file, but not sure abt the use of other files in the zipped folder. Can someone post a short step by step tutorial on how to use this. I dnt want to get stuck up in between and brick my phone.

    I m using Motorola Fire XT530 (also called Motorola Domino) running on Android 2.3.4.

  • CrazyAndro

    I tried it on my Motorola Fire XT530 (Motorola Domino+) running on Android 2.3.4.

    It started as ---- "Initiating Phase 1..... This may take a few minutes dont mind the buzzing.

    But my handset is just buzzing since an hour. Please help me out. Is it safe to disconnect my handset from the laptop, as the process is still on and it is still buzzing.
    Please help urgently....

  • Kevin Sebesky

    Tried rooting my Xoom Wi-Fi using the XYBoard utility but it hangs on "This may take a few minutes, don't mind the buzzing."

    No progress, and no buzzing at all. It just sits there doing nothing, like a fat girl at a sorority mixer.

  • Michael

    mine has been buzzing for an hour as well.. help please

  • VenttAtrix

    I had some kind of doubt about using this, mainly because all of the comments below about Bionics,Dominos etc been stuck on buzzing screen.
    But ultimately I decided to try it out on my Atrix 4g, unfortunately it didnt work but at least I wasn't stuck at any screen.

  • Phibernaut

    Fails on the Droid 3 - hangs during first phase. Motofail works correctly (and surprisingly fast) on the latest 906 firmware. Thank you!

  • Phibernaut

    Fails on the Droid 3 - hangs during first phase. Motofail works correctly (and surprisingly fast) on the latest 906 firmware. Thank you!