03
Aug
evo_2.2

This is exactly why I love Android so much and the awesome developer community around it. Case in point: the official  Android 2.2 update for the EVO 4G has already been rooted by netarchy over at XDA-Devs. Yea – the update that was just released yesterday… pretty impressive stuff. Be forewarned, though – the update may not play nice with the previous (non-final) update that was released.

Full instructions:

You might be able to just flash this over the leaked ota, but I advise doing a full wipe before flashing just to be safe.

MD5 Sums:
f11ac5b0cc1548c722f8df32440a312a - HTC-OTA-3.26.651.6-Final-Froyo-Rooted-Odexed-netarchy-signed.zip
a3d42bf93dce2977748b90d5084d1b44 - Wimax26023.zip
85c7f0e31c66c80397dcc3cece0f5c76 - Radio-2.15.00.07.28.zip

HTC OTA Froyo 2.2, *FINAL*, build 3.36.651.6 (Rooted) Odexed

Mirror 1

Mirror 2

And the updated radios:

Radio update: 2.15.00.07.28

Wimax Update 26023

Flash these radios one at a time in recovery, you will have to reboot once for each one.

evo_2.2

Awesome work guys, as usual!

[Source: XDA-Devs]

Aaron Gingrich
Aaron is a geek who has always had a passion for technology. When not working or writing, he can be found spending time with his family, playing a game, or watching a movie.

  • cherven

    I have a few concern with the new software update, don't know if it's just me or the phone itself.I used to have swipe keyboard on my HTC Evo when I had the 2.1 work flawlessly but now, with the new update 2.2 froyo, my swipe keyboard completely stop. I still can used the keyboard method by typing but not swipe my fingers across the screen. If anybody know what's the cause of it can you please let me know. I'm so used to swipe it seem like I'm malfunction without it

    • http://www.exstatica.net Andrew

      I had that problem, I unselected it on the input method and then selected it again, that fixed mine. It seems to happen every once in a while.

  • cherven

    Thank you Ok I'm gonna go try it

  • cherven

    @Andrew I try everything even configured the phone im still getting nothing its the same error as it was I even turn the phone off. Im still gitting this error stated. The swipe package you installed is configured for another device and will operate with limited functionality.please contact swype

    • Androidfloyd

      I had the same problem. Just uninstall then re install swype.

  • Bill H

    Tried install and it gives the signature fail line and aborts

    • John

      Just select the "toggle signature verification" option and you should be fine.

    • John

      That is if you're using a custom recovery. If you're in stock recovery and you get this, it probably means you're updating from an unsupported version (i.e. .3 or Eclair)

  • Tony

    So if you updated with the unofficial leaked 2.2 you still can't root?

    • John

      You have to find a way to update to the official first, then root this way.

  • RAFAEL

    HOW DO I INSTALL IT? I GET A RED TRIANGLE W/A EXVCLAMATION MARK

    • John

      Hold power and Volume Up together when you get the triangle. Mash it a few times and it should go away.

  • Mike

    Glad there's a root already. I'm running the leaked 2.2 version. Am very very new to Android. I've tried unsuccessfully to do this rooted version. Any help greatly appreciated. I'd be more then happy to paypal anyone for there help in walking me thru this. Not sure if I can post my email here.

  • Will Nelson

    Is there a more detailed instruction set somewhere for this? Sorry, kinda new to the full root process.

  • Bill H

    Everything works great except I have no HDMI out. Any ideas??

    • Aaron Gingrich

      Odd. Did it work before?

Quantcast